Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Não consigo instalar o avant-window-navigator.
04/07/2010, 12:29
Resposta: #1
Não consigo instalar o avant-window-navigator.
Olá,

Fiquei em dúvida se postava isso no fórum novatos ou aqui mesmo porque tô usando Debian faz dois dias. Mas o problema é software:

Tô tentando instalar o avant-window-navigator (https://launchpad.net/awn) e nos repositórios do Debian eu posso baixar a versão 0.2 mas o problema é que preciso da 0.4 porque o awn-extras (https://launchpad.net/awn-extras) exige essa versão.

Mas por sua vez, o avant-window-navigator 0.4 tá exigindo um tal de libdesktop-agnostic (https://launchpad.net/libdesktop-agnostic) e o libdesktop-agnostic tá exigindo:

dpkg-checkbuilddeps: Unmet build dependencies: debhelper (>= 7.0.50~) valac (>= 0.7.10) gobject-introspection (>= 0.6.3) gobject-introspection-glib-2.0 gobject-introspection-freedesktop gobject-introspection-repository libgirepository1.0-dev (>= 0.6.3) libgladeui-1-dev libgconf2-dev libthunar-vfs-1-dev libgnomevfs2-dev libgnome-desktop-dev
dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.
dpkg-buildpackage: warning: (Use -d flag to override.)

Daí começa o problema, já instalei o debhelper, o valac e acabei de instalar o gobject-introspection com aqueles comandos básicos: ./configure, make e make install (tomando o cuidado de pegar versões iguais ou superiores claro). Mas ele continua exigindo as mesmas coisas.

É bem provável que eu esteja fazendo algo errado porque tô tentando montar um pacote e é a primeira vez que faço isso.

Acho que já quebrei a cabeça o suficiente tentando descobrir sozinho o problema hahah xD...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/07/2010, 13:20
Resposta: #2
Re: Não consigo instalar o avant-window-navigator.
Olá, vc está usando o Lenny e a versão 0.4 está nos repositório do squeeze, vc precisa testar se é possível instalar essa versão, isso sem quebrar o sistema, adicionando uma linha do repositório squeeze no seu sources.list e assim tentar fazer a instalação. Observe atentamente a quantidade de pacotes que vai instalar:
aptitude update
aptitude install avant-window-navigator

se der tudo certo, após instalar, comente ou retorne a linha do repositório que alterou no sources.list, para lenny novamente.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS