Responder 
 
Avaliação do Tópico:
  • 1 Votos - 5 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Iceweasel é seguro?
23/12/2011, 00:30
Resposta: #1
Iceweasel é seguro?
É seguro navegar na internet com a versão atual do Iceweasel do Debian Squeeze?

Esta é uma dúvida que tenho, pois vejo muitas atualizações no Mozilla Firefox e o Iceweasel quase não está sendo atualizado. Existe alguma preocupação do time de desenvolvedores do Debian quanto a isto? Existe alguém de olho nas questões de segurança do Iceweasel?

Desculpem tantas perguntas, mas quando o assunto é segurança na internet devemos pesquisar e perguntar.

Leonardo Laporte
Web Interface Design
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/12/2011, 07:46
Resposta: #2
RE: Iceweasel é seguro?
o iceweasel é praticamente um firefox sem os logos da mozila para atualizar voce pode fazer utilizando o repositorio de backport a versão que vem no debian se não me engano é 3.5.8 utilize os passos abaixo para atualizar

abra o terminal como root

com seu editor de texto preferido abra o sources.list em /etc/apt/sources.list

digite ou cole as seguintes linhas no arquivo

#mozilla
deb http://mozilla.debian.net/ squeeze-backports iceweasel-release

#backports
deb http://backports.debian.org/debian-backports squeeze-backports main contrib non-free
deb http://ftp.br.debian.org/debian-backports/ squeeze-backports main contrib non-free

salve o arquivo

voltando ao terminal

baixe a chave da mozilla
wget -O- -q http://mozilla.debian.net/archive.asc | gpg --import; gpg --export -a 06C4AE2A | sudo apt-key add -

ainda no terminal agora a chave do backports

gpg --keyserver hkp://subkeys.pgp.net --recv-keys 16BA136C && gpg --export 16BA136C | apt-key add -

atualize os pacotes

aptitude update

Instale o novo iceweasel

aptitude install -t squeeze-backports iceweasel


*para ficar em português BR vá nos complementos da mozila e baixe a extensão
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/12/2011, 15:33
Resposta: #3
RE: Iceweasel é seguro?
Acredito que as atualizações do Iceweasel são responsabilidade da equipe Mozilla, não da equipe Debian. De qualquer maneira, é esperado que versões mais estáveis tenham menos atualizações mesmo, por conterem menos bugs a serem fechados.

"Vamos tirar a barriga, senhor Barba? Digo..."

Debian Jessie | Usuário #517613
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/12/2011, 02:50
Resposta: #4
RE: Iceweasel é seguro?
Obrigado emanoelsq pelos esclarecimentos.

Eu pensava renatov, que o Iceweasel era de responsabilidade da equipe Debian. Mas se a Mozilla é responsável pelas atualizações do Iceweasel então por que não utilizar logo o Firefox no projeto Debian? A Mozilla não deve gostar muito de manter Iceweasel exclusivo para o Debian?

Leonardo Laporte
Web Interface Design
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/12/2011, 14:07
Resposta: #5
RE: Iceweasel é seguro?
O Iceweasel e o Firefox são a mesma coisa, é o mesmo programa com o mesmo código fonte. A única coisa que muda é o nome e o logotipo.

"Vamos tirar a barriga, senhor Barba? Digo..."

Debian Jessie | Usuário #517613
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/12/2011, 14:55
Resposta: #6
RE: Iceweasel é seguro?
Mas então, o responsável pelo Iceweasel é o Debian, e não a Mozilla Foundation.

O projeto Debian deve pegar os fontes da ultima versão do firefox e recompilar com as caracteristicas do Iceweasel.

Denis - Analista de Sistemas
Minor Soluções Web
http://www.minorsolucoes.com
*** Ganhe dinheiro na internet clicando em anúncios, conheça o Neobux ***
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/01/2012, 22:57
Resposta: #7
RE: Iceweasel é seguro?
seguro é, mas paciencia, comigo ele era muuuuuuito bugado, principalmente em relaçao ao twitter, quase nunca entrava e bugava ao descer a barra de rolagem, me irritei e fui forçado a usar os repositórios backports pra usá-lo bem, mesmo sendo em ingles Lingua
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/01/2012, 20:29
Resposta: #8
RE: Iceweasel é seguro?
Provavelmente tão seguro como qualquer outro. Usei sem problemas quando iniciei no debian mas gosto mesmo do firefox.
Coincidência ou não, na minha última instalação do wheezy, neguei suporte de rede e fiz uma instalação básica para poder praticar a ativação do gráfico no dedômetro e para minha surpresa logo após o upgrade, mesmo acrescentando o repositório padrão, o iceweasel não estava lá.
Não sei deizer que isso se deve a forma que direcionei a instalação ou simplesmente o tiraram propositalmente.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/01/2012, 14:29
Resposta: #9
RE: Iceweasel é seguro?
Acredito que é porque o navegador padrão do Debian é o Epiphany.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/01/2012, 19:41
Resposta: #10
RE: Iceweasel é seguro?
GNU matador de leoes, o notebook da minha amiga tambem tem o negocio para usar o dedo, instalei o fprint-demo no dela e era pra funcionar, verifiquei com lsusb se há suporte ao dispositivo e há sim, mas o programa fprint-demo fica escaneando procurando o dispositivo infinitamente e nao funciona Confuso como vc fez?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/01/2012, 22:03 (Resposta editada pela última vez em: 20/01/2012 16:35 por GNU matador de leoes.)
Resposta: #11
RE: Iceweasel é seguro?
Não foi autenticação digital. Alegre Eu não uso esse programa. O que eu quiz dizer é que arrumei a tela gráfica no braço. Sorrisão
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/07/2012, 10:23
Resposta: #12
RE: Iceweasel é seguro?
Estava lendo alguns textos sobre o Debian e encontrei o seguinte:

"Muitos scanners de avaliação de vulnerabilidades indicarão falso positivos quando forem usados em sistemas Debian, pois podem somente usar checagem de versões para determinar se uma determinada versão de pacote é vulnerável, mas realmente não testam a vulnerabilidade de segurança propriamente dita. Pois a Debian não muda os números de versões quando corrige um pacote (muitas vezes a correção feita em versões novas são reproduzidas nas atuais), algumas ferramentas tendem a achar que um sistema Debian atualizado está vulnerável, quando não está."

http://www.debian.org/doc/manuals/securi...pt-br.html

Acredito que apesar da versão do IceWeasel ser a 3.x o mesmo está sendo atualizado constantemente (correção de falhas) pelo time do Debian.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS