Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Configurar Internet Movel (celular como modem)
28/12/2011, 16:22 (Resposta editada pela última vez em: 28/12/2011 16:43 por Crazy Cat.)
Resposta: #1
Configurar Internet Movel (celular como modem)
Fique na dúvida se postava aqui ou em Wireless, mas acho que aqui é mais abrangente... seguinte, tenho internet no meu celular... ao conectar ele na porta usb o Debian avisa de uma conexão móvel... mas como configura isso?Hein

Eu tentei este tuto, que é para moden e OpenSusy... mas quando clico em Tim informa logo em seguida: a conexão foi encerrada! E vi que NM aparece
Banda Larga Móvel
não habilitado
............
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/12/2011, 16:53
Resposta: #2
RE: Configurar Internet Movel (celular como modem)
bom se ele reconhece seu celular com modem você pode configura uma coneção com ele para isto da uma lida neste topico
http://www.forumdebian.com.br/topico-mod...ight=modem
depois posta se consegui ou não

Jvianez
Todo Cristão é Livre use Linux e não seja Pirata.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/12/2011, 10:13
Resposta: #3
RE: Configurar Internet Movel (celular como modem)
instalei o wvdial e corri o wvdialconf com o celular espetado na usb... ele localizou como modem, fiz as config alterando oi para tim mas não deu certo... no NM continua aparecendo:
Banda Larga Móvel
não habilitado
.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/12/2011, 10:34
Resposta: #4
RE: Configurar Internet Movel (celular como modem)
mas conectou? ver se quando você execulta o wvdial conecta?

[Dialer defaults]

Modem = /dev/ttyUSB1

[Dialer three]

Init2 = ATZ
Init3 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = Analog Modem
ISDN = 0
Phone = *99***1#
Modem = /dev/ttyUSB0
username = tim
Password = tim
Dial Command = ATDT
Baud =466600
Init4 = AT+CGDCONT=1,"IP","gprs.oi.com.br" #você trouco também esta utima parte? no seu casso trocaria o "gprs.oi.com.br por "tim.br"

também de uma lida neste topico do carlos morimoto http://www.hardware.com.br/tutoriais/3g-linux/ tem um script que vai te ajuda muito

Jvianez
Todo Cristão é Livre use Linux e não seja Pirata.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/12/2011, 17:05
Resposta: #5
RE: Configurar Internet Movel (celular como modem)
Copei o texto acima, substitui gprs... por tim.br e substitui todo o conteudo do arquivo, salvei e rodei wvdial,

(gedit:11910): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyUSB1: No such file or directory
--> Cannot open /dev/ttyUSB1: No such file or directory
--> Cannot open /dev/ttyUSB1: No such file or directory
........................
zerei o arquivo e rodei novamente o wvconf para vc ver o que aparece "originalmente" no arquivo:
comando:
wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1 S2 S3
WvModem<*1>: Cannot get information for serial port.
ttyACM0<*1>: ATQ0 V1 E1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 Z -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyACM0<*1>: Modem Identifier: ATI -- Nokia
ttyACM0<*1>: Speed 4800: AT -- OK
ttyACM0<*1>: Speed 9600: AT -- OK
ttyACM0<*1>: Speed 19200: AT -- OK
ttyACM0<*1>: Speed 38400: AT -- OK
ttyACM0<*1>: Speed 57600: AT -- OK
ttyACM0<*1>: Speed 115200: AT -- OK
ttyACM0<*1>: Speed 230400: AT -- OK
ttyACM0<*1>: Speed 460800: AT -- OK
ttyACM0<*1>: Max speed is 460800; that should be safe.
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found an USB modem on /dev/ttyACM0.
Modem configuration written to /etc/wvdial.conf.
ttyACM0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
....
arquivo gerado:

[Dialer Defaults]
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
; Phone = <Target Phone Number>
ISDN = 0
; Username = <Your Login Name>
Init1 = ATZ
; Password = <Your Password>
Modem = /dev/ttyACM0
Baud = 460800
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/12/2011, 17:53
Resposta: #6
RE: Configurar Internet Movel (celular como modem)
edite novamente o arquivo o problema é que ele estava procurando na porta usb mas achou na serial no caso /dev/ttyACM0
deixa o arquivo como abaixo

[Dialer Defaults]
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
Phone = *99***1#
ISDN = 0
Username = tim
Init1 = ATZ
Password = tim
Modem = /dev/ttyACM0
Baud = 460800

e tenta conectar novamente qualque coisa posta aqui

Jvianez
Todo Cristão é Livre use Linux e não seja Pirata.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/12/2011, 19:02 (Resposta editada pela última vez em: 29/12/2011 19:03 por Crazy Cat.)
Resposta: #7
RE: Configurar Internet Movel (celular como modem)
Õpa! agora parece que achou a rede, mas não consegui navegar... veja:

--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT*99***1#
--> Waiting for carrier.
ATDT*99***1#
CONNECT
--> Carrier detected. Waiting for prompt.
~[7f]}#@!}[email protected]} }2}!}$}%\}"}&} }*} } }#}$@#oy~
--> PPP negotiation detected.
--> Starting pppd at Thu Dec 29 20:00:32 2011
--> Pid of pppd: 4xxx
--> Using interface ppp2
--> local IP address xxx.xx.x.xxx.
--> remote IP address 0.xxx.xxx.xx
--> primary DNS address 189.40.226.80
--> secondary DNS address 189.40.224.80
..................................
aí a tela ficou tremendo por uns 2 segundos... parava, depois tremia de novo... é como se ele estivesse discando...
Eu editei os ips porque não sei se é seguro publicar isso rsrsrsrs
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2011, 06:21
Resposta: #8
RE: Configurar Internet Movel (celular como modem)
quem ficou tremendo o pc ou o celular?
a conexão funcionou posta aqui também o seu arquivo /etc/network/interfaces para ver se não esta tendo problema com gateway, junto com os comandos route e ifconfig depois que fizer a conexão antes faz uma pequena alteração no seu arquivo wvdial.conf deixando como abaixo

[Dialer Defaults]
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,"ip","tim.br"
Modem Type = USB Modem
Phone = *99***1#
ISDN = 0
Username = tim
Init1 = ATZ
Password = tim
Modem = /dev/ttyACM0
Baud = 460800

Jvianez
Todo Cristão é Livre use Linux e não seja Pirata.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2011, 09:49 (Resposta editada pela última vez em: 30/12/2011 09:53 por Crazy Cat.)
Resposta: #9
RE: Configurar Internet Movel (celular como modem)
Eita! já tõ enxendo, mas estamos quase conseguindo! Cheguei mesmo a navegar pelo google e yahoo, mas daí a conexão caiu. Vamos por partes:
Arquivo interfaces: herrrr... não tenho o arquivo!!! explico: desde a época que usava Ubuntu aprendi que ao terminar o sudo pppoeconf eu poderia deletar o arquivo interfaces, pois como uso internet via rádio ele se torna inútil na inicialização (acho que é isso), inclusive toda vez que eu o deixava sem deletar o icone do NM sumia!

Tela tremuluzente (sic): é a do pc mesmo... acho que é interferência de ondas no celular x monitor;

Alteração do arquivo wvdialconf: fiz como vc falou e consegui navegar! Só tem um probleminha: só consigo fazer isso como root! Olha só como fica o terminal:
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"ip","tim.br"
AT+CGDCONT=1,"ip","tim.br"
OK
--> Modem initialized.
--> Sending: ATDT*99***1#
--> Waiting for carrier.
ATDT*99***1#
CONNECT
--> Carrier detected. Waiting for prompt.
~[7f]}#@!}!]} }2}!}$}%\}"}&} }*} } }#}$@#E!~
--> PPP negotiation detected.
--> Starting pppd at Fri Dec 30 10:32:47 2011
--> Pid of pppd: 4168
--> Using interface ppp0
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
.....................................
E fica assim no Terminal, até eu fazer um Control+C.
Até aí tudo bem, agora aconteceu de após alguns instantes navegando a conexão caiu, tentei reconectar:

--> Disconnecting at Fri Dec 30 10:32:54 2011
--> The PPP daemon has died: A modem hung up the phone (exit code = 16)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds
--> Cannot open /dev/ttyACM0: No such file or directory
--> Cannot open /dev/ttyACM0: No such file or directory
--> Cannot open /dev/ttyACM0: No such file or directory
--> Disconnecting at Fri Dec 30 10:32:54 2011
.................................................................

fui no arquivo messages e copiei as ultimas linhas referentes ao modem
Dec 30 10:32:47 xequemate pppd[4168]: pppd 2.4.5 started by root, uid 0
Dec 30 10:32:47 xequemate pppd[4168]: Using interface ppp0
Dec 30 10:32:47 xequemate pppd[4168]: Connect: ppp0 <--> /dev/ttyACM0
Dec 30 10:32:53 xequemate pppd[4168]: Remote message: PAP access OK
Dec 30 10:32:53 xequemate pppd[4168]: PAP authentication succeeded
Dec 30 10:32:53 xequemate kernel: [ 7932.749017] usb 1-6: USB disconnect, address 7
Dec 30 10:32:53 xequemate pppd[4168]: Modem hangup
Dec 30 10:32:53 xequemate pppd[4168]: Connection terminated.
Dec 30 10:32:53 xequemate pppd[4168]: Exit.
Dec 30 10:32:54 xequemate kernel: [ 7933.008055] usb 1-6: new high speed USB device using ehci_hcd and address 8
Dec 30 10:32:54 xequemate kernel: [ 7933.576099] usb 1-6: new high speed USB device using ehci_hcd and address 9
Dec 30 10:32:55 xequemate kernel: [ 7934.144060] usb 1-6: new high speed USB device using ehci_hcd and address 10
Dec 30 10:32:55 xequemate kernel: [ 7934.672082] usb 1-6: new high speed USB device using ehci_hcd and address 11
Dec 30 10:32:56 xequemate kernel: [ 7935.464050] usb 2-6: new full speed USB device using ohci_hcd and address 2
Dec 30 10:32:56 xequemate kernel: [ 7935.665408] usb 2-6: not running at top speed; connect to a high speed hub
Dec 30 10:32:56 xequemate kernel: [ 7935.683415] usb 2-6: New USB device found, idVendor=0421, idProduct=0516
Dec 30 10:32:56 xequemate kernel: [ 7935.683425] usb 2-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Dec 30 10:32:56 xequemate kernel: [ 7935.683431] usb 2-6: Product: X2-01
Dec 30 10:32:56 xequemate kernel: [ 7935.683435] usb 2-6: Manufacturer: Nokia
Dec 30 10:32:56 xequemate kernel: [ 7935.683439] usb 2-6: SerialNumber: 357410041424003
Dec 30 10:32:56 xequemate kernel: [ 7935.683643] usb 2-6: configuration #1 chosen from 1 choice
Dec 30 10:32:56 xequemate kernel: [ 7935.743481] cdc_acm 2-6:1.4: ttyACM0: USB ACM device
Dec 30 10:32:56 xequemate kernel: [ 7935.749143] usb 2-6: bad CDC descriptors
Dec 30 10:32:56 xequemate kernel: [ 7935.749339] usb 2-6: bad CDC descriptors
..

Editando: quando vc pediu para alterar o arquivo eu usei aspas (mas li em algum lugar que deveria usar dois apóstrofos), então fiquei na dúvida se fiz certo ao por apas ".
E o número da tim *99***#, o que quer dizer realmente estes asteriscos?? Eu vi que na conexão via Nokia Ovi Suite, no windows, este número aparece: *99#
Ou seja é diferente... e lá ao inves de tim.br é timbrasil.br !!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2011, 10:45
Resposta: #10
RE: Configurar Internet Movel (celular como modem)
*99***1# e *99# vai da mo mesmo e vai funcionar nas operadoras tim, vivo, oi, e claro que já testei.
Eu acho que sem as aspas não vai funcionar. em relação a fica cainda ai já é outro problema é ja é com a operadora que você usa. pode deixar o terminal aberto não é problema. quando desconecar para conectar novamente como você usar celular vai ter que desconeta-lo e conectar novamente ou roudar o wvdialconf pois provavelmente vai muda de porta mas teria que fica mudando o arquivo wvdial.conf

Jvianez
Todo Cristão é Livre use Linux e não seja Pirata.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS