Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
preciso de um source.list válido
21/06/2010, 20:42
Resposta: #1
preciso de um source.list válido
Boa noite meus caros,

Preciso de um source.list válido (debian lenny 5.0) para baixar e instalar os seguintes programas:

postgresql-8.3
postgresql-client-8.3
apache2
openjdk-6-jre
php5
php5-cli
libapache2-mod-php5
php5-gd
php5-pgsql

Se poderem me ajudar eu agradeço, sou iniciante.Obrigado!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/06/2010, 11:39
Resposta: #2
Re: preciso de um source.list válido
cara acredito q tudo esteja no repositorio padrão do debian, como esta o teu source?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/06/2010, 12:55
Resposta: #3
Re: preciso de um source.list válido
Uso este sources, acho que vai funcionar para voce.

Código:
# Mirrors Oficiais
deb ftp://ftp.br.debian.org/debian/ lenny main contrib non-free  
deb-src ftp://ftp.br.debian.org/debian/ lenny main contrib non-free

# Mirror Segurança
deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib

# Debian Multimedia
deb http://www.las.ic.unicamp.br/pub/debian-multimedia/ stable main
deb-src http://www.las.ic.unicamp.br/pub/debian-multimedia/ stable main

[Imagem: 1225_128x128.png]
Debian Linux User
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/06/2010, 12:41
Resposta: #4
Re: preciso de um source.list válido
descomente para usar o repositório backports se a versão que você quer não estiver disponível para o lenny:

Código:
# backports
#deb http://www.backports.org/debian lenny-backports main contrib non-free

"Vamos tirar a barriga, senhor Barba? Digo..."

Debian Jessie | Usuário #517613
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/07/2010, 11:28
Resposta: #5
erro ao instalar openjdk-6-jre
não consigo instalar o openjdk-6-jre, aparece o seuinte erro:

Código:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
  openjdk-6-jre: Depende: openjdk-6-jre-headless (>= 6b11-9.1+lenny2) mas não será instalado
                 Depende: libgif4 (>= 4.1.6) mas não é instalável
                 Recomenda: ttf-baekmuk mas não é instalável ou
                            ttf-unfonts mas não é instalável ou
                            ttf-unfonts-core mas não é instalável
                 Recomenda: ttf-kochi-gothic mas não é instalável ou
                            ttf-sazanami-gothic mas não é instalável
                 Recomenda: ttf-kochi-mincho mas não é instalável ou
                            ttf-sazanami-mincho mas não é instalável
                 Recomenda: ttf-arphic-uming mas não é instalável
                 Recomenda: ttf-indic-fonts mas não é instalável
E: Pacotes quebrados

segue abaixo o meu source.list.Obs:já fiz apt-get update.Espero que possam me ajudar. VAleu!

Código:
# deb cdrom:[Debian GNU/Linux 5.0.4 _Lenny_ - Official i386 CD Binary-1 20100131-18:53]/ lenny main

#deb cdrom:[Debian GNU/Linux 5.0.4 _Lenny_ - Official i386 CD Binary-1 20100131-18:53]/ lenny main

#deb http://security.debian.org/ lenny/updates main
#deb-src http://security.debian.org/ lenny/updates main

#deb http://volatile.debian.org/debian-volatile lenny/volatile main
#deb-src http://volatile.debian.org/debian-volatile lenny/volatile main

deb http://www.backports.org/debian lenny-backports main contrib non-free

# Mirrors Oficiais

deb http://ftp.br.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.br.debian.org/debian/ lenny main contrib non-free
deb http://linorg.usp.br/debian/ lenny main contrib non-free

# Mirror Segurança

deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free


# Debian Multimedia
deb http://www.las.ic.unicamp.br/pub/debian-multimedia/ stable main
deb-src http://www.las.ic.unicamp.br/pub/debian-multimedia/ stable main

deb http://security.debian.org/debian-security lenny/updates main
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/07/2010, 11:32
Resposta: #6
Re: preciso de um source.list válido
renatov Escreveu:descomente para usar o repositório backports se a versão que você quer não estiver disponível para o lenny:

Código:
# backports
#deb http://www.backports.org/debian lenny-backports main contrib non-free

não consigo instalar o openjdk-6-jre, aparece o seuinte erro:

Código:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
  openjdk-6-jre: Depende: openjdk-6-jre-headless (>= 6b11-9.1+lenny2) mas não será instalado
                 Depende: libgif4 (>= 4.1.6) mas não é instalável
                 Recomenda: ttf-baekmuk mas não é instalável ou
                            ttf-unfonts mas não é instalável ou
                            ttf-unfonts-core mas não é instalável
                 Recomenda: ttf-kochi-gothic mas não é instalável ou
                            ttf-sazanami-gothic mas não é instalável
                 Recomenda: ttf-kochi-mincho mas não é instalável ou
                            ttf-sazanami-mincho mas não é instalável
                 Recomenda: ttf-arphic-uming mas não é instalável
                 Recomenda: ttf-indic-fonts mas não é instalável
E: Pacotes quebrados

segue abaixo o meu source.list.Obs:já fiz apt-get update.Espero que possam me ajudar. VAleu!

Código:
# deb cdrom:[Debian GNU/Linux 5.0.4 _Lenny_ - Official i386 CD Binary-1 20100131-18:53]/ lenny main

#deb cdrom:[Debian GNU/Linux 5.0.4 _Lenny_ - Official i386 CD Binary-1 20100131-18:53]/ lenny main

#deb http://security.debian.org/ lenny/updates main
#deb-src http://security.debian.org/ lenny/updates main

#deb http://volatile.debian.org/debian-volatile lenny/volatile main
#deb-src http://volatile.debian.org/debian-volatile lenny/volatile main

deb http://www.backports.org/debian lenny-backports main contrib non-free

# Mirrors Oficiais

deb http://ftp.br.debian.org/debian/ lenny main contrib non-free
deb-src http://ftp.br.debian.org/debian/ lenny main contrib non-free
deb http://linorg.usp.br/debian/ lenny main contrib non-free

# Mirror Segurança

deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free


# Debian Multimedia
deb http://www.las.ic.unicamp.br/pub/debian-multimedia/ stable main
deb-src http://www.las.ic.unicamp.br/pub/debian-multimedia/ stable main

deb http://security.debian.org/debian-security lenny/updates main
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/07/2010, 18:24
Resposta: #7
Re: preciso de um source.list válido
bom cabralsan coloca saida desse comando:
Código:
#aptitude update
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/07/2010, 13:39
Resposta: #8
Re: preciso de um source.list válido
Que estranho cara, esse pacote, openjdk-6-jre-headless, está disponível nos repositórios da versão stable do lenny, sem ser preciso baixá-lo do repositório backports. O erro que você está recebendo está te falando que esse pacote não está mais disponível nos repositórios que você está usando (http://ftp.br.debian.org e linorg.usp.br), mas o pacote está disponível sim. Ao que parece, isso está sendo um problema do repositório, e não do seu computador. Tenta instalar novamente, talvez o repositório já tenha voltado ao normal. Faça o update antes de tentar.

Caso ainda não dê certo, você tem duas opções. A primeira é mudar sua lista de repositórios oficiais, para ver se os repositórios internacionais estão OK. É só comentar os dois repositórios brasileiros e adicionar esse aqui:

deb http://ftp.debian.org/debian/ lenny main contrib non-free

Outra solução seria baixar esse pacote manualmente do site:

http://packages.debian.org/lenny/openjdk-6-jre-headless

Daí você instala ele usando o comando:

Código:
#dpkg -i openjdk-6-jre-headless_6b11-9.1+lenny2_i386.deb

Fique atento porque talvez para fazer a instalação manual você precise baixar os outros pacotes que também tem dependências com o openjdk-6-jre-headless. No link que eu te passei, veja os pacotes com o sinal em vermelho, que são as dependências. Tente instalar eles pelo próprio apt-get, caso você ainda não os tenha instalados.

Qualquer dúvida, posta aí!

"Vamos tirar a barriga, senhor Barba? Digo..."

Debian Jessie | Usuário #517613
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/07/2010, 11:55
Resposta: #9
Re: preciso de um source.list válido
renatov Escreveu:Que estranho cara, esse pacote, openjdk-6-jre-headless, está disponível nos repositórios da versão stable do lenny, sem ser preciso baixá-lo do repositório backports. O erro que você está recebendo está te falando que esse pacote não está mais disponível nos repositórios que você está usando (http://ftp.br.debian.org e linorg.usp.br), mas o pacote está disponível sim. Ao que parece, isso está sendo um problema do repositório, e não do seu computador. Tenta instalar novamente, talvez o repositório já tenha voltado ao normal. Faça o update antes de tentar.

Caso ainda não dê certo, você tem duas opções. A primeira é mudar sua lista de repositórios oficiais, para ver se os repositórios internacionais estão OK. É só comentar os dois repositórios brasileiros e adicionar esse aqui:

deb http://ftp.debian.org/debian/ lenny main contrib non-free

Outra solução seria baixar esse pacote manualmente do site:

http://packages.debian.org/lenny/openjdk-6-jre-headless

Daí você instala ele usando o comando:

Código:
#dpkg -i openjdk-6-jre-headless_6b11-9.1+lenny2_i386.deb

Fique atento porque talvez para fazer a instalação manual você precise baixar os outros pacotes que também tem dependências com o openjdk-6-jre-headless. No link que eu te passei, veja os pacotes com o sinal em vermelho, que são as dependências. Tente instalar eles pelo próprio apt-get, caso você ainda não os tenha instalados.

Qualquer dúvida, posta aí!

olá meu caro, antes de mais nada obrigado pela dica...

bom, substitui os repositórios como vc mencionou, executei o comando apt-get install -f --fix-missing openjdk-6jre, ele começou a baixar suas dependencias e antes da conclusão apareceu o seguinte erro:

Código:
Obter:1003 http://ftp.de.debian.org lenny/main tzdata-java 2010j-0lenny1 [150kB]
Obter:1004 http://ftp.de.debian.org lenny/main tzdata-java 2010j-0lenny1 [150kB]
Obter:1005 http://ftp.de.debian.org lenny/main tzdata-java 2010j-0lenny1 [150kB]
Obter:1006 http://ftp.de.debian.org lenny/main x-ttcidfont-conf 31 [23,4kB]
Baixados 67,4MB em 6min32s (172kB/s)      
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-arphic-uming/ttf-arphic-uming_0.2.20080216.1-1_all.deb  Hash Sum incorreto
Falhou ao buscar http://security.debian.org/pool/updates/main/o/openjdk-6/openjdk-6-jre-lib_6b11-9.1+lenny2_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/r/rhino/rhino_1.7R1-2_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/j/java-access-bridge/libaccess-bridge-java_1.23.0-3_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/j/java-common/java-common_0.30_all.deb  Hash Sum incorreto
Falhou ao buscar http://security.debian.org/pool/updates/main/o/openjdk-6/openjdk-6-jre-headless_6b11-9.1+lenny2_i386.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/g/giflib/libgif4_4.1.6-6_i386.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/tzdata/tzdata_2010j-0lenny1_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-baekmuk/ttf-baekmuk_2.2-2_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-bengali-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-devanagari-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-gujarati-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-kannada-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-malayalam-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-oriya-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-punjabi-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-tamil-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-telugu-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-indic-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-kochi/ttf-kochi-gothic_1.0.20030809-8_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-sazanami/ttf-sazanami-mincho_20040629-2_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/tzdata/tzdata-java_2010j-0lenny1_all.deb  Hash Sum incorreto
Pré-configurando pacotes ...
Selecionando pacote previamente não selecionado x-ttcidfont-conf.
(Lendo banco de dados ... 58726 arquivos e diretórios atualmente instalados).
Desempacotando x-ttcidfont-conf (de .../x-ttcidfont-conf_31_all.deb) ...
Configurando x-ttcidfont-conf (31) ...
Updating font configuration of x-ttcidfont-conf...
Cleaning up category cmap..
Cleaning up category cid..
Cleaning up category truetype..
Updating category truetype..
Updating category cid..
Updating category cmap..
debian:/home/cpd#

Esse erro não é de hoje que aparece, ja tive outras experiencias ao instalar alguns programas e suas respectivas dependencias e ele me retorna "hash sun incorreto", o fato é q se eu usar o "--fix-missing" como é sugerido na console, ele continua baixando os pacotes, e esse erro aparece outras vezes até a sua conclusão do download, e ja aconteceu de alguns programas como é o caso do php não funcionar, tipo eu tentei abrir um arquivo index.php e ele ao invés de abrir o arquivo normalmente aparecia uma tela pedindo pra fazer download do arquivo, tentei intalar denovo e a console apontou que os pacotes estavam instalados, mas se estivessem instalados corretamente o erro nao ocorreria, certo?
Creio que esse problema ocorreu pq os arquivos foram baixados corrompidos e o apt-get instala ou pelo menos tenta instalar os pacotes problemáticos....não sei, essa é a minha dúvida, pq acontece esses erros?O q eu faço p q os pacotes sejam instalados na íntegra, sem erros, e como proceder se o erro persistir?

Desde já agradeço!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/07/2010, 14:26
Resposta: #10
Re: preciso de um source.list válido
Esse erro está dizendo que o arquivo baixado está corrompido. Isso acontece quando o download é interrompido e o arquivo fica incompleto. Andei lendo umas coisas no google sobre isso e parece que algumas pessoas que usam firewall tiveram problema semelhante ao seu. Você está usando algum firewall?

Se você precisar resolver isso de forma urgente, entre no repositório (ex: http://linorg.usp.br/debian/) usando o navegador, procure todos os pacotes que o apt-get tentou instalar e baixe-os manualmente, um por um. Feito isso, coloque todos eles numa pasta, entre nessa pasta e digite o comando:

Código:
# dpkg -i *.deb

Provavelmente não haverá conflitos, já que todas as dependências vão estar na pasta para serem instaladas. Isso não resolve o problema do seu apt-get, mas é uma solução emergencial viável pra você não ficar sem esse programa que você tá precisando enquanto não resolve as coisas.

"Vamos tirar a barriga, senhor Barba? Digo..."

Debian Jessie | Usuário #517613
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/07/2010, 14:30
Resposta: #11
Re: preciso de um source.list válido
cabralsan Escreveu:
renatov Escreveu:Que estranho cara, esse pacote, openjdk-6-jre-headless, está disponível nos repositórios da versão stable do lenny, sem ser preciso baixá-lo do repositório backports. O erro que você está recebendo está te falando que esse pacote não está mais disponível nos repositórios que você está usando (http://ftp.br.debian.org e linorg.usp.br), mas o pacote está disponível sim. Ao que parece, isso está sendo um problema do repositório, e não do seu computador. Tenta instalar novamente, talvez o repositório já tenha voltado ao normal. Faça o update antes de tentar.

Caso ainda não dê certo, você tem duas opções. A primeira é mudar sua lista de repositórios oficiais, para ver se os repositórios internacionais estão OK. É só comentar os dois repositórios brasileiros e adicionar esse aqui:

deb http://ftp.debian.org/debian/ lenny main contrib non-free

Outra solução seria baixar esse pacote manualmente do site:

http://packages.debian.org/lenny/openjdk-6-jre-headless

Daí você instala ele usando o comando:

Código:
#dpkg -i openjdk-6-jre-headless_6b11-9.1+lenny2_i386.deb

Fique atento porque talvez para fazer a instalação manual você precise baixar os outros pacotes que também tem dependências com o openjdk-6-jre-headless. No link que eu te passei, veja os pacotes com o sinal em vermelho, que são as dependências. Tente instalar eles pelo próprio apt-get, caso você ainda não os tenha instalados.

Qualquer dúvida, posta aí!

olá meu caro, antes de mais nada obrigado pela dica...

bom, substitui os repositórios como vc mencionou, executei o comando apt-get install -f --fix-missing openjdk-6jre, ele começou a baixar suas dependencias e antes da conclusão apareceu o seguinte erro:

Código:
Obter:1003 http://ftp.de.debian.org lenny/main tzdata-java 2010j-0lenny1 [150kB]
Obter:1004 http://ftp.de.debian.org lenny/main tzdata-java 2010j-0lenny1 [150kB]
Obter:1005 http://ftp.de.debian.org lenny/main tzdata-java 2010j-0lenny1 [150kB]
Obter:1006 http://ftp.de.debian.org lenny/main x-ttcidfont-conf 31 [23,4kB]
Baixados 67,4MB em 6min32s (172kB/s)      
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-arphic-uming/ttf-arphic-uming_0.2.20080216.1-1_all.deb  Hash Sum incorreto
Falhou ao buscar http://security.debian.org/pool/updates/main/o/openjdk-6/openjdk-6-jre-lib_6b11-9.1+lenny2_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/r/rhino/rhino_1.7R1-2_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/j/java-access-bridge/libaccess-bridge-java_1.23.0-3_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/j/java-common/java-common_0.30_all.deb  Hash Sum incorreto
Falhou ao buscar http://security.debian.org/pool/updates/main/o/openjdk-6/openjdk-6-jre-headless_6b11-9.1+lenny2_i386.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/g/giflib/libgif4_4.1.6-6_i386.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/tzdata/tzdata_2010j-0lenny1_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-baekmuk/ttf-baekmuk_2.2-2_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-bengali-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-devanagari-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-gujarati-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-kannada-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-malayalam-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-oriya-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-punjabi-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-tamil-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-telugu-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-indic-fonts/ttf-indic-fonts_0.5.4_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-kochi/ttf-kochi-gothic_1.0.20030809-8_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-sazanami/ttf-sazanami-mincho_20040629-2_all.deb  Hash Sum incorreto
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/tzdata/tzdata-java_2010j-0lenny1_all.deb  Hash Sum incorreto
Pré-configurando pacotes ...
Selecionando pacote previamente não selecionado x-ttcidfont-conf.
(Lendo banco de dados ... 58726 arquivos e diretórios atualmente instalados).
Desempacotando x-ttcidfont-conf (de .../x-ttcidfont-conf_31_all.deb) ...
Configurando x-ttcidfont-conf (31) ...
Updating font configuration of x-ttcidfont-conf...
Cleaning up category cmap..
Cleaning up category cid..
Cleaning up category truetype..
Updating category truetype..
Updating category cid..
Updating category cmap..
debian:/home/cpd#

Esse erro não é de hoje que aparece, ja tive outras experiencias ao instalar alguns programas e suas respectivas dependencias e ele me retorna "hash sun incorreto", o fato é q se eu usar o "--fix-missing" como é sugerido na console, ele continua baixando os pacotes, e esse erro aparece outras vezes até a sua conclusão do download, e ja aconteceu de alguns programas como é o caso do php não funcionar, tipo eu tentei abrir um arquivo index.php e ele ao invés de abrir o arquivo normalmente aparecia uma tela pedindo pra fazer download do arquivo, tentei intalar denovo e a console apontou que os pacotes estavam instalados, mas se estivessem instalados corretamente o erro nao ocorreria, certo?
Creio que esse problema ocorreu pq os arquivos foram baixados corrompidos e o apt-get instala ou pelo menos tenta instalar os pacotes problemáticos....não sei, essa é a minha dúvida, pq acontece esses erros?O q eu faço p q os pacotes sejam instalados na íntegra, sem erros, e como proceder se o erro persistir?

Desde já agradeço!

olha o que ocorreu na instalação do openjdk-6-jre:

Código:
Obter:107 http://ftp.de.debian.org lenny/main ttf-arphic-uming 0.2.20080216.1-1 [9678kB]
Obter:108 http://ftp.de.debian.org lenny/main ttf-arphic-uming 0.2.20080216.1-1 [9678kB]
Obter:109 http://ftp.de.debian.org lenny/main ttf-arphic-uming 0.2.20080216.1-1 [9678kB]
Obter:110 http://ftp.de.debian.org lenny/main rhino 1.7R1-2 [635kB]
Baixados 10,3MB em 3min50s (44,7kB/s)                                                                                                                                  
Falhou ao buscar http://ftp.de.debian.org/debian/pool/main/t/ttf-arphic-uming/ttf-arphic-uming_0.2.20080216.1-1_all.deb  Hash Sum incorreto
Selecionando pacote previamente não selecionado openjdk-6-jre-lib.
(Lendo banco de dados ... 59461 arquivos e diretórios atualmente instalados).
Desempacotando openjdk-6-jre-lib (de .../openjdk-6-jre-lib_6b11-9.1+lenny2_all.deb) ...
Selecionando pacote previamente não selecionado rhino.
Desempacotando rhino (de .../archives/rhino_1.7R1-2_all.deb) ...
Selecionando pacote previamente não selecionado libaccess-bridge-java.
Desempacotando libaccess-bridge-java (de .../libaccess-bridge-java_1.23.0-3_all.deb) ...
Selecionando pacote previamente não selecionado openjdk-6-jre-headless.
Desempacotando openjdk-6-jre-headless (de .../openjdk-6-jre-headless_6b11-9.1+lenny2_i386.deb) ...
Selecionando pacote previamente não selecionado openjdk-6-jre.
Desempacotando openjdk-6-jre (de .../openjdk-6-jre_6b11-9.1+lenny2_i386.deb) ...
Processando gatilhos para man-db ...
Processando gatilhos para menu ...
Configurando openjdk-6-jre-lib (6b11-9.1+lenny2) ...
Configurando libaccess-bridge-java (1.23.0-3) ...
Configurando openjdk-6-jre-headless (6b11-9.1+lenny2) ...
Configurando openjdk-6-jre (6b11-9.1+lenny2) ...
Configurando rhino (1.7R1-2) ...
Processando gatilhos para menu ...

Depois disso , apesar do erro de "hash sum incorrreto" executei novamente apt-get install -f --fix-missing openjdk-6-jre, segue a saída :

Código:
debian:/home/cpd# apt-get install -f openjdk-6-jre --fix-missing
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
openjdk-6-jre já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 59 não atualizados.
debian:/home/cpd#

quer dizer, apesar do erro o apt diz q o openjdk está instalado.Pelo fato de ter ocorrido estes erros, não é possivel que o openjdk-6-jre estaja instalado incompleto ?ou algo do tipo?, isto aconteceu tambem com a instalação do php e ele nao funcionou,
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/07/2010, 14:39
Resposta: #12
Re: preciso de um source.list válido
renatov Escreveu:Esse erro está dizendo que o arquivo baixado está corrompido. Isso acontece quando o download é interrompido e o arquivo fica incompleto. Andei lendo umas coisas no google sobre isso e parece que algumas pessoas que usam firewall tiveram problema semelhante ao seu. Você está usando algum firewall?

Se você precisar resolver isso de forma urgente, entre no repositório (ex: http://linorg.usp.br/debian/) usando o navegador, procure todos os pacotes que o apt-get tentou instalar e baixe-os manualmente, um por um. Feito isso, coloque todos eles numa pasta, entre nessa pasta e digite o comando:

Código:
# dpkg -i *.deb

Provavelmente não haverá conflitos, já que todas as dependências vão estar na pasta para serem instaladas. Isso não resolve o problema do seu apt-get, mas é uma solução emergencial viável pra você não ficar sem esse programa que você tá precisando enquanto não resolve as coisas.

não utilizo firewall, mas acesso a internet através do proxy do governo e sei q eles utilizam firewall la, meu ip deve ter restrições de acesso, eu estou dentro da intranet do governo do estado.

Valeu!Obrigado!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS