Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Configurar pppoe Squeeze amd64 (resolvido)
20/01/2012, 19:42 (Resposta editada pela última vez em: 24/01/2012 08:40 por Crazy Cat.)
Resposta: #1
Configurar pppoe Squeeze amd64 (resolvido)
Tentei configurar a internet no novo hd e não consegui... minha internet é via rádio, e a placa é uma ralink.

1) Instalei o Debian Squeeze amd64 no hd IDE de 160 gigas;
Configurando a internet no Debian;
2) baixei o pacote deb do firmawre ralink;
2) Colei o arquivo deb na pasta pessoal e com o botão direito escolhi
Abrir com GDebi pakage installer;
3) Na janelinha que abriu cliquei em Instalar
digitei a senha de root
instalou;
4) Reiniciei o pc e a placa ralink piscou... ao logar apareceu Redes sem fio disponíveis;
5) Como root, e com o DVD do Debian (o dvd de instalação, não o non-free) no drive fiz o comando
apt-get install pppoeconf
O pacote foi instalado... no final, ainda como root fiz;
6) pppoeconf -wlan0
abriu o configurador ... coloquei servidor, senha, etc...
7) Cliquei no NM e escolhi Editar conexões... segui colocando o IP, máscara, et... aplicar

No fim tentei navegar e não consegui... então fiz
pon dsl-provider conforme abaixo:

[email protected]# pon dsl-provider
Plugin rp-pppoe.so loaded.
/usr/sbin/pppd: In file /etc/ppp/peers/dsl-provider: unrecognized option 'nic--wlan0-wlan0'

deu este erro aí acima... então fiz:

[email protected]:/home/sniperchess# ifconfig wlan0 up

[email protected]:/home/sniperchess# iwconfig
bash: iwconfig: comando não encontrado

e retornou a frase acima... então tentei:

[email protected]:/home/sniperchess# iwlist wlan0 scan
bash: iwlist: comando não encontrado

ocorreu a mesma coisa...
......................
Resumindo: conecta-se na rede no NM, mas o comando de conectar para navegar (pon dsl-provider) não funfa.
Assim não consigo navegar.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/01/2012, 22:11
Resposta: #2
RE: Configurar pppoe Squeeze amd64
Primeiramente qual é o seu modem? Por favor especifique o modelo completo.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/01/2012, 09:57 (Resposta editada pela última vez em: 21/01/2012 09:58 por Crazy Cat.)
Resposta: #3
RE: Configurar pppoe Squeeze amd64
moden?? até onde eu sei não tenho moden nenhum aqui. deixa explicar melhor:
O meu provedor envia o sinal por uma atena sobre um prédio aqui próximo;
meu pc capta o sinal via uma antena de rádio externa, sobre o teto da minha casa; o sinal desce pelo cabo que conecta-se na placa ralink wireless (estes modelos RTs)...
Normalmente neste tipo de conexao o IP não é individual, o provedor recebe todos os ips na central e converte para um só (é por isso que é praticamente impossível para mim baixar alguma coisa do megaupload rsrsrs sempre diz que meu ip já baixou algo tststs)
No windowsxp há o discador PPPoe... no Debian eu vejo as redes no NM, e através do comando pppoeconf -wlan0 eu insiro o meu login, senha, IP local, mascara, dns (uso o do google); e depois que já está configurado basta eu digitar pon dsl-provide e já estou navegando... ou pelo menos deveria rsrsrs
Se ajuda: a Mobo é uma Phitronics N68C-M
Processador AMD64 X2
DDR 3 2 gigas.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/01/2012, 10:42
Resposta: #4
RE: Configurar pppoe Squeeze amd64
Desculpe o termo usado aqui, mas pelo que estou vendo de dificuldades expostas aqui no fórum, essa internet rádio é uma "porcaria". Deixa o cliente todo engessado.
Bom você tem o windows? E se tem quando loga na internet qual o retorno de linha de comando com o ipconfig? Se não ligue para a operadora e obtenha com eles o:
gateway
máscara
Nome da rede
senha
E pergunte se é ip fixo ou se o ip é dado por dhcp.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/01/2012, 11:20
Resposta: #5
RE: Configurar pppoe Squeeze amd64
Primeiro teve ver porque os comandos acima não funciona ver se não esta instalado pode ir no seu gerenciamento de arquivos e procurar por eles, depois configurara o resto o método é o seguinte.
Primeiro configure a conexão wireless com o seu provedor, conecte-se na torre que você faz sempre não precisa colocar ip pois pode esta ai o problema.
Segundo depois de conectado na torre você vai fazer a configuração do pppoe executa como root o pppoeconf ele vai busca nas interfaces se tudo estiver certo quando chegar na wlan0 vai encontra e vai pedir para fazer as configurações senha e nome de usuário os dns deixa automático, lembre primeiro tem que fazer a conexão com a torre ai. Bom trabalho num provedor que usa este mesmo método.

Jvianez
Todo Cristão é Livre use Linux e não seja Pirata.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/01/2012, 23:11
Resposta: #6
RE: Configurar pppoe Squeeze amd64
Acredito que pode ser um problema coma interface wlan0, você consegue pingar o gateway?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/01/2012, 07:22
Resposta: #7
RE: Configurar pppoe Squeeze amd64
Bom, eu entrei com o outro HD com Debian instalado e funfando a internet, como root abri o nautilus e copiei o arquivo dsl-provider da pasta peers e colei na pasta peers do outro HD (o que estou tentando usar)... reiniciei e tentei conectar, não deu mais o erro de
unrecognized option 'nic--wlan0-wlan0'
Mas continua sem conexão e não pinga.
Lembrando que tentei o modo automático (DHCP), mas sempre usei o modo manual, inserindo os IPs... tentei novamente pelo modo manual e continua na mesma... o comando pon-dsl provider abre, mas não navega .
Lembrando que minha conexão sempre funcionou no modo manual e Sem Fio IpV4 (não lembro agora rsrs) onde coloco o IP, máscara, gat 0.0.0.0 e DNS 8.8.8.8
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/01/2012, 08:38 (Resposta editada pela última vez em: 26/01/2012 07:30 por Crazy Cat.)
Resposta: #8
RE: Configurar pppoe Squeeze amd64 (Resolvido)
Consegui!! Bom, foi uma lambança danada, mas como pode vir a acontecer com outro já fica a dica de como procedi:

O primeiro passo foi

Configurando a internet no Debian

1) baixei o pacote deb do firmawre ralink (para ver a lista das placas compatíveis clique aqui)
2) Colei o arquivo deb na pasta pessoal e com o botão direito escolhi
Abrir com GDebi pakage installer
3) Na janelinha que abriu cliquei em Instalar.
digitei a senha de root
instalou
4) Reiniciei o pc e a placa ralink piscou... ao logar apareceu Redes sem fio disponíveis; cliquei na minha torre (rede que conecto) conectou;
5) Com botão direito no NM escolhi
Editar Conexões...
6) Cliquei na aba Configurações IPv4, coloquei Método Manual, adicionei meu endereço de IP, a máscara, e gateway (no meu caso é 0.0.0.0), e em DNS coloquei o do google (8.8.8.8) e cliquei em Aplicar.
7) Como root, e com o DV do Debian (o dvd de instalação, não o non-free) no drive fiz o comando
apt-get install pppoeconf
O pacote foi instalado... no final, ainda como root fiz
8) pppoeconf -wlan0
abriu o configurador ... coloquei servidor, senha, etc...
9) No terminal fiz
pon dsl-provider

e foi aqui que deu o primeiro erro:
unrecognized option 'nic--wlan0-wlan0'
e com isso não navegava e nem pingava... então fiz como root:

gedit /etc/ppp/peers/dsl-provider

e apaguei a linha
'nic--wlan0-wlan0' deixando apenas
nic-wlan0

E acrescentei embaixo de nic-wlan0
as linhas

user "meuloginnoservidordeinternet" (entre aspas mesmo)
userpeerdns

Salvei e fechei o arquivo

Ainda como root fui em

gedit /etc/resolv.conf

e percebi que estava

nameserver 201.77.0.1
nameserver 201.77.0.2
# Generated by NetworkManager

ou seja sem o nome do meu provedor, entao acrescentei

simonet.com.br
nameserver 8.8.8.8
nameserver 201.77.0.1
nameserver 201.77.0.2
# Generated by NetworkManager

salvei e fechei

no terminal fiz

pon dsl-provider

e
ping http://www.google.com.br

funcionou!!

voltei no

resolv.conf e percebi que ele tinha alterado de novo ficando assim

nameserver 201.77.0.1
nameserver 201.77.0.2
# Generated by NetworkManager

sai sem salvar e pinguei de novo e funcionou.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS