Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Duvidas sobre como montar uma rede doméstica com um servidor!
12/07/2012, 17:16
Resposta: #16
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
Ok, talvez eu deva ter me confundido e assim confundido vocês com a minha explicação, mas tendo em vista o que você disse amigo GNU matador de leões eu já fiz isso de organizar primeiro as lans, pra depois ir para a wan é tanto que eu já recebi o dhcp vindo do servidor no meu note ( só que via cabo ) e acredito não ter conseguido acessar a internet devido a alguma coisa que estou fazendo errado ou esquecendo de fazer.
Quero que a minha rede fique exatamente como essa:
[Imagem: th_Semttulo.png]

Por favor, me tirem umas duvidas?
Eu tenho que configurar as duas placas de rede ( eth0 e eth1 ) manualmente?
Ou eu só preciso configurar manualmente a eth0 que é a que vai ter um cabo que vai sair pro roteador?
Ou tenho que configurar manualmente a eth1 que vai receber o cabo que vem do modem?
Como seria essa configuração que tenho que fazer nas placas ( se é que tenho que fazer )?

Mais uma vez me desculpem pelas duvidas, mas sou iniciante no linux!!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/07/2012, 18:04
Resposta: #17
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
Citar:Eu tenho que configurar as duas placas de rede ( eth0 e eth1 ) manualmente?
Ou eu só preciso configurar manualmente a eth0 que é a que vai ter um cabo que vai sair pro roteador?
Ou tenho que configurar manualmente a eth1 que vai receber o cabo que vem do modem?
Como seria essa configuração que tenho que fazer nas placas ( se é que tenho que fazer )?

Como os colegas sugeriram e também prefiro deixe o modem como "bridge". Após isso no servidor baixe o pacote "pppoeconf" para poder fazer autenticação gerando uma interface "ppp0".

# apt-get install pppoeconf
depois
# pppoeconf eth1
vai pedir dados da operadora, senha, etc....

Assim não irá precisar configurar a eth1 (ligada no modem). Bastando apenas configurar a eth0 (ligada no router ou switch)

Para configurar a eth0, sugiro deixa-la fixa no arquivo interfaces (/etc/network/interfaces), veja no wiki abaixo, tem boas dicas de como compartilhar internet, configurar servidor dhcp e configurar interfaces, no seu caso eth0.

http://wiki.forumdebian.com.br/index.php...n_com_Dhcp

Altair M. de Souza
Liberdade é tudo !!!!
Linux Counter user #469759
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/07/2012, 20:22
Resposta: #18
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
Da uma olhada neste posto do wiki foi eu mesmo que fiz basta trocar os ip pelo que você quer usar na sua rede
E se não fizer como altarimsouza falou basta trocar o ppp0 pela eth1 nesta linha iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

como você via usar porxy também tem que fazer o redirecionamento par ao proxy

modpobre iptable_nat echo 1 > /proc/sys/net/ipv4/ip_forward iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE iptables -A FORWARD -i 192.168.254.254 -p tcp --dport 3128 -j ACCEPT #troca pelos ip da sua rede iptables -t nat -A PREROUTING -s 192.168.254.0/24 -p tcp --dport 80 -j REDIRECT --to-port 3128 #troca pelos ip da sua rede
Lembre de colocar estes comando no fim do arquivo /etc/init.d/bootmisc.sh

Jvianez
Todo Cristão é Livre use Linux e não seja Pirata.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/07/2012, 21:11
Resposta: #19
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
Como eu mexi em milhões de coisas aqui e nenhuma delas deu certo, eu vou formatar a minha maquina novamente, e depois vou seguir fielmente o que você Jvianez e o amigo altairmsouza me mandaram.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/07/2012, 22:27
Resposta: #20
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
O seu servidor esta como nós, confusos!!! rsrsrs essa de bebados foi boa!!
Bom acredito que vc esteja tentando desenhar seja isso;
Internet > ISP > Servidor > Wireless
O cabo quem vem do seu ISP teria que estar na eth0 ou eth1 configurado como DHCP, já que você não possui um ip fixo publico.
Ai a sua eth1 ou eth0 que tem q ter um ip fixo ex: 10.0.0.1, aqui para seu servidor navegar como o GNU disse,vc precisará fazer um NAT.
Se este for o cenário acho mais facil acertar a WAN primeiro, assim vc mexerá somente na parte interna da rede.
Com seu servidor navegando vc irá puxar o cabo da eth1 e ligar em uma porta do seu roteador wireless (qualquer porta menos a que está escrita wan.. rs)
aqui seu roteador terá por exemplo o ip 10.0.0.2 com o gateway final 1.
Neste cenario seria mais simples o servidor de DHCP ser o seu wireless e não o seu gateway de internet, agora se quiser que seja o servidor o seriço de dhcp no wireless fica inativo. Evite fixar ips que estão no escopo no DHCP.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/07/2012, 01:08
Resposta: #21
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
Imaginei que o problema era eu quem não estava sabendo explicar!
Me deixe tentar mais uma vez!
Sim, amigo [email protected], de fato o que eu estou tentando desenhar é exatamente isso, internet>ISP( que eu não sei o que é, mas acredito que seja o modem )>Servidor>wireless!
Como eu falei, instalei o debian normalzinho, em seguida atualizei os repositórios " apt-get update e upgrade " e instalei o serviço DHCP " apt-get install dhcp3-server " e em seguida configurei o arquivo de configuração do serviço " /etc/dhcp/dhcpd.conf " que ficou dessa forma:

option domain-name " casa.local ";
option domain-name-servers 192.168.1.254;
default-lease-time 600;
max-lease-time 7200;
subnet 192.168.1.0 netmask 255.255.255.0 {
range 192.168.1.50 192.168.1.200;
option broadcast-address 192.168.1.255;
option routers 192.168.1.254;
}

Feito isso eu configurei a placa " eth0 " da seguinte forma:

# Primary network interface
allow-hotplug eth0
iface eth0 inet static
address 192.168.1.10
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.254
# dns-* options are implemented by the resolvconf package, if install
dns-nameservers 192.168.1.254
dns-search casa.local

Lembrando que a minha placa eth1 tava lá quietinha sem eu mexer em nada dela além de fazer o que o amigo jvianez pediu, que foi subir ela manualmente " ifconfig eth1 up " e editar no aquivo " /etc/init.d/bootmisc.sh " pra que toda a vez que eu iniciasse o sistema ela funcionasse normalmente.

Pronto!
Feito isso eu testei pra ver se tava tudo funcionando direitinho ( e foi que começou a putaria )!
Primeiro eu tentei fazer funcionar tudo da seguinte forma:
Restartei o serviço dhcp " /etc/init.d/isc-dhcp-server restart ";
Depois eu liguei o cabo que sai do modem direto na minha eth1 ( que tava recebendo o dhcp - pelo menos era o que tinha mostrando no "/etc/network/interfaces" sobre ela - ), em seguida liguei um cabo que sai da minha eth0 direto no roteador ( com o dhcp dele desabilitado ), não funcionou!
Nem o servidor conectava na internet, nem o meu note recebeu um ip da faixa que vinha do dhcp do servidor.
Depois eu reiniciei o servidor e tirei o cabo que ia pro roteador e liguei direto no meu note, ai o meu note recebeu um ip vindo do dhcp do servidor, mas o servidor continuava sem conectar na internet.
Em seguida fiz o que o amigo altairmsouza recomendou, colocar o modem em modo bridge e instalar o pacote " pppoeconf " e eu fiz exatamente como ele recomendou, mas também não deu certo.
Em seguida eu tentei fazer exatamente como no link da wiki indicado pelo amigo altairmsouza, o post foi feito pelo amigo jvianez e eu segui direitinho o que dizia nele, mas também não funcionou ( e lá vai o tadinho do teclado sentir a fúria da minha frustração )!
Ai quando o amigo jvianez fez sua ultima recomendação eu decidi formatar a maquinha novamente e iniciar do 0 ( zero )!
Agora a pouco eu terminei de formatar a maquina, já subi a eth1 e configurei manualmente a minha eth0.
Enquanto terminava a formatação eu tive que consertar a configuração do modem e do roteador, dai quando a formatação terminou e eu fiz as coisas que falei acima eu tentei ligar o servidor só que ele iria receber o dhcp vindo do roteador e eu liguei na minha eth1 e ta funcionando normalzinho, perfeito, agora eu pergunto... Porque essa bendita placa eth1 recebe o dhcp normalzinho do roteador e quando eu ligo ela direto no modem ela não pega o ip que vem dele?

Gente, mais uma vez obrigado pela a ajuda, muito obrigado!!!

Eu sou meio burro, mas eu sou persistente e sei que vou aprender!!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/07/2012, 09:18 (Resposta editada pela última vez em: 13/07/2012 09:22 por altairmsouza.)
Resposta: #22
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
Bruno,

- Conforme o [email protected] sugeriu arrume sua WAN (Wide Area Network) Area Externa de Rede/Internet, onde seu modem estará conetado ao ISP (Internet Service Provider), seu provedor de internet (GVT, Oi, etc..), somente depois acerte sua LAN (Local Area Network) sua rede local.

- Escolha se deseja que o servidor faça o roteamento ou se o modem será o roteador, existe uma certa confusão quando fala-se de roteamento e Access Point Wireless, mas quem redireciona portas, bloqueia, libera tráfego é o serviço de roteamento, ok.
- Se deixou o modem como router+dhcp ativo terá que dizer ao servidor que a placa de rede eth1 (/etc/network/interfaces) será um cliente dhcp do modem.
- Se deixou o modem como bridge(ponte), deverá instalar o serviço pppoeconf no servidor para criar uma interface ppp0 (prefiro essa opção).
- Depois de definir quem é o roteador, conecte o cabo do modem na eth1
- Se o modem for router, (modem em modo router, com dhcp ativo) de o comando:
# dhclient eth1
- Atenção é um teste, se for isso que deseja, tem que ajustar em /etc/network/interfaces deixando eth1 com client automático.

- Se o servidor for o router (modem em modo bridge, sem dhcp), de o comando:
# pppoeconf eth1 (informe login, senha operadora e continue...)

- Neste ponto seu servidor deverá estar na nuvem, faça teste com ping:
# ping http://www.forumdebian.com.br
# ping google.com.br
De Ctrl+C para parar de pingar.
- Se houver exito, seu servidor realmente está navegando.
- Sugiro agora que siga o excelente wiki que o colega Jvianez criou
Citar:http://wiki.forumdebian.com.br/index.php...n_com_Dhcp

- Atenção sobre o wiki pois depende de sua escolha, quem é o router
Se o modem for bridge sua interface da internet é ppp0
Se o modem for router sua interface de internet é eth1
Observe no wiki e altere conforme seu gosto, observando sempre ppp0 e eth1. de o comando (ifconfig) para ver as interfaces de rede.

- E finalmente pegue um cabo de rede, conecte na eth0 e a outra ponta conecte a um switch ou Access Point Wireless/router wireless e veja se o computador da ponta consegue navegar.

Também passei por isso no início, sei que não é fácil, você fica perdido, mas tenha certeza que existem pessoas realmente dispostas em ajudar (Jvianez, [email protected] e muitos outros no mundo linux), hoje continuo pedindo ajuda e acredito que não irei parar de ajudar e pedir ajuda.

Qualquer duvida poste novamente, que uma hora esse bichinho vai funcionar, hehehehe...
PS: se optou em deixar modem como bridge, antes de fazer (pppoeconf eth1), o pacote pppoeconf deve estar instalado.

# aptitude install pppoeconf

depois continue conforme orientações ácima:

# pppoeconf eth1

Altair M. de Souza
Liberdade é tudo !!!!
Linux Counter user #469759
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/07/2012, 10:32
Resposta: #23
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
Calma ninguem é burro, é falta de experiencia só isso!!Você vai ver que depois que acertar a primeira vez, depois fica facil.

Tenta fazer assim;

Deixe o modem em modo router,ai vc liga ele na eth0 do servidor e faz esses comandos;

# nano/etc/network/interface

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp # ip automaticamente do dhcp do modem

auto eth1
iface eth1 inet static
address 192.168.0.1
netmask 255.255.255.0
dns-nameservers 8.8.8.8

Salva as configs. Ai vc faz;

# modprobe iptable_nat
# echo 1 > /proc/sys/net/ipv4/ip_forward
# iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

Depois reinicie o serviço

# /etc/init.d/networking restart

No servidor pinga o 8.8.8.8.
Se pingar blz, faz um nslookup no 8.8.8.8
Se responder blz, agora vc liga o cabo da eth1 no seu note, ele não vai atribuir nenhum ip pq ate o momento não há serviço de DHCP então coloque na mão (esqueça nesse momento o serviço de dhcp do seu server).

IP: 192.168.0.2
mask: 255.255.255.0
Gateway: 192.168.0.1
DNS: 192.168.0.1

Tenta navegar, se navegar blz, tira o cabo do note e coloca no wireless em qualquer porta menos a WAN e configura o Wireless com os mesmos dados que vc colocou anteriormente no note, e no proprio Wireless, vc defini o escopo do DHCP
Feito isso, volta seu note para pegar ip por dhcp, não é possível que assim não funcione!! rsrs Tenta seguir o raciocinio do desenho


Arquivos Anexos Miniaturas
   
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/07/2012, 15:15 (Resposta editada pela última vez em: 13/07/2012 15:19 por Bruno Rocha.)
Resposta: #24
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
Amigos digamos que de 100% só deu certo 50%!
Primeiro a dica dada pelo amigo altairmsouza não deu certo ( definitivamente o problema sou eu ).
Mas a dica do amigo [email protected] deu certo em partes.... tipo, ate a parte do restartar o serviço " /etc/init.d/networking restart " ta tudo beleza, o pinga para 8.8.8.8 também ta belezinha, mas eu não sei o que é ou como se faz um " nslookup no 8.8.8.8 ".
Ate ai esse foi o primeiro problema que deu, mas eu pulei e segui em frente, quando eu fui configurar a minha placa no note com :

IP: 192.168.0.2
mask: 255.255.255.0
Gateway: 192.168.0.1
DNS: 192.168.0.1

ela conectou, mas não tinha conexao com a internet, dai eu troquei o DNS por 8.8.8.8 e ai sim funcionou direitinho ( ate aqui belezinha de novo )!
Dai eu segui a diante, fui ligar o cabo no roteador ( em qualquer porta que não a WAN ), configurei direitinho e definir o dhcp.
Quando eu tentei no note pegar um ip ele pegou, mas mais uma vez tava conectado, mas não tinha conexão ( lembrando que no roteador eu coloquei tudo direitinho ):

IP: 192.168.0.2
mask: 255.255.255.0
Gateway: 192.168.0.1-------> Não tem no roteador opção pra eu colocar o gateway
DNS: 192.168.0.1---------> Eu só troquei esse DNS, coloquei 8.8.8.8, na opção DOMAIN NAME que tem no roteador.

Como não deu certo eu troquei o DNS, coloquei da forma como o [email protected] falou 192.168.0.1, também não deu certo.
Depois só pra ver se o problema era no roteador eu coloquei novamente o cabo no note, configurei tudo manual e tentei conectar e tava dando a mesma coisa, conectava, mas não tinha conexao, independente de qual DNS eu colocasse, ou o 192.168.0.1, ou 8.8.8.8 dava a mesma coisa.
Dai eu tentei pingar pra ver se do note tava pingando para as duas placas e esta, como também as placas estao pingando para o ip do note.
E agora???
Lembrando que no servidor, tá tudo normal, ele tá acessando a internet bonitinho, o problema agora é na rede interna!

To indo aqui bater em algo porque no teclado não da mais não!! rsrsrsrsrs
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/07/2012, 09:56 (Resposta editada pela última vez em: 14/07/2012 19:15 por GNU matador de leoes.)
Resposta: #25
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
"fui ligar o cabo no roteador ( em qualquer porta que não a WAN )",,,,
Ligue o cabo que vem do servidor na porta WAN do roteador.
Acho que os colegas te passaram todas as dicas importantes. Para reforçar dá uma olhada no wiki.debian.
http://wiki.forumdebian.com.br/index.php..._no_Debian
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/07/2012, 17:26 (Resposta editada pela última vez em: 17/07/2012 18:02 por FuRuKaWa.)
Resposta: #26
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
galera o meu problema é o inverso do Bruno Rocha, mas a maneira que ele quer fazer é igual a que eu quero fazer.
meu server não ta conectando na net, mas pinga direitinho em maquinas da rede interna.
se eu ligar o modem no roteador ligar um cabo saindo de alguma lan do roteador indo pro server ele acessa a net, mas se tirar esse cabo do roteador e ligar no modem o meu server nao conecta. Porque??
eu fiz parecido com o que tem aqui nesse post.
e o meu modem ta em modo router tambem!!
o que eu faço agora????????????????
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/07/2012, 21:20
Resposta: #27
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
provavelmente o seu modem esta rodeado em modo brigde e quem faz a conexão com a internet é o roteador o que você precisa saber é qual o tipo de conexão que você usa (pppoe, dhcp, ou ip fixo) é provável que seja pppoe basta saber o nome de usuário e senha instalar o programa pppoeconf no debian e depois executar o programa vai encontra a interface e pedi a senha e usuário e dai esta pronto você vai reconfigura o roteador para distribuir a internet que seu servidor vai esta fornecendo

Jvianez
Todo Cristão é Livre use Linux e não seja Pirata.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/07/2012, 21:53 (Resposta editada pela última vez em: 18/07/2012 07:45 por GNU matador de leoes.)
Resposta: #28
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
Olá FuRuKaWa. Deixa o dhcp funcional só no roteador para não dar confusão. Coloca um ip fixo no servidor. Na configuração dos clientes (computadores atraz do roteador) coloca em cada um o ip do servidor como gateway .
Obs: Você está atravessando o tópico. Abre um explicitando o problema e coloca os dados para ter ajuda.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/07/2012, 00:09 (Resposta editada pela última vez em: 18/07/2012 01:07 por Bruno Rocha.)
Resposta: #29
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
Amigos, por favor, sinto que falta pouco pra dar certo!
Consegui configurar o pppoeconf, agora o modem ta em bridge e a autenticação ta sendo feita pelo servidor, mas agora quando eu uso o comando "ifconfig" aparece outra placa "pppo" com um ip valido que eu pego emprestado.
Gente agora eu pergunto, como eu configuro a minha placa de rede interna no meu caso a " eth0 "?
Ela ta assim:

iface eth0 inet static
address 192.168.1.2
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255

Detalhe, seguindo a dica do [email protected], depois que eu ligasse o cabo no meu note e configurasse a placa manualmente, era pro meu note acessar a net, mas ele nao acessa, so pinga pro servidor sem problemas ( inclusive eu acesso o servidor via ssh do meu note ).
Depois que eu instalar o serviço dhcp, como eu devo configurar as minhas placas de rede?
Como deve ser a configuração no meu roteador?
Devo mudar o endereço que uso pra entrar no menu dele?
Além de desabilitar o dhcp do meu roteador o que mais eu tenho que fazer nele?
Meu roteador é um d-link DI524!
Todas as configuraçoes que eu fiz ate aqui no servidor, estao inicializando automaticamente?
Posso desligar o servidor sem perigo de eu perder alguma configuração?
Lembrando que so o que eu fiz foi o que o amigo [email protected] me aconselhou em seu post!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/07/2012, 00:15
Resposta: #30
RE: Duvidas sobre como montar uma rede doméstica com um servidor!
Primeiro como o seu servidor esta conectando direto na internet então você tem que muda a configuração do seu iptables para a nova interface no caso a ppp0 em vez de eth0 e quanto a configuração desta interface não importa como ela esta se ela esta ligada no modem vai funcionar apenas com um brigde entre o modem e a conexão pppoe mas você pode deixar com a mesma classe de ip do modem assim quando for preciso acessar o modem basta colocar o ip do modem no navegador.

Aparte que terá que muda é a debaixo deixando assim para que sua net seja compartilhada

modpobre iptable_nat echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE #deixa como esta esta linha se no lugar do ppp0 estiver outra interface basta deixa como esta gora

Jvianez
Todo Cristão é Livre use Linux e não seja Pirata.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS