Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Erro ao tentar habilitar o Compiz[RESOLVIDO]
28/10/2012, 10:13 (Resposta editada pela última vez em: 20/11/2012 23:22 por lokospokos.)
Resposta: #1
Erro ao tentar habilitar o Compiz[RESOLVIDO]
Uso o Debian 6.0.6 rodando perfeito.

Instalei o compiz e todas as dependências porém quando tento rodar o comando compiz --replace dá o seguinte retorno:

[email protected]:~$ compiz --replace
compiz (core) - Fatal: Software rendering detected.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Launching fallback window manager

Já rodei o glxgears e está tudo OK as engrenagens aparecem perfeitamente.
Verifiquei o que na pasta /etc/X11 não tem o xorg.conf, então criei parando o gdm3 no modo texto e rodando o comando Xorg configure o debian criou o arquivo xorg.conf.new na pasta do root, então copiei para a pasta /etc/X11, pensando que iria resolver, mas para a minha surpresa, após reiniciar o Gnome não inicia fica apenas o cursor piscando.
Entrei no modo recovery e apaguei o xorg.conf dai voltou ao normal, mas compiz que é bom nada...!

Procurei no Fórum porém não encontrei nada especificamente.
Alguma ajuda?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/10/2012, 20:52
Resposta: #2
RE: Erro ao tentar habilitar o Compiz
Você viu esse link?
http://www.forumdebian.com.br/topico-com...32-5-amd64
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/10/2012, 17:38
Resposta: #3
RE: Erro ao tentar habilitar o Compiz
Olá GNU...!
Verifiquei esse tópico sim, fiz todo o processo com exceção da instalação do drive da placa Nvidia, pois minha placa não é Nvídia, e sim Intel.

Quando faço o processo completo que reinicio o notebook não levante o Gnome, fica apenas um cursor piscando travado e não aceita comando nenhum.
O problema deve está no Xorg.conf que o Debian criou, pois quando entro em modo texto que apago o xorg.conf do diretório /etc/X11 e reinicio o notebook, o Gnome carrega normalmente.

Alguma solução para que possamos "matar este leão" ? hehe!
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/11/2012, 08:42
Resposta: #4
RE: Erro ao tentar habilitar o Compiz
Vou postar o Xorg.conf que o Debian gerou após o comando Xorg configure. Pra ver se alguém me ajuda a habilitar o compiz..! Ajuda ai pessoal..!

------------------------------------------------------------------------------------------------
Xorg.conf - Só lembrando que quando eu coloco este arquivo no diretório /etc/X11 o gnome não levanta, ao tentar iniciar o Debian fica apenas a tela do prompt e o cursor piscando.
------------------------------------------------------------------------------------------------
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"
EndSection

Section "Module"
Load "glx"
Load "dri2"
Load "record"
Load "dri"
Load "dbe"
Load "extmod"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "AccelMethod" # [<str>]
#Option "DRI" # [<bool>]
#Option "ColorKey" # <i>
#Option "VideoKey" # <i>
#Option "FallbackDebug" # [<bool>]
#Option "Tiling" # [<bool>]
#Option "Shadow" # [<bool>]
#Option "SwapbuffersWait" # [<bool>]
#Option "XvMC" # [<bool>]
#Option "XvPreferOverlay" # [<bool>]
#Option "DebugFlushBatches" # [<bool>]
#Option "DebugFlushCaches" # [<bool>]
#Option "DebugWait" # [<bool>]
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "Sandy Bridge Integrated Graphics Controller"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/11/2012, 16:02
Resposta: #5
RE: Erro ao tentar habilitar o Compiz
Coloca a resposta do comando "glxgears"
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/11/2012, 11:09
Resposta: #6
RE: Erro ao tentar habilitar o Compiz
Pesquisei, pesquisei, depois pesquisei um pouco mais...!
E verifiquei que o problema está na minha placa de vídeo (Intel sandy bridge) em relação ao Kernel de Debian 6. Pois os drivers só estão disponíveis a partir do Kernel 3.0
Tentei atualizar o kernel até consegui atualizar inclusive reconheceu o Vídeo direitinho e tudo mais.
Porém depois da atualização uma série de coisas deixaram de funcionar como rede, e etc..!
Resolvi tomar uma decisão radical, e instalei o agora congelado Debian 7 Wheezy.
Já no primeiro boot já reconheceu o vídeo certinho, porém ainda não vi como instala o Compiz no Wheezy (mas isso é assunto para outro tópico).
Então vou tentar instalar o Compiz e volto aqui para postar o resultado.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/11/2012, 06:50
Resposta: #7
RE: Erro ao tentar habilitar o Compiz
Pessoal...!
Instalei o Debian Wheezy e para minha surpresa dei de cara com o Gnome3, para mim aquilo é sem condições de usar.
Reinstalei o Debian e decidir me "aventurar" com o KDE, (A muito tempo que não usava o KDE, tinha usado na ápoca do Kurumin).
Estou simplesmente maravilhado o KDE amadureceu muito.
E por aqui tudo funcionando todos os meu aplicativos que preciso, e os efeitos da janelas e animações.
100%
Obrigado GNU Matador de Leões pela tentativa..!
Mas em resumo o problema era o drive de minha placa de vídeo Intel sandy bridge que o kernel do debian 6 não tinha suporte.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 2 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS