Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
mensagem erro firewall
24/06/2013, 13:28 (Resposta editada pela última vez em: 24/06/2013 13:29 por luisteixeira25.)
Resposta: #1
mensagem erro firewall
boa tarde amigos,
configurei o firewall em /etc/init.d, dei a permissão de execução.
mas qdo dei o comando update-rc.d firewall defaults, dá a seguinte mensagem de erro:
update-rc.d: using dependency based boot sequencing
insserv: warning: script 'firewall' missing LSB tags and overrides

meu firewall:

#!/bin/bash
# Script de configuração do iptables gerado pelo configurador do Kurumin
# Este script pode ser usado em outras distribuições Linux que utilizam o
# Kernel 2.4 em diante
# Por Carlos E. Morimoto

# Abre para uma faixa de endereços da rede local
iptables -A INPUT -p tcp --syn -s 192.168.13.0/255.255.255.240 -j ACCEPT

# Abre uma porta (inclusive para a Internet)
iptables -A INPUT -p tcp --destination-port 22 -j ACCEPT

# Ignora pings
#echo "1" > /proc/sys/net/ipv4/icmp_echo_ignore_all

# Proteções diversas contra portscanners, ping of death, ataques DoS, etc.
iptables -A FORWARD -p icmp --icmp-type echo-request -m limit --limit 1/s -j ACCEPT
iptables -A FORWARD -p tcp -m limit --limit 1/s -j ACCEPT
iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -p tcp --tcp-flags SYN,ACK,FIN,RST RST -m limit --limit 1/s -j ACCEPT
iptables -A FORWARD --protocol tcp --tcp-flags ALL SYN,ACK -j DROP
iptables -A FORWARD -m unclean -j DROP

# Abre para a interface de loopback.
iptables -A INPUT -p tcp --syn -s 127.0.0.1/255.0.0.0 -j ACCEPT

# Compartilha a conexão
modprobe iptable_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

# Ignora qualquer pacote de entrada, vindo de qualquer endereço, a menos que especificado o contrário acima. Bloqueia tudo.
iptables -A INPUT -p tcp --syn -j DROP

até mais

Luis - Linux User: #420124
ºvº. | Linux, porque eu amo a liberdade!
/(L)\ | Socialmente justo, economicamente viável e tecnologicamente sustentável
.^.^.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/06/2013, 23:35
Resposta: #2
RE: mensagem erro firewall
esta mensagem aparece depois de instalar qualquer serviço.
vejam a mensagem depois de instalar o bind.

[ ok ] Starting domain name service...: bind9.
insserv: warning: script 'K01firewall' missing LSB tags and overrides
insserv: warning: script 'firewall' missing LSB tags and overrides

alguém poderia me informar o que significa?
até mais

Luis - Linux User: #420124
ºvº. | Linux, porque eu amo a liberdade!
/(L)\ | Socialmente justo, economicamente viável e tecnologicamente sustentável
.^.^.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/06/2013, 10:18
Resposta: #3
RE: mensagem erro firewall
Para fazer iniciar no boot, execute "sudo update-rc.d firewall start 99 2 3 4 5 . stop 0 1 6 ."
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/06/2013, 20:47
Resposta: #4
RE: mensagem erro firewall
bom dia amigo,
resultado no comando que me passou acima:
[email protected]:/home/luis# update-rc.d firewall start 99 2 3 4 5 . stop 0 1 6 .
update-rc.d: using dependency based boot sequencing
insserv: warning: script 'K01firewall' missing LSB tags and overrides
insserv: warning: script 'firewall' missing LSB tags and overrides
insserv: warning: current start runlevel(s) (empty) of script `firewall' overrides LSB defaults (2 3 4 5).

até mais

Luis - Linux User: #420124
ºvº. | Linux, porque eu amo a liberdade!
/(L)\ | Socialmente justo, economicamente viável e tecnologicamente sustentável
.^.^.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/06/2013, 21:29
Resposta: #5
RE: mensagem erro firewall
Boa noite,

Você precisa adicionar um cabeçalho informando as dependências do serviço que será iniciado no boot. Exemplo:

Código:
#!/bin/sh
### BEGIN INIT INFO
# Provides:          firewall.sh
# Required-Start:    $local_fs $remote_fs $network $syslog
# Required-Stop:     $local_fs $remote_fs $network $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Start firewall.sh at boot time
# Description:       Enable service provided by firewall.sh.
### END INIT INFO

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/06/2013, 17:51
Resposta: #6
RE: mensagem erro firewall
boa tarde amigos,
depois de muita luta consegui, mas ainda está dando a seguinte mensagem:
iptables: No chain/target/match by that name.

até mais

Luis - Linux User: #420124
ºvº. | Linux, porque eu amo a liberdade!
/(L)\ | Socialmente justo, economicamente viável e tecnologicamente sustentável
.^.^.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/06/2013, 21:30
Resposta: #7
RE: mensagem erro firewall
Boa noite luisteixeira25,

Apenas para que eu possa entender.

1) O seu primeiro problema era referente ao cabeçalho do script (dependências)? Correto? Não está mais acontecendo?

2) O segunda mensagem que você postou está dizendo que a chain ou o alvo de destino da regra não foi encontrado com o nome indicado. Para verificarmos este problema, peço novamente, que você poste o conteúdo do seu script de firewall e a versão do iptables, e também a saída do comando abaixo, com o firewall de pé:
Código:
iptables --list-rules

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/06/2013, 21:52
Resposta: #8
RE: mensagem erro firewall
boa noite vadinhodebian,
segue o que vc pediu:

iptables v1.4.14

firewall
# Abre para uma faixa de endereços da rede local
iptables -A INPUT -p tcp --syn -s 192.168.13.0/255.255.255.240 -j ACCEPT

# Abre uma porta (inclusive para a Internet)
iptables -A INPUT -p tcp --destination-port 22 -j ACCEPT
# permite conexões no servidor de dns
iptables -A INPUT -p tcp -m tcp --dport 53 -j ACCEPT
iptables -A INPUT -p udp -m udp --dport 53 -j ACCEPT

# Ignora pings
#echo "1" > /proc/sys/net/ipv4/icmp_echo_ignore_all

# Proteções diversas contra portscanners, ping of death, ataques DoS, etc.
iptables -A FORWARD -p icmp --icmp-type echo-request -m limit --limit 1/s -j ACCEPT
iptables -A FORWARD -p tcp -m limit --limit 1/s -j ACCEPT
iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -p tcp --tcp-flags SYN,ACK,FIN,RST RST -m limit --limit 1/s -j ACCEPT
iptables -A FORWARD --protocol tcp --tcp-flags ALL SYN,ACK -j DROP
iptables -A FORWARD -m unclean -j DROP

# Abre para a interface de loopback.
iptables -A INPUT -p tcp --syn -s 127.0.0.1/255.0.0.0 -j ACCEPT

# Compartilha a conexão
modprobe iptable_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

saída do comando iptables --list-rules:
-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT
-A INPUT -s 192.168.13.0/28 -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -j ACCEPT
-A INPUT -p tcp -m tcp --dport 22 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 53 -j ACCEPT
-A INPUT -p udp -m udp --dport 53 -j ACCEPT
-A INPUT -s 127.0.0.0/8 -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -j ACCEPT
-A FORWARD -p icmp -m icmp --icmp-type 8 -m limit --limit 1/sec -j ACCEPT
-A FORWARD -p tcp -m limit --limit 1/sec -j ACCEPT
-A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT
-A FORWARD -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK RST -m limit --limit 1/sec -j ACCEPT
-A FORWARD -p tcp -m tcp --tcp-flags FIN,SYN,RST,PSH,ACK,URG SYN,ACK -j DROP

até mais

Luis - Linux User: #420124
ºvº. | Linux, porque eu amo a liberdade!
/(L)\ | Socialmente justo, economicamente viável e tecnologicamente sustentável
.^.^.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/07/2013, 14:37
Resposta: #9
RE: mensagem erro firewall
Boa tarde,

Qual a versão do seu kernel:
Código:
uname -a

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/07/2013, 21:22
Resposta: #10
RE: mensagem erro firewall
Linux servidor 3.2.0-4-686-pae #1 SMP Debian 3.2.46-1 i686 GNU/Linux

Luis - Linux User: #420124
ºvº. | Linux, porque eu amo a liberdade!
/(L)\ | Socialmente justo, economicamente viável e tecnologicamente sustentável
.^.^.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/07/2013, 15:11
Resposta: #11
RE: mensagem erro firewall
Boa tarde,

Experimente alterar a regra de:
Código:
iptables -A FORWARD -p tcp --tcp-flags SYN,ACK,FIN,RST RST -m limit --limit 1/s -j ACCEPT

Para:
Código:
iptables -A FORWARD -p tcp --tcp-flags SYN,ACK,FIN,RST -m limit --limit 1/s -j ACCEPT

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/07/2013, 09:42
Resposta: #12
RE: mensagem erro firewall
bom dia amigo,
depois da alteração dá a seguinte mensagem:
iptables v1.4.14: --tcp-flags requires two args.
Try `iptables -h' or 'iptables --help' for more information.
iptables: No chain/target/match by that name.

mas fiz algumas alteração no fairewall:
#!/bin/sh
### BEGIN INIT INFO
# Provides: firewall.sh
# Required-Start: $local_fs $remote_fs $network $syslog
# Required-Stop: $local_fs $remote_fs $network $syslog
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Start firewall.sh at boot time
# Description: Enable service provided by firewall.sh.
### END INIT INFO

echo "Carregando o firewall..."

# Interface da Internet:
ifinternet="eth0"

# Interface da rede local
iflocal="eth1"

iniciar(){

# Abre para uma faixa de endereços da rede local
iptables -A INPUT -p tcp --syn -s 192.168.13.0/255.255.255.240 -j ACCEPT

# Abre uma porta (inclusive para a Internet)
iptables -A INPUT -p tcp --destination-port 22 -j ACCEPT

# permite conexões no servidor de dns
iptables -A INPUT -p tcp -m tcp --dport 53 -j ACCEPT
iptables -A INPUT -p udp -m udp --dport 53 -j ACCEPT
# Ignora pings
#echo "1" > /proc/sys/net/ipv4/icmp_echo_ignore_all

# Proteções diversas contra portscanners, ping of death, ataques DoS, etc.
iptables -A FORWARD -p icmp --icmp-type echo-request -m limit --limit 1/s -j ACCEPT
iptables -A FORWARD -p tcp -m limit --limit 1/s -j ACCEPT
iptables -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -p tcp --tcp-flags SYN,ACK,FIN,RST -m limit --limit 1/s -j ACCEPT
iptables -A FORWARD --protocol tcp --tcp-flags ALL SYN,ACK -j DROP
iptables -A FORWARD -m unclean -j DROP

# Abre para a interface de loopback.
iptables -A INPUT -p tcp --syn -s 127.0.0.1/255.0.0.0 -j ACCEPT

# Compartilha a conexão
modprobe iptable_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o $ifinternet -j MASQUERADE
iptables -t nat -A PREROUTING -i $iflocal -p tcp --dport 80 -j REDIRECT --to-port 3128
# Ignora qualquer pacote de entrada, vindo de qualquer endereço, a menos que especificado o contrário acima. Bloqueia tudo.
#iptables -A INPUT -p tcp --syn -j DROP
}

parar(){
iptables -F
iptables -F -t nat
}

case "$1" in
"start") iniciar ;;
"stop") parar ;;
"restart") parar; iniciar ;;
*) echo "Use os parâmetros start ou stop"
esac

echo "Firewall carregado..."

até mais

Luis - Linux User: #420124
ºvº. | Linux, porque eu amo a liberdade!
/(L)\ | Socialmente justo, economicamente viável e tecnologicamente sustentável
.^.^.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS