Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Configuraçao de teclado - abnt2 - acentos n~ao funcionam
27/06/2013, 12:57
Resposta: #1
Configuraçao de teclado - abnt2 - acentos n~ao funcionam
Ola!

Minhas sessoes no Gnome estao sem acentuaçao (^e, ´e, ~a, etc)
Nos tty[1:6] tudo acentuando normal.

Estou usando debian Wheezy em um netbook acer aspire (teclado com ç). Algum programa que instalei, ou atualizaç~ao, fez com que eu perdesse o teclado funcional. (n~ao consigo me lembrar quando =/ )

meu /etc/default/keyboard
Código:
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="br"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

fica desse jeito, e na configuraçao grafica do sistema, nao existe uma possibilidade de inserir o layout abnt2.

Jah tentei deixar o XKBVARIANT="abnt2", mas isso tb nao mudou qualquer coisa nas acentuaçoes.

Alguma indicaçao de soluç~ao?
Muito obrigado.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/06/2013, 19:40
Resposta: #2
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
estranho, talvez vc tenha atualizado o xorg, aqui esse arquivo no default está assim:
XKBMODEL="pc105"
XKBLAYOUT="br"
XKBVARIANT="abnt2"
XKBOPTIONS=""

verifique se vc possue o xorg.conf e como está configurado a seção do teclado lá.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/06/2013, 07:00
Resposta: #3
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
Ola Dmatrix,

Eu esqueci de dizer, mas nao tenho xorg.conf, nem o diretorio xorg.conf.d

Obrigado
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/06/2013, 09:49
Resposta: #4
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
então, tenho um notebook com teclado internacional que estava acontecendo isso, na console beleza mas no gráfico errado, aí eu ia no gerenciado do teclado grafico e configurava o teclado, daí ele funcionava certo mas ao reiniciar voltava a ficar errado, tava vendo aqui e num tem o xorg.conf tb, pode ser isso. Faz um tempo que não ligo ele e me lembro se resolveu isso, vou verificar pois ainda não tem xorg.conf nele.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/06/2013, 09:55 (Resposta editada pela última vez em: 28/06/2013 09:56 por pierrot.)
Resposta: #5
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
Valeu!

Eu ja pesquisei por todo o google, bug reports do gnome, mas sempre que relatam o problema eh de alguma maquina antiga, onde conseguem mudar configuraçoes no proprio xorg.conf

Ja rodei algumas vezes o dpkg-reconfigure keyboard-configuration para testar algumas outras coisas, mas nada ficou funcional ao acentuar.

Alias, pq o xorg.conf caiu em desuso?

Obrigado por qualquer ajuda.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/06/2013, 22:46
Resposta: #6
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
Boa noite,

Eu ainda utilizo o xorg.conf e funciona normalmente.
Mas vamos lá... Como estão as configurações de Região e Idioma e as disposições que você está utilizando. Você já verificou?

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/06/2013, 22:58
Resposta: #7
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
Ola Vadinho,

Eu jah tentei fazer a configuraçao direta por modo grafico, onde o keymap que estah selecionado eh exatamente o meu teclado, entretanto ele estah sem dead keys. Infelizmente nao existe essa opçao, com o teclado Portuguese (Brazil)

[Imagem: 5eExg4E.png]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/06/2013, 21:26
Resposta: #8
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
(28/06/2013 22:58)pierrot Escreveu:  Ola Vadinho,

Eu jah tentei fazer a configuraçao direta por modo grafico, onde o keymap que estah selecionado eh exatamente o meu teclado, entretanto ele estah sem dead keys. Infelizmente nao existe essa opçao, com o teclado Portuguese (Brazil)

[Imagem: 5eExg4E.png]
seu gráfico é o gnome?
aqui estava vendo no notebook que não tem o xorg.conf e o problema era que não estava executando o gnome-settings-daemon, com isso a configuração que fazia utilizanfo o gnome-keyboard-properties não fixava ao reiniciar. Tenta reconfigurar o teclado usando um terminal root e chamando a ferramenta gnome-keyboard-properties. Não entendi sobre as teclas mortas (deadkeys) lá nas configurações do teclado tem sim como configurar o tecla com essas teclas.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/06/2013, 21:47
Resposta: #9
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
Boa noite,

Qual a marca dou seu teclado. Será que ele está sendo reconhecido corretamente pelo udev?

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/06/2013, 23:38
Resposta: #10
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
Como posso descobrir a marca do teclado?
Com o lspci, nada sobre teclado eh retornado.
Meu /proc/modules nao encontrei nada especifico sobre o teclado.

No /etc/udev/rules.d/ nem em udev.conf, nem em links.conf aparecem qqer descriçao sobre o teclado.

segue a descriçao onboard
Código:
00:00.0 Host bridge: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx DMI Bridge
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
00:02.1 Display controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 02)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation NM10/ICH7 Family SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 02)
01:00.0 Ethernet controller: Atheros Communications Inc. AR8152 v1.1 Fast Ethernet (rev c1)
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/07/2013, 14:53
Resposta: #11
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
não entendo porque na sua janela aparece "Região e Idioma" enquanto no meu debian aparece "Preferências do teclado" acho que está usando outro utilitário. Mas como não respondeu então deve ser kde.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/07/2013, 15:25
Resposta: #12
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
Boa tarde,

Tente fazer o seguinte:
Código:
mkdir /etc/X11/xorg.conf.d
cp /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/

Depois de copiar o arquivo, procure pela Section definida com a configuração MatchIsKeyboard e adicione a está seção as variáveis de layout do teclado, conforme exemplo:
Código:
Section “InputClass”
Identifier “evdev keyboard catchall”
MatchIsKeyboard “on”
MatchDevicePath “/dev/input/event*”
Driver “evdev”
        Option “XkbLayout” “br”
        Option "XkbModel" "pc105"
        Option "XkbVariant" "abnt2"
EndSection

Depois reinicie o servidor X e verifique se as acentuações voltaram a funcionar.

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/07/2013, 15:59
Resposta: #13
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
Olá dmatrix,

desculpe, mas acabei não lendo sua resposta.
Achei que era a minha resposta, com a inserção das figuras e acabei não lendo as suas palavras.
Sim, minha interfácie gráfica é Gnome, com gdm3.
Estranho pois não aparece mesmo essa possibilidade de escolher o teclado COM dead keys.
Existe sim a opção de "eliminate dead keys".
Em outro Debian, que estou agora, a interfacie grafica para escolha de teclado é a mesma que no netbook. Inclusive o teclado é com a mesma configuração (teclado com ç e ~), mas aqui tá funcionando. =/
O que é muito estranho.

Não tenho a ferramenta do gnome para acessar os teclados.
# gnome-keyboard-properties
bash: gnome-keyboard-properties: comando não encontrado

Abraço
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/07/2013, 16:26
Resposta: #14
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
instale o pacote gnome-control-center que contém essa ferramenta. Estou atualizando o meu debian para wheezy para ver se essa ferramenta mudou.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/07/2013, 09:31 (Resposta editada pela última vez em: 05/07/2013 09:32 por pierrot.)
Resposta: #15
RE: Configuraçao de teclado - abnt2 - acentos n~ao funcionam
Oi Dmatrix,
Tento instalar e diz não ter candidato para instalação.
E, mesmo assim, a ferramenta gnome-keyboard-properties dah not found.

Desculpem a demora nas mensagens, mas não sei porque, não estou recebendo as notificações de resposta. [estranho].
Oi Vandinho,

Desculpa por não responder antes. As mensagens de notificação não estão sendo enviadas ao meu e-mail!

Agora que vi a sua resposta.
Vou testar incluir o xorg.conf, e logo retorno com respostas!

Valeu.

(01/07/2013 15:25)vadinhodebian Escreveu:  Boa tarde,

Tente fazer o seguinte:
Código:
mkdir /etc/X11/xorg.conf.d
cp /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/

Depois de copiar o arquivo, procure pela Section definida com a configuração MatchIsKeyboard e adicione a está seção as variáveis de layout do teclado, conforme exemplo:
Código:
Section “InputClass”
Identifier “evdev keyboard catchall”
MatchIsKeyboard “on”
MatchDevicePath “/dev/input/event*”
Driver “evdev”
        Option “XkbLayout” “br”
        Option "XkbModel" "pc105"
        Option "XkbVariant" "abnt2"
EndSection

Depois reinicie o servidor X e verifique se as acentuações voltaram a funcionar.

Até mais...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS