Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
apt-get com pacote recorrente
16/05/2010, 20:01
Resposta: #1
apt-get com pacote recorrente
Toda vez que eu uso o apt-get install ele pede para que eu termine uma instalação interrompida antiga,
eu já instalei o java na unha (sem o apt) entao eu quero que ele pare de pedir isso.

Segue abaixo exemplo com o xchat

Código:
# apt-get install xchat
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
Os seguintes pacotes foram automaticamente instalados e não são mais requeridos:
  bluez-gnome libcommons-collections3-java gappletviewer-4.3 eclipse-jdt-gcj
  junit4 libmtp7 libecj-java libcommons-pool-java eclipse-source eclipse-jdt
  libgksu1.2-0 python-notify eclipse-pde liblucene-java libgda3-common
  python-gnome2-extras libgksuui1.0-1 eclipse-rcp evolution-exchange
  libcommons-el-java antlr junit rhythmbox libcommons-modeler-java
  system-config-printer eclipse-pde-gcj libantlr-java ecj-gcj
  libswt3.2-gtk-java libgpod3 libtomcat5.5-java gnome-themes-extras
  ant-optional-gcj ant libcommons-launcher-java gcj-4.3
  libcommons-logging-java ecj python-eggtrayicon gjdoc gnome-spell libgcj9-dev
  eclipse-platform-gcj libcommons-dbcp-java zlib1g-dev
  libcommons-collections-java libcommons-beanutils-java java-gcj-compat-dev
  libgcj9-src libcommons-digester-java python-4suite-xml libgda3-3
  libswt3.2-gtk-gcj eclipse-platform libservlet2.3-java liblucene-java-doc
  libjsch-java libswt3.2-gtk-jni libecj-java-gcj ant-gcj ant-optional
  transmission-common libantlr-java-gcj libgdl-1-0 serpentine libopenobex1
  transmission-gtk libgdl-1-common eclipse-rcp-gcj gnome-vfs-obexftp
Use 'apt-get autoremove' para removê-los.
Os pacotes extra a seguir serão instalados:
  tcl8.4 xchat-common
Pacotes sugeridos:
  tclreadline libnet-google-perl
Os NOVOS pacotes a seguir serão instalados:
  tcl8.4 xchat xchat-common
0 pacotes atualizados, 3 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
É preciso baixar 2554kB de arquivos.
Depois desta operação, 7287kB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? s
Obter:1 http://ftp.br.debian.org lenny/main tcl8.4 8.4.19-2 [1175kB]
Obter:2 http://ftp.br.debian.org lenny/main xchat-common 2.8.6-2.1 [1063kB]    
Obter:3 http://ftp.br.debian.org lenny/main xchat 2.8.6-2.1 [316kB]            
Baixados 2554kB em 37s (68,6kB/s)                                              
Selecionando pacote previamente não selecionado tcl8.4.
(Lendo banco de dados ... 103146 arquivos e diretórios atualmente instalados).
Desempacotando tcl8.4 (de .../tcl8.4_8.4.19-2_i386.deb) ...
Selecionando pacote previamente não selecionado xchat-common.
Desempacotando xchat-common (de .../xchat-common_2.8.6-2.1_all.deb) ...
Selecionando pacote previamente não selecionado xchat.
Desempacotando xchat (de .../xchat_2.8.6-2.1_i386.deb) ...
Processando gatilhos para man-db ...
Processando gatilhos para menu ...
Configurando sun-java6-doc (6-12-1) ...
This package is an installer package, it does not actually contain the
JDK documentation.  You will need to go download one of the
archives:

    jdk-6u12-docs.zip jdk-6u12-docs-ja.zip

(choose the non-update version if this is the first installation).
Please visit

    http://java.sun.com/javase/downloads/

now and download.  The file should be owned by root.root and be copied
to /tmp.

[Press RETURN to try again, 'no' + RETURN to abort] no
Abort installation of JDK documentation
dpkg: erro processando sun-java6-doc (--configure):
sub-processo post-installation script retornou estado de saída de erro 1
Configurando tcl8.4 (8.4.19-2) ...
Configurando xchat-common (2.8.6-2.1) ...
Configurando xchat (2.8.6-2.1) ...
Processando gatilhos para menu ...
Erros foram encontrados durante o processamento de:
sun-java6-doc
E: Sub-process /usr/bin/dpkg returned an error code (1)

[Imagem: 38572.png]
[Imagem: 2534zq4.jpg]
[Imagem: 19980.jpg]
[Imagem: 10494dt9.png]
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/05/2010, 23:16
Resposta: #2
Re: apt-get com pacote recorrente
Use o aptitude e procure pelo parametro unhold.

Lucas Saliés Brum
site | blog | telegram | medium | vk | twitter | github | .share
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/05/2010, 22:02
Resposta: #3
Re: apt-get com pacote recorrente
SOLUÇÃO


Código:
#apt-get install -f


o sistema ofereceu a solução
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS