Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Felinux
31/12/2014, 09:30
Resposta: #1
Felinux
após instalar nvidia 173 o xtartx não abre e recebo este aviso= xauth:(argr):1: bad display name "debian:0" in "remove" comand

Alguma ajuda para resolver isto, Obrigado

Xorg.0.log
[ 772.033] (II) NOUVEAU(0): Modeline "1440x900"x0.0 88.75 1440 1488 1520 1600 900 903 909 926 +hsync -vsync (55.5 kHz e)
[ 772.033] (II) NOUVEAU(0): Modeline "1440x900"x0.0 136.75 1440 1536 1688 1936 900 903 909 942 -hsync +vsync (70.6 kHz e)
[ 772.033] (II) NOUVEAU(0): Modeline "1280x1024"x0.0 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync (64.0 kHz e)
[ 772.033] (II) NOUVEAU(0): Modeline "1280x960"x0.0 108.00 1280 1376 1488 1800 960 961 964 1000 +hsync +vsync (60.0 kHz e)

parece que esta usando o NOVEAU, quando abre, depois de tentar vários comandos,
mas ao reiniciar tenho que fazer td de novo ?????
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/01/2015, 07:33
Resposta: #2
RE: Felinux
Bem vindo! verifique se no direitório /etc/modprobe.d existe um arquivo .conf com as linhas:
Código:
# generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0

caso não exista crie um com elas e reinicie, veja se o problema ainda ocorre.
verifique se no lsmod ainda está carregando o nouveau:
# lsmod | grep nouveau

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/01/2015, 21:47
Resposta: #3
RE: Felinux
dmatrix=obrigado pela ajuda
meu arquivo= blacklist.conf

blacklist amd76x_edac #this might not be required for x86 32 bit users.
blacklist vga16fb
blacklist nouveau
options nouveau modeset=0
blacklist rivafb
blacklist nvidiafb
blacklist rivatv
--------------------------------------
removi todo drive nvidia não livre, e agora esta subindo o X normal, só que
as config de tela não da a opção 1440x900. se criar um xorg.config, não
sobe o X
detalhe= tenho 2GB de RAM e minha placa é NV44A GeForce 6200
além da imagem ruim, quando abre imagens pesadas ou executo muita coisas,
simplesmente o X reinicia (não tenho como aumentar a memória)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/01/2015, 22:37 (Resposta editada pela última vez em: 06/01/2015 22:43 por dmatrix.)
Resposta: #4
RE: Felinux
Para instalar utilizou o driver da nvidia do fabricante? http://www.nvidia.com.br/download/driver...x/59849/br http://www.nvidia.com.br/download/driver...x/59903/br

Lembro ainda que para se ter uma resolução apropriada muitas vezes temos que especificar a frequencias do monitor, por exemplo o meu xorg está assim:
Código:
....
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "GSM"
    ModelName      "20Si"
    HorizSync       30.0 - 54.0
    VertRefresh     50.0 - 90.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    Modes        "1920x1440" "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
07/01/2015, 20:42
Resposta: #5
RE: Felinux
então amigo, com o nvidia-installer --uninstall acho que foi removido os drivers nvidia, parece-me que só está o nouveau.
Já existe um xorg.conf
--------------------------------------------------
# Xorg.conf universal

Section "ServerFlags"
# Essa opção deixa o xorg abrir mesmo que se tenha um erro no
# mouse.
Option "AllowMouseOpenFail" "true"
EndSection

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "ddc"
Load "dbe"
Load "extmod"
Load "bitmap"
Load "type1"
Load "speedo"
Load "freetype"
Load "record"
EndSection

#
# Nessa parte temos dois tipos de teclado, o ABNT2 e o Americano
# Internacional, deixamos o ABNT2 por padrão, caso você use o
# Americano Internacional descomente as linhas dele
# (é só remover o # no início de cada linha)
# e remover as linhas do ABNT2.
#

###### Teclado ABNT2 ######
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
Option "XkbVariant" "abnt2"
EndSection
###### Fim do Teclado ABNT2 ######

###### Teclado americano internacional ######
#Section "InputDevice"
# Identifier "Generic Keyboard"
# Driver "kbd"
# Option "CoreKeyboard"
# Option "XkbRules" "xorg"
# Option "XkbModel" "pc105"
# Option "XkbLayout" "us_intl"
#EndSection
####### Fim do americano internacional ######

#
# Aqui estão os mouses, você não precisa remover nenhum deles
# pois o Xorg irá aceitar qualquer um já que temos a diretiva
# "AllowMouseOpenFail" setada como "true" acima.
#

# Mouse PS/2
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "Auto"
Option "Emulate3Buttons" "true"
EndSection

# Mouse USB
Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
Option "Resolution" "650"
EndSection

# Mouse Serial em ttys0
Section "InputDevice"
Identifier "Mouse2"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/ttys0"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
Option "Resolution" "650"
EndSection

# Mouse Serial em ttys1
Section "InputDevice"
Identifier "Mouse3"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/ttys1"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
Option "Resolution" "650"
EndSection

Section "Device"
Identifier "Placa de Vídeo Genérica"
# Em raros caso, comente o vesa e descomente o fbdev
Driver "vesa"
# Driver "fbdev"
EndSection

Section "Monitor"
Identifier "SAMSUNG SyncMaster"
Option "DPMS"
HorizSync 30-81
VertRefresh 56-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "rdCR.HA5+NUvfiuD"
Monitor "SAMSUNG SyncMaster"
DefaultDepth 32
SubSection "Display"
Depth 16
Modes "1440x900" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Mouse0"
InputDevice "Mouse1"
InputDevice "Mouse2"
InputDevice "Mouse3"
EndSection

Section "DRI"
Mode 0666
EndSection
-------------------------------------
A resolução que esta rodando é a 1024x768 (61HZ)

Obrigado pela ajuda.....
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/01/2015, 22:16
Resposta: #6
RE: Felinux
Veja, se esse xorg.conf está ativo então o seu sistema está utilizando o driver generico vesa, nada de nvidia e nouveau, desta forma vai abrir o gráfico mas num vai poder utilizar todos os recursos da placa de video, derrube o gráfico e tente instalar o driver da nvidia e observe se o xorg com nvidia vai funcionar o gráfico. Tem um wiki aqui no forum, um pouco desatualizado mas pode ajudar instalar a nvidia.
Código:
Section "Device"
Identifier "Placa de Vídeo Genérica"
# Em raros caso, comente o vesa e descomente o fbdev
Driver "vesa"
# Driver "fbdev"
EndSection

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/01/2015, 11:55
Resposta: #7
RE: Felinux
Ok vou tentar, obrigado.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS