Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Samba 4
19/02/2016, 12:59
Resposta: #1
Samba 4
Bom dia a todos,

Estou com uma duvida referente a instalação de pacotes com uma determinada versão do mesmo via apt-get.
Vou dar um exemplo que fica mais fácil.

Cenário
Servidor 1 - Debian 8 64x
Pacote instalado via apt-get: samba 4.1.17
Obs.: Faço backup dos arquivos do samba, para que se um dia der problemas eu possa restaurar em outro servidor físico novamente.

O restore de acordo com site do samba só funciona se o pacote dele for a mesma versão do que foi feito backup.

Daqui 1 ou 2 anos o pacote do samba atualiza para 4.3.4 no repositório. Se eu precisar instalar este pacote com a versão 4.1.17 novamente, como eu poderia fazer isso?

Eu baixei o .deb deste link: https://packages.debian.org/jessie/amd64/samba/download
Mais não consegui instalar devido as dependências, se tiver uma forma de fazer isso usando o apt-get já agiliza um tempão e infelizmente a infra disponível não tem como adicionar um domínio secundário.

Desde já agradeço.
Abraços.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/02/2016, 16:56
Resposta: #2
RE: Samba 4
Não tenho muita experiência com o Samba, mas acredito q apenas fazendo o restore do arquivo /etc/samba/smb.conf vc consegue migrar as configurações de uma versão pra outra. Mesmo se daqui a 2 anos a versão do Samba mudar radicalmente, é muito difícil que as suas configurações atuais sejam perdidas (alguém me corrija se eu estiver errado)

Outra coisa: se vc usa o Debian 8, não haveria necessidade de vc baixar o .deb desse link aí pq é desse repositório jessie q o apt-get puxa os pacotes da versão 4.1.17, e essa é a última versão disponível nos repositórios do Debian, não sendo possível baixar a última via apt-get (a não ser se ele estivesse disponível em algum repositório testing ou backports, mas hoje a versão 4.3 ainda não está disponível)

Espero ter ajudado
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/02/2016, 16:50
Resposta: #3
RE: Samba 4
(19/02/2016 16:56)davidcarvalho Escreveu:  Não tenho muita experiência com o Samba, mas acredito q apenas fazendo o restore do arquivo /etc/samba/smb.conf vc consegue migrar as configurações de uma versão pra outra. Mesmo se daqui a 2 anos a versão do Samba mudar radicalmente, é muito difícil que as suas configurações atuais sejam perdidas (alguém me corrija se eu estiver errado)

Outra coisa: se vc usa o Debian 8, não haveria necessidade de vc baixar o .deb desse link aí pq é desse repositório jessie q o apt-get puxa os pacotes da versão 4.1.17, e essa é a última versão disponível nos repositórios do Debian, não sendo possível baixar a última via apt-get (a não ser se ele estivesse disponível em algum repositório testing ou backports, mas hoje a versão 4.3 ainda não está disponível)

Espero ter ajudado

davidcarvalho,

Muito obrigado pelo retorno.
Então amigo, o smb.conf realmente não tem muitas alterações e ali o que mais é alterado são os compartilhamentos. Quanto a isso até que é tranquilo.

Mais o backup que estou fazendo é do /var/lib/samba ... assim consigo restaurar todo meu dominio com unidades, grupos e usuarios por exemplo. Funciona normalmente.

Porem no site do samba diz que as versões devem ser as mesmas. Então se eu tenho 4.1 e faço backup, só consigo restaurar na versão 4.1. Por isso tentei baixar o .deb do site, se um dia o pacote do samba for atualizado nos repositorios para sei lah ... 4.3 por exemplo. Eu ainda teria o 4.1 ...deb entendeu.

Mais pelo jeito não terá como mesmo.
O lance é manter o atual e instalado atualizado, para que se um dia der problemas eu consiga instalar a versão disponível e restauro todo o domínio.

Outra forma seria baixar os fontes e instalar manualmente mesmo. Assim baixaria e instalaria o fonte da versão que quiser do ftp do samba. Mais prefiro a opção acima, mais rápido e comodo.

Me ajudou sim, clareou pra eu chegar nesta conclusão.
Obrigado pela ajuda amigo.
Abraços.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/02/2016, 08:56
Resposta: #4
RE: Samba 4
Entendi, nesse caso, uma opção que seria interessante é manter uma base centralizada de todos os usuários e grupos no OpenLDAP, só não sei lhe dizer se é possível migrar as configs. atuais do Samba, caso tenha interesse dê uma pesquisada por "Integração Samba com OpenLDAP", abs.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/02/2016, 16:50
Resposta: #5
RE: Samba 4
(22/02/2016 08:56)davidcarvalho Escreveu:  Entendi, nesse caso, uma opção que seria interessante é manter uma base centralizada de todos os usuários e grupos no OpenLDAP, só não sei lhe dizer se é possível migrar as configs. atuais do Samba, caso tenha interesse dê uma pesquisada por "Integração Samba com OpenLDAP", abs.

Desta forma é como fazia no samba 3, a versão 4 já inclui o openldap. Economiza um tempinho né rsrsr. O ruim é que te amarra na Microsoft rsrsrs.

O que eu fiz foi o seguinte ...
- clonei o disco onde esta instalado o samba 4.1. Assim qualquer incidente eu posso restaurar o SO já com o samba na versão 4.1.
- Fiz o restore e esta tranquilo, já tirou essa preocupação da minha cabeça.

Obrigado pela ajuda.
Abs.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS