Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Error: Dependency is not satisfaiable: libcups2
24/02/2010, 17:54
Resposta: #16
Re: Error: Dependency is not satisfaiable: libcups2
dmatrix:

1-o problema do grafico foi resolvido em partes. agora aparece o gdm porem não consigo usar nada pois o mouse e o teclado não funcionam. tentei acessar o arquivo /etc/x11/xf86config pelo mcedit porem não consegui, diz que o programa não pode abrir o arquivo para leitura.

2-quanto ao flash, enquanto eu estava fazendo o upgrade para o squeeze ja tinha sido concertado.

3-o "fstab" que postei era o fstab do ubuntu. e o resultado do comando "fdisk" é também do ubuntu. meu hd está configurado da seguinte maneira:

existem quatro partições pelo que vejo:

Citar:-> /dev/sda1 (partição ext3, onde está o ubuntu karmic)
->/dev/sda3 (partição ext3, onde está o debian squeeze)
->/dev/sda2 (partição extended, dentro dela existe uma outra partição denominada /dev/sda5 , na qual está escrito linux-swap)

estão gravadas nesta sequencia no disco.
tenho todos esses dados do hd através do g-parted.


aguardo analise.

choose linux.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/02/2010, 17:19
Resposta: #17
Re: Error: Dependency is not satisfaiable: libcups2
o arquivo para se editar é o /etc/X11/xorg.conf, xf86config é versão antiga do X nem se utiliza mais, agora é xorg.conf. Agora mouse e teclado sem funcionar é quase travado o X. Faz um teste, ao entrar na tela de menu do Grub posicione o cursor sobre o kernel de boot e tecle "e" entrando em modo de edição do grub, feito isso selecione a linha do kernel e tecle novamente "e" assim vá com o cursor até o final da linha e adicione acpi=off tecle "enter" e depois tecle "b" para continuar o boot e veja se muda algo no gdm.
caso negativo tente reconfigurar o pacote com:
# dpkg-reconfigure gdm
no caso da partição do ubuntu vc pode acessá-la adicionando:
# cd /media
# mkdir ubuntu
e edite o fstab adicionando a linha:
/dev/sda1 /media/ubuntu ext3 relatime,errors=remount-ro 0 1

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/02/2010, 21:15
Resposta: #18
Re: Error: Dependency is not satisfaiable: libcups2
infelizmente não consegui resultado com nenhum dos dois comandos.
tentei o comando "Xorg -confiugre" o qual também não deu resultado algum.

agora pelo menos consigo acessar o arquivo de configuração do xorg pelo mcedit, porem não sei se e o que alterar.

update:
mais um maldito erro de dependcia. com o comando "aptitude safe-upgrade" obtive o seguinte resultado.

Citar:dependency error
xserver-xorg-core: depends: udev (>=149) but 0.125-7 + lenny3 is installed and it is kept back.


e com o "dpkg-reconfigure xserver-xorg":

Citar:xserver-xorg is broken or not fully installed

perdido de novo.

choose linux.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/02/2010, 22:09
Resposta: #19
Re: Error: Dependency is not satisfaiable: libcups2
rapaz não fique dando reconfigure no seu xorg pois se o gdm abre então o modo gráfico está funcionando, o que vc deve fazer é um backup deste arquivo xorg.conf antes que perca o gráfico novamente e aí sim vc pode alterá-lo. Talvez vc deva gerar um novo xorg.conf, tem um tópico aqui no forum sobre isso. Tá parecendo problema de falta de pacotes de fontes do X é preciso dar uma olhada na log do xorg ( var/log/xorg.log). Quando a mensagem de dependencia, veja que o pacote udev está configurado como mantido, vc deve forçar a instalação deste pacote:
# aptitude install udev

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/03/2010, 08:05
Resposta: #20
Re: Error: Dependency is not satisfaiable: libcups2
-tentei gerar um novo xorg.conf após o backup, não deu resultado.

-"# aptitude install -f udev" sem resultado também

-# tail /var/log/Xorg.0.log

Citar:(ii)chrome (0) [drm] freeing agp memory
(ii)chrome (0) [drm] releasing agp module
(ii)chrome (0) [drm] removed 1 reserved context for kernel
(ii)chrome (0) [drm] umaping 8192 bytes of SAREA 0xf8a0600 at 0xb7f3b000
(ii)chrome (0) [drm]
(ii)chrome (0) [drm] IRQ handler uninstaled
(ii)chrome (0) ViaRestore
(ii)chrome (0) ViaDisablePrimaryFIFO
(ii)chrome (0) ViaUnmapMen
-no fim das contas "# aptitude safe-upgrade" :

Citar:dependency error
xserver-xorg-core: depends: udev (>=149) but 0.125-7 + lenny3 is installed and it is kept back.

-me parece que o pacote udev tem conflitos com a versão do kernel e pede uma mais recente porem não sei como fazer o upgrade.

choose linux.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/03/2010, 09:47
Resposta: #21
Re: Error: Dependency is not satisfaiable: libcups2
Pelo que está postando não vejo nada relacionado com o kernel, a não ser que esteja omitindo mensagens sobre isso, a meu ver o pacote do udev está marcado como mantido.
vejamos, tente os comandos:
# aptitude update
# aptitude dist-upgrade
# aptitude update
# aptitude safe-upgrade

Veja saída de erros na log do xorg com:
# grep -i EE /var/log/Xorg.0.log

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/03/2010, 18:51
Resposta: #22
Re: Error: Dependency is not satisfaiable: libcups2
segui todos os passos e continua na mesma situação.
com o comando "# grep -i EE /var/log/Xorg.0.log" não obtive nenhum erro, está tudo correto.


em relação ao udev quando tentei forçar a instalação o apt informou que poderia desconfigurar o kernel e que era para atualizar o mesmo para um versão mais atual caso contrario haveria conflitos com o pacote udev.


o pacote está mantido e o X está travado.

choose linux.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/03/2010, 09:45
Resposta: #23
Re: Error: Dependency is not satisfaiable: libcups2
é estranho o dist-upgrade deveria ter atualizado a versão do kernel. Verifique a versão do kernel instalada com:
# uname -r
caso seja inferior ao 2.6.30 faça a atualização do kernel com o apt-get:
primeiro localize a ultima imagem de versão disponível do kernel com:
# aptitude search linux-image | grep 2.6
deve retornar uma lista com os pacotes de imagens disponíveis e entre elas a provável versão 2.6.30, então instale a imagem do kernel mais apropriada para arquitetura da sua máquina, se 64bits ou 32 ( pode seguir a mesma retornada pelo comando uname)
então instale:
# aptitude install linux-image-XXX
depois disso reinicie e selecione no grub a nova versão do kernel e assim verifique se o udev faz o upgrade:
# aptitude safe-upgrade

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/03/2010, 12:59
Resposta: #24
Re: Error: Dependency is not satisfaiable: libcups2
realizei os procedimentos e com algumas outras coisas o debian voltou a funcionar.
porem começaram a ocorrer problemas nas outras partições e a dar erros nos sistemas.

me vi forçado a formatar o hd e começar tudo novamente. agora que formatei o debian é o unico sistema operacional instalado. criei uma partição para a pasta home como vocês ja haviam me orientado e está tudo funcionando corretamente.

fico feliz de ver os esforços do pessoal aqui do fórum para tentar ajudar aos outros e principalmente o seu dmatrix.

embora eu tenha formatado o hd, eu tinha conseguido resolver o problema do debian com a ajuda de vocês a formatação veio depois devido a outros problemas.


só tenho uma ultima duvida. devo tentar atualizar o lenny para o squeeze? ha alguma vantagem?



muito obrigado por tudo, por continuar até o final da maratona rs rs. agradeço muito o tempo dedicado e todos os esforços vou tentar ajudar aos outros também.

choose linux

choose linux.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/03/2010, 14:53
Resposta: #25
Re: Error: Dependency is not satisfaiable: libcups2
Romulo Escreveu:só tenho uma ultima duvida. devo tentar atualizar o lenny para o squeeze? ha alguma vantagem?
Romulo, se não me engano já havia feito essa pergunta e respondido neste tópico.
eu utilizo o squeeze no desktop e lenny no notebook, a única coisa que me incomoda é o sumiço do botão desligar no gnome. A opção de um ou outro vai mais por querer um sistema com pacotes mais recentes ou ainda a necessidade de instalar programas que requerem bibliotecas mais novas ou kernel, o que me parece ser o seu caso.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/03/2010, 01:00
Resposta: #26
Re: Error: Dependency is not satisfaiable: libcups2
Pessoal, e qual a maneira mais fácil de atualizar o Kernel? Isso sempre acontece quando uma versão mais nova está para sair?
Agradeço a atenção.
Abraço a todos.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/03/2010, 08:10
Resposta: #27
Re: Error: Dependency is not satisfaiable: libcups2
Você pode atualizar pelo apt-get...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/03/2010, 16:35
Resposta: #28
Re: Error: Dependency is not satisfaiable: libcups2
Cara, isso poderia ser feito assim?

#aptitude install -f linux-image-<versao>

Por que se o procedimento for este, olha o erro:

notebook:/home/neto# aptitude install -fy linux-image-2.6.32-2-686
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Lendo descrições de tarefas... Pronto
Os pacotes a seguir estão QUEBRADOS:
hal
Os NOVOS pacotes a seguir serão instalados:
firmware-linux-free{a} linux-image-2.6.32-2-686
Os pacotes a seguir serão REMOVIDOS:
alacarte{u} capplets-data{u} cheese{u} deskbar-applet{u} dmz-cursor-theme{u} ekiga{u} eog{u} evince{u} evolution{u} evolution-common{u}
evolution-data-server{u} evolution-data-server-common{u} fast-user-switch-applet{u} gcalctool{u} gconf-editor{u} gdm{u} gedit{u} gedit-common{u}
gnome-about{u} gnome-applets{u} gnome-applets-data{u} gnome-backgrounds{u} gnome-control-center{u} gnome-desktop-data{u} gnome-media{u}
gnome-media-common{u} gnome-menus{u} gnome-netstatus-applet{u} gnome-nettool{u} gnome-network-admin{u} gnome-panel{u} gnome-panel-data{u}
gnome-power-manager{u} gnome-screensaver{u} gnome-session{u} gnome-settings-daemon{u} gnome-system-monitor{u} gnome-system-tools{u}
gnome-user-guide{u} gnome-utils{u} gnome-volume-manager{u} gstreamer0.10-gnomevfs{u} gstreamer0.10-tools{u} gtk2-engines{u} gtkhtml3.14{u}
gucharmap{u} libapm1{u} libavahi-ui0{u} libbluetooth2{u} libcairomm-1.0-1{u} libcpufreq0{u} libcupsys2{u} libdjvulibre-text{u} libdjvulibre21{u}
libdmx1{u} libebook1.2-9{u} libecal1.2-7{u} libedata-book1.2-2{u} libedata-cal1.2-6{u} libedataserverui1.2-8{u} libeel2-2.20{u} libeel2-data{u}
libegroupwise1.2-13{u} libepc-1.0-1{u} libepc-ui-1.0-1{u} libexchange-storage1.2-3{u} libgalago3{u} libgdata-google1.2-1{u} libgdata1.2-1{u}
libglibmm-2.4-1c2a{u} libgnome-media0{u} libgnome-menu2{u} libgnome-pilot2{u} libgnome-window-settings1{u} libgnomecups1.0-1{u} libgnomekbd-common{u}
libgnomekbd2{u} libgnomekbdui2{u} libgnomeprint2.2-0{u} libgnomeprint2.2-data{u} libgnomeprintui2.2-0{u} libgnomeprintui2.2-common{u}
libgnomevfs2-bin{u} libgtk-vnc-1.0-0{u} libgtkhtml3.14-19{u} libgtkmm-2.4-1c2a{u} libgtksourceview-common{u} libgtksourceview1.0-0{u}
libgtksourceview2.0-0{u} libgtksourceview2.0-common{u} libgucharmap6{u} libgweather-common{u} libgweather1{u} libkpathsea4{u} liblircclient0{u}
libmetacity0{u} libnautilus-burn4{u} libnet-dbus-perl{u} libnm-glib0{u} liboobs-1-4{u} libopal-2.2{u} libpanel-applet2-0{u} libpisock9{u}
libpisync1{u} libpt-1.10.10{u} libpt-1.10.10-plugins-alsa{u} libpt-1.10.10-plugins-v4l{u} libsdl1.2debian{u} libsdl1.2debian-alsa{u} libslab0{u}
libsmbios2{u} libspectre1{u} libspeexdsp1{u} libsvga1{u} libswfdec-0.6-90{u} libtalloc1{u} libtrackerclient0{u} libx86-1{u} libxklavier12{u}
libxml-twig-perl{u} metacity{u} metacity-common{u} nautilus-data{u} p7zip-full{u} python-gdata{u} python-glade2{u} python-gmenu{u} python-gnome2{u}
python-gnome2-desktop{u} python-gtksourceview2{u} python-pyorbit{u} seahorse{u} sound-juicer{u} svgalibg1{u} swfdec-gnome{u} system-tools-backends{u}
totem-common{u} totem-gstreamer{u} totem-plugins{u} vinagre{u} vino{u} zenity{u}
Os pacotes a seguir, parcialmente instalados, serão configurados:
gnome-mount
0 pacotes atualizados, 2 novos instalados, 142 a serem removidos e 598 não atualizados.
É preciso obter 0B/26,7MB de arquivos. Depois do desempacotamento, 406MB serão liberados.
Os pacotes a seguir possuem dependências não satisfeitas:
hal: Depende: udev (>= 143) mas 0.125-7+lenny3 está instalado e é mantido.
As seguintes ações resolverão estas dependências:

Atualizar os pacotes a seguir:
udev [0.125-7+lenny3 (now) -> 151-2 (testing, unstable)]

Pontuação é 120

Escrevendo informações estendidas de estado... Pronto
Pré-configurando pacotes ...
(Lendo banco de dados ... 105284 arquivos e diretórios atualmente instalados).
Preparando para substituir udev 0.125-7+lenny3 (usando .../archives/udev_151-2_i386.deb) ...


Since release 150, udev requires that support for the CONFIG_SYSFS_DEPRECATED
feature is disabled in the running kernel.

Please upgrade your kernel before or while upgrading udev.

AT YOUR OWN RISK, you can force the installation of this version of udev
WHICH DOES NOT WORK WITH YOUR RUNNING KERNEL AND WILL BREAK YOUR SYSTEM
AT THE NEXT REBOOT by creating the /etc/udev/kernel-upgrade file.
There is always a safer way to upgrade, do not try this unless you
understand what you are doing!


dpkg: erro processando /var/cache/apt/archives/udev_151-2_i386.deb (--unpack):
sub-processo novo script pre-installation retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/udev_151-2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A instalação de um pacote falhou. Tentando recuperar:
dpkg: problemas de dependência impedem a configuração de hal:
hal depende de udev (>= 143); porém:
Versão de udev no sistema é 0.125-7+lenny3.
dpkg: erro processando hal (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-mount:
gnome-mount depende de hal; porém:
Pacote hal não está configurado ainda.
dpkg: erro processando gnome-mount (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
hal
gnome-mount
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Escrevendo informações estendidas de estado... Pronto
Lendo descrições de tarefas... Pronto

e depois disso não anda mais pra lugar algum.

Alguma dica para mim?

Agradeço e abraço a todos.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
07/03/2010, 23:35
Resposta: #29
Re: Error: Dependency is not satisfaiable: libcups2
Se o Kernel ainda não tiver no upstream o apt não vai instalar por causa dos conflitos e inter-dependências.
Instale um novo Kernel "não-default" pelo source em http://kernel.org ou use o AptPinning.
Não conheço/lembro de outras maneiras de se fazer isso.

Abraço.

Lucas Saliés Brum
site | blog | telegram | medium | vk | twitter | github | .share
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS