Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Habilitar Wireless [RESOLVIDO]
25/10/2009, 18:11
Resposta: #1
Habilitar Wireless [RESOLVIDO]
Oi gente!!

Comprei um notebook HP(meu primeiro notebook). Instalei o Debian 5.0.3 sem problema algum e a rede via cabo (DHCP) está funcionando maravilhosamente.

Meu problema é com o wireless...

Vocês podem me ajudar?

Aí vão algumas informações:

1- A saída do lspci
Citar:00:00.0 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a2)
00:01.0 ISA bridge: nVidia Corporation Device 075e (rev a2)
00:01.1 SMBus: nVidia Corporation MCP78S [GeForce 8200] SMBus (rev a1)
00:01.3 Co-processor: nVidia Corporation MCP78S [GeForce 8200] Co-Processor (rev a2)
00:01.4 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:02.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:04.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:04.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:06.0 IDE interface: nVidia Corporation MCP78S [GeForce 8200] IDE (rev a1)
00:07.0 Audio device: nVidia Corporation Device 0774 (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:09.0 IDE interface: nVidia Corporation Device 0ad0 (rev a2)
00:0a.0 Ethernet controller: nVidia Corporation MCP78S [GeForce 8200] Ethernet (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:14.0 PCI bridge: nVidia Corporation Device 077a (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 11h HyperTransport Configuration (rev 40)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 11h Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 11h DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 11h Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 11h Link Control
02:00.0 VGA compatible controller: nVidia Corporation Device 0845 (rev a2)
07:00.0 Network controller: Atheros Communications Inc. Device 002a (rev 01)


2- A saída do lsusb
Citar:Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 0951:1607 Kingston Technology Data Traveler 2.0
Bus 002 Device 002: ID 04f2:b091 Chicony Electronics Co., Ltd
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. Mass Stroage Device
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

3- O arquivo /etc/network/interfaces:
Citar:auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet dhcp


4- O arquivo /proc/net/wireless:
Citar:Inter-| sta-| Quality | Discarded packets | Missed | WE
face | tus | link level noise | nwid crypt frag retry misc | beacon | 22

Desde já, agradeço a todos.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/10/2009, 13:06
Resposta: #2
Re: Habilitar Wireless
Hp é show! olha a atheros num está sendo reconhecida, talvez vc tenha mais sorte se proceder a atualização para um kernel mais recente tipo 2.6.30 que está disponível nos repositórios do squeeze. Tente carregar o modulo da atheros:
modprobe ath5k
ou
modprobe ath9k
e depois verifique se o dispositivo aparece:
ifconfig -a
Vi que tem o chipset de video Nvidia, o processador é AMD? é bom monitorar a temperatura desta GPU.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/10/2009, 18:17
Resposta: #3
Re: Habilitar Wireless
Bem, dei um modprobe ath5k e depois um lspci, mas Atheros continua na mesma.

Vou agora tentar passar o kernel para 2.6.30. Mas como faço isso? Basta trocar em /etc/apt/sources.list as entradas lenny por squeeze, e depois apt-get update e apt-get install linux-headers-2.6.30-2-amd64?

Eu li seu post sobre HP+nVidia+AMD, mas parece que o problema são com as linhas dv4 e dv6. O meu HP é G60. Será que pode ocorrer o mesmo problema?

Abraços
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/10/2009, 23:44
Resposta: #4
Re: Habilitar Wireless
Consegui instalar o kernel 2.6.30 e reconheceu o Wireless automaticamente.

Obrigado
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/10/2009, 16:12
Resposta: #5
Re: Habilitar Wireless
blz, se o seu for amd e nvidia é bom dar uma olhada na temperatura, o logista me falou que até hj ainda o problema existe, só num sei se esse seu modelo está isento.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/10/2009, 18:42
Resposta: #6
Re: Habilitar Wireless
Ok! Vou ficar de olho na temperatura. Qual deve ser a temperatura ideal?

Uma dúvida: Depois que instalei o kernel, ficou aparecendo - às vezes - um ícone no gnome informando erro. Será que instalei certo o kernel? O que fiz foi tocar no sources.list, lenny por squeeze e, depois, apt-get update e apt-get install kernel-image-2.6.30-2-amd64. Depois voltei no sources.list e troquei squeeze por lenny.

Outra coisa, seguindo esse tutorial
http://www.guiadohardware.net/dicas/deb ... sktop.html
será que consigo instalar minha placa de vídeo nvidia? Estou com uma resolução de 1024x768... Triste

Abraços
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/10/2009, 19:42
Resposta: #7
Re: Habilitar Wireless
num estou certo a temperatura, mas acho que o maximo é 77, passando disso já corre o risco de começar a derreter as coisas.
Um icone no gnome? num seria o icone do update? depois de voltar o sources.list vc deu o aptitute update novamente?
tem bons wikis aqui no forum ensinando instalar a nvidia, dá uma olhada.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/10/2009, 22:04
Resposta: #8
Re: Habilitar Wireless
É sim o ícone do update... ele fica como um círculo vermelho... ao colocar o cursor sobre ele, ele indica um erro. Sim, eu dei um apt-get update.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/10/2009, 07:43
Resposta: #9
Re: Habilitar Wireless
abre esse update é dá um verificada que pacote está dando erro ou quebrado.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/11/2009, 05:48
Resposta: #10
Re: Habilitar Wireless
Consegui instalar o drive na nvidia e consertar o erro. Para consertar o erro, bastou dar apt-get update kernel-headers-2.6.30-2-2amd64

Obrigado!!!!

Abraços
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS