Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Wireless não funciona
20/10/2009, 09:04
Resposta: #1
Wireless não funciona
Bom dia, comprei um Notebook CCE usado. Não sei muita coisa sobre ele. O problema é que o wireless não está funcionando. Para ligar o wireless aperto as teclas Fn + F10. No Kernel 2.6.26 eu consigo ligar o wireless. No kernel 2.6.30, eu aperto estas teclas mas o wireless não liga.
Alguns comandos
Código:
lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)
Código:
lsusb
Bus 003 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. Mass Stroage Device
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Valeu.

www.pequenotux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/10/2009, 12:21
Resposta: #2
Re: Wireless não funciona
Boa tarde,

Meu notebook tem as mesmas configurações e também não consegui fazer o wireless funcionar... Caso encontre a solução por favor me avise, pois também estou procurando.

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/10/2009, 20:39
Resposta: #3
Re: Wireless não funciona
Agora tentei fazer o wireless funcionar novamente e funcionou! :shock:
Estou utilizando o kernel 2.6.30-2. O sinal está uma porcaria, mesmo do lado do modem / roteador wireless. Se eu estiver através de uma parede a internet não funciona.
Não sei o que eu fiz. Acredito que nada. Mas funcionou porcamente.
Alguém sabe resolver este problema?
Valeu.

www.pequenotux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/10/2009, 09:15
Resposta: #4
Re: Wireless não funciona
Olá,

Jpa tentou verificar no site do fabricante se disponibiliza os módulos, me refiro a SiS...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/10/2009, 10:59
Resposta: #5
Re: Wireless não funciona
Sis? Mas pelo que entendi minha placa é listada no lsusb ou não?
Vou dar uma olhada, valeu.

www.pequenotux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/10/2009, 07:48
Resposta: #6
Re: Wireless não funciona
Descupe o erro, é Realtek Alegre Ela nãomostra maiores informações sobre o modelo do chip-set,na documentação do equipamento não fala nada a respeito?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/10/2009, 15:18
Resposta: #7
Re: Wireless não funciona
Vou dar uma olhada no manual do equipamento e depois posto aqui. Valeu.

www.pequenotux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/10/2009, 16:09
Resposta: #8
Re: Wireless não funciona
Executei o comando hwinfo e recebi a saída que está no arquivo http://rapidshare.de/files/48580897/hardware.html. Percebam no final da saída existe wlan.

Desculpem hospedar o arquivo no RapidShare mas o fórum não aceitou este arquivo! Confuso

No manual do notebook não encontrei nada sobre a marca/modelo do wireless.

Valeu.

www.pequenotux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/10/2009, 07:09
Resposta: #9
Re: Wireless não funciona
Olá,

Não consegui ver o conteúdo do arquivo, coloque somente a partye referente a rede...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/10/2009, 07:57
Resposta: #10
Re: Wireless não funciona
Existem várias partes que falam da wireless mas no final existe isto:
Código:
48: None 00.0: 10780 Network Interface
  [Created at net.124]
  Unique ID: agy+.GSopYcFr9cF
  Parent ID: ADDn.sfmFuxjLWYE
  SysFS ID: /class/net/wmaster0
  SysFS Device Link: /devices/pci0000:00/0000:00:03.3/usb1/1-1/1-1:1.0
  Hardware Class: network interface
  Model: "Network Interface"
  Driver: "rtl8187"
  Driver Modules: "rtl8187"
  Device File: wmaster0
  HW Address: 00:16:44:70:d8:d0
  Link detected: yes
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #42 (WLAN controller)

49: None 00.0: 1070a WLAN
  [Created at net.124]
  Unique ID: AYEt.QXn1l67RSa1
  Parent ID: ADDn.sfmFuxjLWYE
  SysFS ID: /class/net/wlan0
  SysFS Device Link: /devices/pci0000:00/0000:00:03.3/usb1/1-1/1-1:1.0
  Hardware Class: network interface
  Model: "WLAN network interface"
  Driver: "rtl8187"
  Driver Modules: "rtl8187"
  Device File: wlan0
  HW Address: 00:16:44:70:d8:d0
  Link detected: yes
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #42 (WLAN controller)
Valeu.

www.pequenotux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/10/2009, 12:27
Resposta: #11
Re: Wireless não funciona
Pelo que vi você está utilizando a RTL 8187B, eu tenho esta placa também, já relatei em alguns post aqui do FD, mas esta somente consegui fazer funcionar no kernel 2.6.30-1, veja a versão do kernel que está utilizando e se o módulo foi carregado corretamente...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/10/2009, 13:18
Resposta: #12
Re: Wireless não funciona
O Wireless só funciona se eu ficar do lado do modem / roteador. Se eu mudar de cômodo, já não funciona. Estou utilizando o kernel 2.6.30-2. No Windows este problema não ocorria.
Valeu.

www.pequenotux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/10/2009, 07:24
Resposta: #13
Re: Wireless não funciona
Então, isso pode ser a questão do módulo utilizado, o meu nem do lado do access point funcionava, qual módulo está utilizando? Poste o resultado do comando lsmod...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
31/10/2009, 07:02
Resposta: #14
Re: Wireless não funciona
Código:
lsmod
Module                  Size  Used by
arc4                    1660  2
ecb                     2524  2
rtl8187                50624  0
mac80211              181236  1 rtl8187
led_class               4096  1 rtl8187
eeprom_93cx6            1916  1 rtl8187
cfg80211               93052  2 rtl8187,mac80211
binfmt_misc             8356  1
ppdev                   6688  0
joydev                 10272  0
psmouse                56180  0
serio_raw               5280  0
lp                      8964  0
parport                35340  2 ppdev,lp
sis190                 17824  0
mii                     5212  1 sis190
shpchp                 32272  0
snd_hda_codec_si3054     4636  1
snd_hda_codec_realtek   203328  1
iptable_filter          3100  0
snd_hda_intel          26920  2
ip_tables              11692  1 iptable_filter
snd_hda_codec          75708  3 snd_hda_codec_si3054,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               7200  1 snd_hda_codec
x_tables               16544  1 ip_tables
snd_pcm_oss            37920  0
snd_mixer_oss          16028  1 snd_pcm_oss
snd_pcm                75296  4 snd_hda_codec_si3054,snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy           2656  0
snd_seq_oss            28576  0
snd_seq_midi            6432  0
snd_rawmidi            22208  1 snd_seq_midi
snd_seq_midi_event      6940  2 snd_seq_oss,snd_seq_midi
snd_seq                50224  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              22276  2 snd_pcm,snd_seq
snd_seq_device          6920  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    59204  17 snd_hda_codec_si3054,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep​,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd​_seq_device
soundcore               7264  1 snd
snd_page_alloc          9156  2 snd_hda_intel,snd_pcm
usb_storage            52544  0
video                  19380  0
output                  2780  1 video
sis_agp                 6972  1
agpgart                34988  1 sis_agp

www.pequenotux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/11/2009, 07:23
Resposta: #15
Re: Wireless não funciona
O módulo está correto, caso a versão do seu kernel seja inferior a 2.6.30 atualize para verificar se ela passa a funcionar...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS