Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Codecs no Debian Lenny 5.0 - RESOLVIDO!!!
10/10/2009, 01:38
Resposta: #16
Re: Codecs no Debian Lenny 5.0!!!
richex

converti logo os videos aqui brother, eram so 3 videos

to editando o titulo do topico para RESOLVIDO

valeu pela força ai galera

flow
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/01/2010, 20:59
Resposta: #17
Re: Codecs no Debian Lenny 5.0 - RESOLVIDO!!!
Por incrível que pareça, estou com o mesmo problema aqui, o mais engraçado é que *TODOS* os vídeos e audios estavam rodando totem :? e agora o totem cismou em não rodar vídeos do tipo Vídeo AVI (video/x-msvideo).

Sistema: Debian Lenny
Kernel: 2.6.26-2-amd64
Desktop Environment: Gnome
Passos para reprodução do problema: Clique duplo no vídeo
Erro: Totem procura por plugins, e não acha nenhum :lol:

Código:
lenny:~# dpkg -l | egrep -i "gstreamer|lame|ffmpeg|totem"
ii  ffmpeg                               3:20080706-0.3lenny1           audio/video encoder, streaming server & audi
ii  ffmpeg2theora                        0.21-0.1                       Theora video encoder using ffmpeg
ii  gstreamer0.10-alsa                   0.10.19-2                      GStreamer plugin for ALSA
ii  gstreamer0.10-ffmpeg                 0.10.4-3                       FFmpeg plugin for GStreamer
ii  gstreamer0.10-gnomevfs               0.10.19-2                      GStreamer plugin for GnomeVFS
ii  gstreamer0.10-plugins-bad            0.10.7-2+lenny2                GStreamer plugins from the "bad" set
ii  gstreamer0.10-plugins-base           0.10.19-2                      GStreamer plugins from the "base" set
ii  gstreamer0.10-plugins-base-apps      0.10.19-2                      GStreamer helper programs from the "base" se
ii  gstreamer0.10-plugins-good           0.10.8-4.1~lenny2              GStreamer plugins from the "good" set
ii  gstreamer0.10-plugins-ugly           0.10.8-1                       GStreamer plugins from the "ugly" set
ii  gstreamer0.10-sdl                    0.10.7-2+lenny2                GStreamer plugin for SDL output
ii  gstreamer0.10-tools                  0.10.19-3                      Tools for use with GStreamer
ii  gstreamer0.10-x                      0.10.19-2                      GStreamer plugins for X11 and Pango
ii  lame                                 3.98.2-0.4                     LAME Ain't an MP3 Encoder
ii  lame-extras                          3.97-0.0                       LAME Ain't an MP3 Encoder
ii  libavdevice52                        3:20080706-0.3lenny1           ffmpeg device handling library
ii  libavformat52                        3:20080706-0.3lenny1           ffmpeg file format library
ii  libavutil49                          4:0.5+svn20090706-5            ffmpeg utility library
ii  libgstreamer-plugins-base0.10-0      0.10.19-2                      GStreamer libraries from the "base" set
ii  libgstreamer0.10-0                   0.10.19-3                      Core GStreamer libraries and elements
rc  liblame0                             3.97-0.0                       LAME Ain't an MP3 Encoder
ii  libmp3lame0                          3.98.2-0.4                     LAME Ain't an MP3 Encoder
ii  libpostproc51                        4:0.5+svn20090706-5            ffmpeg video postprocessing library
ii  libswscale0                          3:20080706-0.3lenny1           ffmpeg video scaling library
ii  libtotem-plparser10                  2.22.3-1                       Totem Playlist Parser library - runtime vers
rc  libtwolame0                          0.3.12-1                       MPEG Audio Layer 2 encoding library
ii  libxine1-ffmpeg                      1.1.14-6                       MPEG-related plugins for libxine1
ii  toolame                              02l-6lenny1                    MPEG-1 layer 2 audio encoder
ii  totem                                2.22.2-5                       A simple media player for the GNOME desktop
ii  totem-common                         2.22.2-6                       Data files for the Totem media player
ii  totem-gstreamer                      2.22.2-6                       A simple media player for the GNOME desktop
ii  totem-mozilla                        2.22.2-6                       Totem Mozilla plugin
ii  totem-plugins                        2.22.2-6                       Plugins for the Totem media player
ii  totem-xine                           2.22.2-5                       A simple media player for the GNOME desktop

/etc/apt/sources.list
Código:
# Proposed
deb http://ftp.br.debian.org/debian/ lenny-proposed-updates contrib main non-free
deb-src http://ftp.br.debian.org/debian/ lenny-proposed-updates contrib main non-free #Added by software-properties

# Security
deb http://security.debian.org/ lenny/updates contrib main non-free
deb-src http://security.debian.org/ lenny/updates contrib main non-free #Added by software-properties

# Estavel
deb http://ftp.br.debian.org/debian/ lenny main contrib non-free
# deb http://ftp.br.debian.org/debian/ stable non-free main contrib
deb-src http://ftp.br.debian.org/debian/ lenny main contrib non-free # Fontes estaveis

# Teste
# deb http://ftp.br.debian.org/debian/ testing main contrib non-free

# Instavel
# deb http://ftp.br.debian.org/debian/ unstable main contrib non-free

# Multimidia
deb http://www.debian-multimedia.org lenny main

# Google Chrome
# deb http://dl.google.com/linux/deb/ stable main non-free

E agora? Alguem me ajuda? Sorrisão

Lucas Saliés Brum
site | blog | telegram | medium | vk | twitter | github | .share
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/01/2010, 21:04
Resposta: #18
Re: Codecs no Debian Lenny 5.0 - RESOLVIDO!!!
Esqueci um detalhe, no mplayer tudo funciona 100%, mas eu gostaria muito de usar o totem(questão de costume mesmo :mrgreen: ), afinal os vídeos rodavem nele até ontem. :|

Lucas Saliés Brum
site | blog | telegram | medium | vk | twitter | github | .share
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/02/2010, 22:35
Resposta: #19
Re: Codecs no Debian Lenny 5.0 - RESOLVIDO!!!
Possuo o DVD1 do Debian Lenny. Para automatizar a tarefa de instalar os codecs multimídias fiz o seguinte script:


Código:
#!/bin/bash

#********************************************************************
#Instalação do codecs multimidia pelo DVD Debian Lenny
#Data: 03/12/2009
#Luciano J Grisoste.
#********************************************************************

if [ `id -u` != 0 ]
then
    clear

    tput cup 3 40

    echo -e "\033[40;31;1mERRO:\033[m \033[4mFavor logar-se como ROOT e executar o script novamente!\n\n\033[m"

    exit 0
fi

pacote[0]='libavutil49'

pacote[1]='libgsm1'

pacote[2]='libavcodec51'

pacote[3]='libavformat52'

pacote[4]='libpostproc51'

pacote[5]='gstreamer0.10-ffmpeg'

pacote[6]='liba52-0.7.4'

pacote[7]='libdvdread3'

pacote[8]='libid3tag0'

pacote[9]='libmad0'

pacote[10]='libmpeg2-4'

pacote[11]='libsidplay1'

pacote[12]='gstreamer0.10-plugins-ugly'

pacote[13]='libdvdnav4'

#*******************************************************************************​********************

numPacote=13

for a in $(seq 0 "$numPacote")
do
    clear

    tput cup 1 40

    echo -e "\033[40;36;1m\aCODECS MULTIMIDIA DEBIAN LENNY.\n\033[m"

    echo -e "Informacoes do pacote a ser instalado:\033[40;33;1m ${pacote["$a"]}\n\033[m"

    apt-get install "${pacote["$a"]}"

    sleep 3

done

#*******************************************************************************​********************************

Eu sei que poderia ter ficado mais encolhido, nas desse modo fica mais fácil o entendimento.

Antes de executar o script para quem também possui o dvd é rodar um

#sudo apt-cdrom add

Obs: críticas são bem-vindas.

O que me preocupa não é o grito dos maus. É o silêncio dos bons.
Martin Luther King
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/12/2010, 12:40
Resposta: #20
Re: Codecs no Debian Lenny 5.0 - RESOLVIDO!!!
Consegui resolver fazendo um update de uns aquivos

sudo aptitude install gstreamer0.10-plugins-bad gstreamer0.10-plugins-good

E pronto... o totem rodou direitinho!

abraço
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/12/2010, 16:28
Resposta: #21
Re: Codecs no Debian Lenny 5.0 - RESOLVIDO!!!
Que bom que funcionou.

[Imagem: 1225_128x128.png]
Debian Linux User
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS