Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
apt-get -f install apresentando erro
07/09/2009, 10:50
Resposta: #1
apt-get -f install apresentando erro
Utilizo o debian lenny e está apresentando o seguinte erro nas dependências:

debian:/home/fabio# apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os pacotes extra a seguir serão instalados:
binutils gcc gcc-4.3 gimp-data libamrnb3 libamrwb3 libartsc0 libasyncns0
libaudio2 libavcodec51 libavdevice52 libavformat52 libavutil49 libc6-dev
libcap1 libcups2 libdc1394-22 libdirac0 libfaac0 libfreebob0 libfreetype6
libfribidi0 libggi-target-x libggi2 libgii1 libgii1-target-x libgimp2.0
libgomp1 libice-dev libjack0 libkrb53 liblzo2-2 libmng1 libmp3lame0
libmpcdec3 libmpeg2-4 libmpg123-0 libopenal1 libpostproc51 libpthread-stubs0
libpthread-stubs0-dev libqt3-mt libqt4-dbus libqt4-designer libqt4-network
libqt4-qt3support libqt4-script libqt4-sql libqt4-sql-mysql libqt4-xml
libqtcore4 libqtgui4 libschroedinger-1.0-0 libsidplay1 libsm-dev libswscale0
libwmf0.2-7 libx11-dev libx264-65 libxau-dev libxdmcp-dev libxext-dev
libxi-dev libxvidcore4 libxvmc1 mplayer mplayer-skin-blue x11proto-core-dev
x11proto-input-dev x11proto-kb-dev x11proto-xext-dev xtrans-dev zlib1g-dev
Pacotes sugeridos:
binutils-doc gcc-multilib manpages-dev autoconf automake1.9 libtool flex
bison gdb gcc-doc gcc-4.3-multilib libmudflap0-4.3-dev gcc-4.3-doc
gcc-4.3-locales libgcc1-dbg libgomp1-dbg libmudflap0-dbg nas glibc-doc
libggi-target-emu libggi-target-monotext libggimisc2 jackd krb5-doc
krb5-user libqt3-mt-psql libqt3-mt-mysql libqt3-mt-odbc libqt4-dev
sidplay-base xsidplay mplayer-doc
Os NOVOS pacotes a seguir serão instalados:
binutils gcc gcc-4.3 gimp-data libamrnb3 libamrwb3 libartsc0 libasyncns0
libaudio2 libavcodec51 libavdevice52 libavformat52 libavutil49 libc6-dev
libcap1 libdc1394-22 libdirac0 libfaac0 libfreebob0 libfribidi0
libggi-target-x libggi2 libgii1 libgii1-target-x libgimp2.0 libgomp1
libice-dev libjack0 liblzo2-2 libmng1 libmp3lame0 libmpcdec3 libmpeg2-4
libmpg123-0 libopenal1 libpostproc51 libpthread-stubs0 libpthread-stubs0-dev
libqt3-mt libqt4-dbus libqt4-designer libqt4-network libqt4-qt3support
libqt4-script libqt4-sql libqt4-sql-mysql libqt4-xml libqtcore4 libqtgui4
libschroedinger-1.0-0 libsidplay1 libsm-dev libswscale0 libwmf0.2-7
libx11-dev libx264-65 libxau-dev libxdmcp-dev libxext-dev libxi-dev
libxvidcore4 libxvmc1 mplayer mplayer-skin-blue x11proto-core-dev
x11proto-input-dev x11proto-kb-dev x11proto-xext-dev xtrans-dev zlib1g-dev
Os pacotes a seguir serão atualizados:
libcups2 libfreetype6 libkrb53
3 pacotes atualizados, 70 pacotes novos instalados, 0 a serem removidos e 53 não atualizados.
304 pacotes não totalmente instalados ou removidos.
É preciso baixar 0B/51,2MB de arquivos.
Depois desta operação, 138MB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? s
AVISO: Os pacotes a seguir não podem ser autenticados!
libfaac0 libamrnb3 libamrwb3 libavutil49 libdirac0 libmp3lame0 libx264-65
libxvidcore4 libavcodec51 libavformat52 libavdevice52 libpostproc51
libswscale0 mplayer
Instalar estes pacotes sem verificação [s/N]? s
E: Internal Error, Could not perform immediate configuration (1) on libc6
debian:/home/fabio#

Desta maneira não consigo instalar nenhum arquivo na linha de comando e simplesmente não resolve estas dependências. Tentei usar o aptitude porém o mesmo não funcionou, gostaria de um apoio de vcs. =)

Segue o source.list meu:
# Line commented out by installer because it failed to verify:
#deb http://security.debian.org/ lenny/updates main
# Line commented out by installer because it failed to verify:
#deb-src http://security.debian.org/ lenny/updates main

# Line commented out by installer because it failed to verify:
deb http://volatile.debian.org/debian-volatile lenny/volatile main
# Line commented out by installer because it failed to verify:
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main

#http://ftp.br.debian.org/debian-multimedia/ lenny main

deb http://www.debian-multimedia.org lenny main

deb http://ftp.br.debian.org/debian/ lenny main contrib non-free
deb http://security.debian.org/ lenny/updates main contrib non-free

deb http://ftp.br.debian.org/debian/ lenny main
deb http://security.debian.org/ lenny/updates main
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
07/09/2009, 13:03
Resposta: #2
Re: apt-get -f install apresentando erro
Boa tarde,

Experimente atualizar somente o pacote libc6 antes de outras atualizações.

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/09/2009, 10:09
Resposta: #3
Re: apt-get -f install apresentando erro
Se não der certo faça um

Código:
# apt-get -f dist-upgrade

Vejamos como se sai.

[Imagem: 1225_128x128.png]
Debian Linux User
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/09/2009, 07:41
Resposta: #4
Re: apt-get -f install apresentando erro
Bom dia, tentamos atualizar o libc6 apenas porém retorna que deve utilizar o apt-get -f install
e também tentamos o apt-get -f dist-upgrade e também não foi satisfatório, retornou a mesma saída.
O que mais poderia ser realizado para reparar as dependências?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/09/2009, 07:41
Resposta: #5
Re: apt-get -f install apresentando erro
Bom dia, tentamos atualizar o libc6 apenas porém retorna que deve utilizar o apt-get -f install
e também tentamos o apt-get -f dist-upgrade e também não foi satisfatório, retornou a mesma saída.
O que mais poderia ser realizado para reparar as dependências?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/09/2009, 11:18
Resposta: #6
Re: apt-get -f install apresentando erro
Bom dia,

Primeiro tente reconfigurar o pacote:
Código:
dpkg-reconfigure libc6-xxx

Para descobrir o pacote faça:
Código:
dpkg -l | grep libc6

Caso ainda não funcione, entre no site do www.debian.org e baixe o pacote e efetue a instalação manualmente:
Código:
dpkg -i libc6*.deb

Se não retornar nenhum erro, execute novamente o comando:
Código:
aptitude -f install

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/09/2009, 11:18
Resposta: #7
Re: apt-get -f install apresentando erro
Bom dia,

Primeiro tente reconfigurar o pacote:
Código:
dpkg-reconfigure libc6-xxx

Para descobrir o pacote faça:
Código:
dpkg -l | grep libc6

Caso ainda não funcione, entre no site do www.debian.org e baixe o pacote e efetue a instalação manualmente:
Código:
dpkg -i libc6*.deb

Se não retornar nenhum erro, execute novamente o comando:
Código:
aptitude -f install

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/09/2009, 16:29
Resposta: #8
Re: apt-get -f install apresentando erro
Uma outra sugestão:

aptitude reinstall <pacote>
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/09/2009, 16:29
Resposta: #9
Re: apt-get -f install apresentando erro
Uma outra sugestão:

aptitude reinstall <pacote>
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS