Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
[Resolvido] Desabilitar scroll horizontal do toutchpad?
24/05/2009, 13:08
Resposta: #1
[Resolvido] Desabilitar scroll horizontal do toutchpad?
Eu quero desativar o scroll horizontal do meu touchpad, mas não estou conseguindo...

Eu adicionei isso ao meu xorg.conf, mas não funcionou.
Código:
Section "InputDevice"
    Identifier  "Synaptics Touchpad"
    Driver      "synaptics"
    Option        "SendCoreEvents" "true"
    Option        "Device" "/dev/psaux"
    Option        "Protocol" "auto-dev"
    Option        "HorizEdgeScroll" "0"
    Option        "SHMConfig" "on" # Eu adicionei pra fazer o toutchpad para enquanto digito.
EndSection

No meu Kubuntu 8.04 tem essa parte no xorg.conf e o scroll horizontal está desativado.

Como desativo o scroll horizontal?

Notebook:
HP Pavilon DV5-1004
Processador: AMD Turion X2 Ultra Dual-Core Moblie ZM-80
Video: ATI Radeon HD 3200, 256Mb
Memória: 4Gb
HD: 320 Gb


LinuxUser #456735
LinuxMachine #364912
[Imagem: belimawr342690.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/05/2009, 17:06
Resposta: #2
Re: Desabilitar scroll horizontal do toutchpad?
na seção de serverlayout tem o input configurado:
Section "ServerLayout"
InputDevice "Synaptics Touchpad"

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/05/2009, 16:20
Resposta: #3
Re: Desabilitar scroll horizontal do toutchpad?
dmatrix Escreveu:na seção de serverlayout tem o input configurado:
Section "ServerLayout"
InputDevice "Synaptics Touchpad"

O meu xorg.conf está assim:

Código:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
    Identifier  "Generic Keyboard"
    Driver      "kbd"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc104"
    Option        "XkbLayout" "us"
    Option        "XkbVariant" "intl"
EndSection

Section "InputDevice"
    Identifier  "Configured Mouse"
    Driver      "mouse"
EndSection

Section "InputDevice"
    Identifier  "Synaptics Touchpad"
    Driver      "synaptics"
    Option        "SendCoreEvents" "true"
    Option        "Device" "/dev/psaux"
    Option        "Protocol" "auto-dev"
    Option        "HorizEdgeScroll" "0"
    Option        "SHMConfig" "on" # Eu adicionei pra fazer o toutchpad para enquanto digito.
EndSection

Section "Monitor"
    Identifier   "Configured Monitor"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "Configured Video Device"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver    "fglrx"
    BusID       "PCI:1:5:0"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Monitor    "Configured Monitor"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection


Section "Extensions"
    Option      "Composite"    "disable"
#    Option      "RENDER"    "disable"
EndSection

então eu devo adicionar a seção serverlayout? Ficando assim:

Código:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "ServerLayout"
       InputDevice "Synaptics Touchpad"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
    Identifier  "Generic Keyboard"
    Driver      "kbd"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc104"
    Option        "XkbLayout" "us"
    Option        "XkbVariant" "intl"
EndSection

Section "InputDevice"
    Identifier  "Configured Mouse"
    Driver      "mouse"
EndSection

Section "InputDevice"
    Identifier  "Synaptics Touchpad"
    Driver      "synaptics"
    Option        "SendCoreEvents" "true"
    Option        "Device" "/dev/psaux"
    Option        "Protocol" "auto-dev"
    Option        "HorizEdgeScroll" "0"
    Option        "SHMConfig" "on" # Eu adicionei pra fazer o toutchpad para enquanto digito.
EndSection

Section "Monitor"
    Identifier   "Configured Monitor"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "Configured Video Device"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver    "fglrx"
    BusID       "PCI:1:5:0"
EndSection

Section "Screen"
    Identifier "Default Screen"
    Monitor    "Configured Monitor"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection


Section "Extensions"
    Option      "Composite"    "disable"
#    Option      "RENDER"    "disable"
EndSection

Notebook:
HP Pavilon DV5-1004
Processador: AMD Turion X2 Ultra Dual-Core Moblie ZM-80
Video: ATI Radeon HD 3200, 256Mb
Memória: 4Gb
HD: 320 Gb


LinuxUser #456735
LinuxMachine #364912
[Imagem: belimawr342690.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/05/2009, 11:16
Resposta: #4
Re: Desabilitar scroll horizontal do toutchpad?
acho que sim, mas vc já tem a seção do server layout acredito que pode adicionar a linha dentro dela.
Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
InputDevice "Synaptics Touchpad"
EndSection

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/05/2009, 14:08
Resposta: #5
Re: Desabilitar scroll horizontal do toutchpad?
analisando novamente me parece que está faltando mais linhas para adicionar:
Código:
Section "ServerLayout"
   Identifier "aticonfig Layout"
   Screen 0 "aticonfig-Screen[0]-0" 0 0
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice   "Synaptics Touchpad"
EndSection

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/05/2009, 22:11
Resposta: #6
Re: Desabilitar scroll horizontal do toutchpad?
dmatrix Escreveu:analisando novamente me parece que está faltando mais linhas para adicionar:
Código:
Section "ServerLayout"
   Identifier "aticonfig Layout"
   Screen 0 "aticonfig-Screen[0]-0" 0 0
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice   "Synaptics Touchpad"
EndSection

FUNCIONOU!!!!! Muito obrigado!!!! Funcionou!!!!!!

Notebook:
HP Pavilon DV5-1004
Processador: AMD Turion X2 Ultra Dual-Core Moblie ZM-80
Video: ATI Radeon HD 3200, 256Mb
Memória: 4Gb
HD: 320 Gb


LinuxUser #456735
LinuxMachine #364912
[Imagem: belimawr342690.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS