Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Resolvido - Gnome trava com 4GB de memória
09/04/2009, 14:36
Resposta: #1
Resolvido - Gnome trava com 4GB de memória
Acabei de ganhar 4gb de memória do meu cunhado. São dois módulos de 2gb cada. Com um módulo funciona com os dois não. Quando coloco os dois módulos e o sistema incia o gnome trava.
Mas quando vou para o terminal ele reconhece os dois módulos de memória.

Como resolver?

Os dois módulos de memória estão funcionando.
Placa mãe asus M2V MX AMD64.
Rorando Debian Lenny com Gnome.
Estou com 2 módulos de 2gb DDR 2.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/04/2009, 20:31
Resposta: #2
Re: Gnome trava com 4GB de memória
Boa noite,

Me tire uma dúvida. A sua arquitetura e de 64bits? Caso for 64bits, instale o memtester e faça um teste na memória para ver se esta tudo ok.
Caso sua arquitetura for 32 bits, talvez o problema possa estar ai, pois as memórias são reconhecidas mas não podem ser totalmente endereçadas (32bits gerencia no máximo 3.2gb).

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/04/2009, 20:55
Resposta: #3
Re: Gnome trava com 4GB de memória
vadinhodebian Escreveu:Boa noite,
A sua arquitetura e de 64bits? Caso for 64bits, instale o memtester e faça um teste na memória para ver se esta tudo ok.
Até mais...

A arquitetura é de 64 bits. Vou fazer o teste com o memtester. Mas já fiquei um bom tempo utilizando um módulo e depois outro bom tempo utilizando o outro e não tive problemas.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/04/2009, 11:09
Resposta: #4
Re: Gnome trava com 4GB de memória
Voce tem outro sistema operacional para testar, tipo o Windows ou outra instalação linux na sua maquina para testar e ver se acontece o mesmo?

[Imagem: 1225_128x128.png]
Debian Linux User
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/04/2009, 13:32
Resposta: #5
Re: Gnome trava com 4GB de memória
Coo tem 4GB de memória, é uma boa utilizar o kernel big mem...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/06/2009, 00:09
Resposta: #6
Re: Gnome trava com 4GB de memória
Fiz o CD de boot do memtester, ficou cerca de 4h rodando o programa mas não encontrou erros.
O Gnome continua travando.

Eu já fiz o teste usando os pentes alternadamente e isso funciona. Os dois pentes de memória juntos é que não dá certo.

Alguém tem alguma outra sugestão?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/06/2009, 07:34
Resposta: #7
Re: Gnome trava com 4GB de memória
Bom dia,

Qual kernel você esta utilizando? Já tentou utilizar o bigmem, conforme nosso amigo spikey mencionou?

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/06/2009, 08:03
Resposta: #8
Re: Gnome trava com 4GB de memória
mais umas sufestões:

Em um livecd também trava? Qual o barramento dos módulos?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/06/2009, 13:53
Resposta: #9
Re: Gnome trava com 4GB de memória
vadinhodebian Escreveu:Qual kernel você esta utilizando? Já tentou utilizar o bigmem, conforme nosso amigo spikey mencionou?
Olá,
O meu Kernel é o 2.6.26-2-amd64, acabei de atualizar.
Ainda não tentei utilizar o bigmem. Vou fazer isso.
Já atualizei BIOS mas nada.
Até..
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/06/2009, 13:59
Resposta: #10
Re: Gnome trava com 4GB de memória
spikey Escreveu:Em um livecd também trava? Qual o barramento dos módulos?
Ainda não testei um livecd. Vou tentar o bigmem e depois o livecd.
Utilizei o comando lshw para ver a memória instalada. Veja que o kernel está detectando a memória corretamente.
*-memory
description: System Memory
physical id: 2b
slot: System board or motherboard
size: 4GiB
*-bank:0
description: DIMM Synchronous 800 MHz (1.2 ns)
product: PartNum0
vendor: Manufacturer0
physical id: 0
serial: SerNum0
slot: DIMM0
size: 2GiB
width: 64 bits
clock: 800MHz (1.2ns)
*-bank:1
description: DIMM Synchronous 800 MHz (1.2 ns)
product: PartNum1
vendor: Manufacturer1
physical id: 1
serial: SerNum1
slot: DIMM1
size: 2GiB
width: 64 bits
clock: 800MHz (1.2ns)

Com o comando free:

total used free shared buffers cached
Mem: 3998172 711816 3286356 0 43184 287732
-/+ buffers/cache: 380900 3617272
Swap: 1172736 0 1172736

Uma novidade importante. Parece que o problema está no vídeo. Eu não consigo visualizar nada quando o gnome é iniciado. Mas dei um Print Screen e a imagem do gnome fica perfeita. Será alguma configuração no vídeo, resolução, monitor? O monitor é um Acer X193w de 19".
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/06/2009, 14:32
Resposta: #11
Re: Gnome trava com 4GB de memória
spikey Escreveu:Coo tem 4GB de memória, é uma boa utilizar o kernel big mem...
Existe bigmem para arquitetura 64 bits ?
O que encontrei foi o http://packages.debian.org/lenny/linux- ... 686-bigmem e não instala.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/06/2009, 08:40
Resposta: #12
Re: Gnome trava com 4GB de memória
Como tentou instalar, pelo apt? Ge3rou algum erro?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/06/2009, 12:21
Resposta: #13
Re: Gnome trava com 4GB de memória
spikey Escreveu:Como tentou instalar, pelo apt? Ge3rou algum erro?

Pelo apt não instala. Ele não encontra o pacote.
# apt-get install linux-image-2.6-686-bigmem_2.6.26+17+lenny1_i386
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível achar pacote linux-image-2.6-686-bigmem_2.6.26+17+lenny1_i386

o arquivo "/etc/apt/sources.list" está com as seguintes linhas:
deb http://ftp.de.debian.org/debian lenny main
deb-src http://ftp.de.debian.org/debian lenny main

Baixei o pacote e obviamente também não instalou.

# dpkg -i linux-image-2.6-686-bigmem_2.6.26+17+lenny1_i386.deb
dpkg: erro processando linux-image-2.6-686-bigmem_2.6.26+17+lenny1_i386.deb (--install):
arquitetura do pacote (i386) não combina com a do sistema (amd64)
Erros foram encontrados durante o processamento de:
linux-image-2.6-686-bigmem_2.6.26+17+lenny1_i386.deb


Acredito que o caminho é o arquivo xorg.conf, andei alterando as configurações e mudou a aparência da tela do gnome quando ele abre. No começo acreditei que o gnome travava. Mas acredito que ele está tendo problemas ao compartilhar a memória RAM com a placa de vídeo onboard.

Fui no log "/var/log/Xorg.0.log" e ele lista os seguintes erros.

(EE) CHROME(0): [drm] Failed to initialize DMA ring-buffer: 22

(EE) AIGLX error: dlopen of /usr/lib/dri/swrast_dri.so failed (/usr/lib/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering

E os seguintes Warnings.

(WW) CHROME(0): Unable to activate panel: no panel is present.

(WW) CHROME(0): [drm] The DRM heap and pixmap cache memory may be too
[drm] small for optimal performance. Please increase
[drm] the frame buffer memory area in the BIOS.

O meu "/etc/X11/xorg.conf" está assim (não tenho muita experiencia, estou começando a ler sobre as opções existentes e ver o que se aplica ao meu hardware):

Section "Files"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
Load "extmod"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
Option "XkbVariant" "abnt2"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
DisplaySize 408 255
HorizSync 30-82
Identifier "Monitor[0]"
ModelName "ACER X193W"
Option "DPMS"
Option "1024x768"
VendorName "ACR"
VertRefresh 43-76
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1440x900" 104.58 1440 1520 1672 1904 900 901 904 931
Modeline "1440x900" 85.75 1440 1488 1520 1600 900 903 909 925 +HSync -Vsync
Modeline "1280x960" 105.61 1280 1360 1496 1712 960 961 964 995
Modeline "1280x960" 86.75 1280 1328 1360 1440 960 963 967 988 +HSync -Vsync
Modeline "1152x864" 104.99 1152 1224 1352 1552 864 865 868 902
Modeline "1152x864" 96.77 1152 1224 1344 1536 864 865 868 900
Modeline "1152x864" 89.56 1152 1224 1344 1536 864 865 868 897
Modeline "1152x864" 86.75 1152 1200 1232 1312 864 867 871 895 +HSync -Vsync
Modeline "1152x864" 81.62 1152 1216 1336 1520 864 865 868 895
Modeline "1024x768" 83.00 1024 1080 1192 1360 768 769 772 803
Modeline "1024x768" 76.89 1024 1080 1192 1360 768 769 772 800
Modeline "1024x768" 70.50 1024 1072 1104 1184 768 771 775 796 +HSync -Vsync
Modeline "1024x768" 70.07 1024 1080 1184 1344 768 769 772 798
Modeline "1024x768" 64.11 1024 1080 1184 1344 768 769 772 795
Modeline "800x600" 50.32 800 840 928 1056 600 601 604 627
Modeline "800x600" 45.93 800 840 920 1040 600 601 604 625
Modeline "800x600" 44.75 800 848 880 960 600 603 607 622 +HSync -Vsync
Modeline "800x600" 42.33 800 840 920 1040 600 601 604 623
Modeline "800x600" 38.22 800 832 912 1024 600 601 604 622
Modeline "1440x900" 106 1440 1520 1672 1904 900 903 909 934 +hsync -vsync
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1440x900" "1280x960" "1152x864" "1024x768" "800x600"
Virtual 3840 1200
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900" "1280x960" "1152x864" "1024x768" "800x600"
Virtual 3840 1200
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1280x960" "1152x864" "1024x768" "800x600"
Virtual 3344 1200
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900" "1280x960" "1152x864" "1024x768" "800x600"
Virtual 3840 1200
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "openchrome"
BusID "PCI:1:0:0"
VideoRam 131072
Option "AccelMethod" "EXA"
Option "ActiveDevice" "LCD"
Option "AGPMem" "131072"
Option "Center" "false"
Option "DisableIRQ" "false"
Option "DisableVQ" "false"
Option "EnableAGPDMA" "false"
Option "ExaNoComposite" "true"
Option "ExaScratchSize" "8192"
Option "MaxDRIMem" "32768"
Option "MigrationHeuristic" "greedy"
Option "NoAccel" "false"
Option "NoAGPFor2D" "false"
Option "NoXVDMA" "true"
Option "XaaNoImageWriteRect" "true"
Option "SWCursor" "true"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Screen[0]"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

#Section "Extensions"
# Option "Composite" "Enable"
#EndSection

Section "DRI"
Mode 0666
EndSection
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/06/2009, 08:03
Resposta: #14
Re: Gnome trava com 4GB de memória
Faça da seguinte forma:

apt-get install linux-image-2.6-686-bigmem
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/07/2009, 19:39
Resposta: #15
Re: Gnome trava com 4GB de memória
richex Escreveu:Voce tem outro sistema operacional para testar, tipo o Windows ou outra instalação linux na sua maquina para testar e ver se acontece o mesmo?

Usei o LiveCD ubuntu-9.04-desktop-amd64 e o problema foi o mesmo ao abrir o Gnome.

Encontrei um forum do Opensuse onde o gnome está apresentando o mesmo problema:
http://forums.opensuse.org/hardware/391 ... b-ram.html

Parece que o problema está na memória compartilhada com a placa de vídeo onboard.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS