Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Acessar CUPS pela rede !
07/01/2009, 18:53
Resposta: #1
Acessar CUPS pela rede !
Até a um tempo atrás acessava o servidor CUPS pelas estações de rede normalmente, porém após alguma das atualizações, não me lembro qual não consigo mais. Fica o tempo todo tentando acessar HTTPS mas não passa. Já tentei todo tipo de liberação que conheço no /etc/cups/cupsd.conf porém sem sucesso.

Alguém tem alguma dica ? Debian ETCH !
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/01/2009, 20:45
Resposta: #2
 
vc utiliza o windows para acessar o servidor cups?
se sim o browser é o internet 7?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/01/2009, 06:59
Resposta: #3
 
Isso mesmo as estações são windows, mas tentei com linux tb com IE 6 IE 7 e Firefox !
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/01/2009, 15:45
Resposta: #4
 
verifique se as seguintes linha estão configuradas semelhante o exemplo abaixo, as seguinte seções são do arquivo cupsd.conf definindo os ips que poderão acessar:

Código:
<Location />
Encryption IfRequested
Satisfy All
Order allow,deny
Allow localhost
Allow 192.168.10.*
</Location>

<Location /admin>
Encryption Required
Satisfy All
Order allow,deny
Allow localhost
Allow 192.168.10.*
</Location>

<Location /admin/conf>
AuthType Basic
Require user @SYSTEM
Encryption IfRequested
Satisfy All
Order allow,deny
Allow localhost
</Location>

No caso acima todas estações que tem o ip da rede 192.168.10. poderão acessar pelo browse o cups do servidor digitando-se o endereço <ip do servidor>:631
No IE7 pode ocorrer de não funcionar.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/01/2009, 18:17
Resposta: #5
 
Olhe meu Conf completo :

#
#
# Sample configuration file for the Common UNIX Printing System (CUPS)
# scheduler. See "man cupsd.conf" for a complete description of this
# file.
#

# Log general information in error_log - change "info" to "debug" for
# troubleshooting...
LogLevel warning

# Administrator user group...
SystemGroup lpadmin

# Only listen for connections from the local machine.
Listen localhost:631
Listen 192.168.20.1:631 # Minha Rede
Listen /var/run/cups/cups.sock

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow @LOCAL

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Restrict access to the server...
<Location />
Order allow,deny
Allow localhost
Allow 192.168.20.*
</Location>

# Restrict access to the admin pages...
<Location /admin>
Encryption Required
Order allow,deny
Allow localhost
Allow 192.168.20.*
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
AuthType Basic
Require user @SYSTEM
Encryption IfRequested
Satisfy All
Order allow,deny
Allow localhost
</Location>

# Set the default printer/job policies...
<Policy default>
# Job-related operations must be done by the owner or an adminstrator...
<Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

# All administration operations require an adminstrator to authenticate...
<Limit Pause-Printer Resume-Printer Set-Printer-Attributes Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Add-Printer CUPS-Delete-Printer CUPS-Add-Class CUPS-Delete-Class CUPS-Accept-Jobs CUPS-Reject-Jobs CUPS-Set-Default>
AuthType Basic
Require user @SYSTEM
Order deny,allow
</Limit>

# Only the owner or an administrator can cancel or authenticate a job...
<Limit Cancel-Job CUPS-Authenticate-Job>
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

<Limit All>
Order deny,allow
</Limit>
</Policy>

#
#

#
# Printcap: the name of the printcap file. Default is /etc/printcap.
# Leave blank to disable printcap file generation.
#

Printcap /var/run/cups/printcap

#
# PrintcapFormat: the format of the printcap file, currently either
# BSD or Solaris. The default is "BSD".
#

#PrintcapFormat BSD
#PrintcapFormat Solaris

#
# PrintcapGUI: the name of the GUI options panel program to associate
# with print queues under IRIX. The default is "/usr/bin/glpoptions"
# from ESP Print Pro.
#
# This option is only used under IRIX; the options panel program
# must accept the "-d printer" and "-o options" options and write
# the selected printer options back to stdout on completion.
#

#PrintcapGUI /usr/bin/glpoptions

Bem parecido com o seu mas não acessa nem com o IE 6 nem o IE 7
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/01/2009, 18:21
Resposta: #6
 
O interessante é que acessava até pelo IE 7. Dava um alerta de aceeso a site perigoso depois que voce confirmava a abertura do site abria normalmente. Só mais um detalhe o Cups abre mais só a primeira tela o que eu não consigo e fazer nenhuma tarefa administrativa. É neste ponto que ele para.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/01/2009, 08:44
Resposta: #7
 
num sei...tá bem semelhante mesmo, só se tem algumas linhas a mais no seu que esteja impedindo a autenticação, talvez se vc pegasse e fizesse um backup deste cupsd.conf e colocasse o cupsd.conf original do pacote e só adicionasse as linha que citei, só para testar se num seria em outras linhas o problema.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/01/2009, 17:45
Resposta: #8
 
Tem como vc me mandar uma cópia do seu cupsd.conf ? Só pra teste !
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/01/2009, 18:10
Resposta: #9
 
infelizmente não pois copiei somente essa parte do cuspd.conf e sempre utilizo ela para configurar toda vez que preciso instalar o cups no cliente.
Mas talvez eu possa conseguir mais tarde o cupsd.conf de uma maquina no trabalho.
mas tb acredito que num tenha muito problema se vc extrair o cupsd.conf do pacote cups ou então utilizar o arquivo /etc/cups/cupsd.conf.default como base para testes.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/01/2009, 14:19
Resposta: #10
 
olha aí o meu cupsd.conf como está e estou conseguindo abrir a aba administration normal.
Arquivo anexado.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS