Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Modem reseta as permissões ao reiniciar daemon.
01/01/2009, 16:51
Resposta: #1
Modem reseta as permissões ao reiniciar daemon.
Bom dia e Feliz Ano Novo à todos!!!
Instalei e coloquei pra rodar em um NeoPC o Debian Etch e também o famigerado modem sm56 da motorola(quase desisti...).
Funciona, conecta e navega, só que toda vez que reinicio o micro, ou o sl-modem-daemon, seja qual for o motivo tenho de reajustar as permissões do modem em /dev/ttySL0, pois só dá acesso ao root e aos membros do grupo uucp.
Todos estão habilitados a usar o modem na seção de controle de usuários.
Será que tem de fazer alguma gambiarra no rc.local?
Qualquer ajuda agradeço.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/01/2009, 22:56
Resposta: #2
 
O dev está sendo criado por que vc que adicionou manualmente na inicialização? vc já aplicou as permissões citadas no wiki? http://wiki.forumdebian.com.br/index.ph ... com_Wvdial

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/01/2009, 09:02
Resposta: #3
 
Eu não adicionei nada manualmente, foi tudo através da instalação do pacote sl-modem-daemon e suas dependências.
Já instalei em diversas máquinas com o mesmo procedimento e isso nunca ocorreu.
Nesta máquina, em particular, é que ao reiniciar o micro, o /dev/ttySL0 fica com permissões de leitura e escrita apenas para o root e o grupo uucp, todos os outros usuários ficam sem acesso, mesmo que eu dê acesso ao modem através da ferramenta Usuários e Grupos.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/01/2009, 23:28
Resposta: #4
 
as permissões é 660 mesmo só esse grupo que está errado por isso que num adianta habilitar pela ferramenta de usuários, tinha que estar com grupo dialout, vc deve verificar se no udev está correto isso:
/etc/udev/rules.d
neste diretório localize se existe algum arquivo de regra com o nome de sl-modem, se não existir procure pelo de permissions.rules e localize nele as linha onde estão os serial devices, veja aí se o grupo do tty estão com dialout.
as permissões tb podem estar sendo definidas em um arquivo de carregamento do modulo no /etc/modprobe.d

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/01/2009, 19:33
Resposta: #5
Quem entende?
Como tinha dito, o micro é da minha cunhada. Não mexi em nada, ela não manja de linux e agora o modem funciona que é uma beleza. Vai entender...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS