Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Apt-get
26/12/2008, 16:17
Resposta: #1
Apt-get
Bom, a um tempo atras eu estava instalando pacotes do repositório, derepente faltou energia e o computador des ligou no meio de um pacote. Depois eu fui continuar e então apareceu erro, e disse que eu tinha de executar o comando dpkg --configure e solucionar o problema. Fiz isso e então apareceu:

/var/lib/dpkg/updates/0000
Próximo a linha1: O campo Linux precisa ser seguido de vírgula.

Fui lá e botei a vírgula e executei o comando novamente, então apareceu:

O campo Linux, precisa ser seguido de vírgula. Como não resolveu :roll: retirei a vírgula. Aqui está o arquivo:

Arquivo anexado.

Só sei que deis daí não consigo instalar pacotes .deb e .rpm. Valeu!

Douglas Lima
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/12/2008, 16:46
Resposta: #2
 
está meio confuso, o arquivo anexado num tem nada a ver com o seu problema. O que realmente aparece ao dar os comandos:
# apt-get update
# apt-get -f install

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/12/2008, 16:22
Resposta: #3
 
Este screenshot responde sua pergfunta?


Arquivo anexado.
:?:

Douglas Lima
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/12/2008, 18:09
Resposta: #4
 
Olá Douglas...

os comandos devem ser feitos timtim por timtim, ou seja:

no teu screenshot, o sistema manda vc dar um "dpkg --recunfigure -a", mas segundo você disse, você só fez "dpkg --reconfigure", sem o parâmetro "-a"

tente "dpkg --reconfigure -a"

e no caso do apt-get -f install, a letra "F" você digitou em letra maiúscula, ela tem que ser digitada com letra minúscula:

apt-get -f install...

sendo assim, primeiro tente (ipsis litteris):

"dpkg --reconfigure -a"

depois, se não der certo, tente:

"apt-get -f install"

Abraços!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/12/2008, 20:40
Resposta: #5
 
Não esqueça que o Linux é case sensitive, ou seja, minúsculos e maiúsculos fazem diferença, como o dmatrix citou, é -f, e não -F...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/01/2009, 19:32
Resposta: #6
 
Valeu voces dois!!

Douglas Lima
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/01/2009, 20:38
Resposta: #7
 
Arquivo anexado.
Bom, no apt-get -f install eu nem precisei de pacote pra instalar, taí, logo de cara se ve o problema, e agora?!

Douglas Lima
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/01/2009, 22:24
Resposta: #8
 
Tente:

dpkg-reconfigure -a
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/01/2009, 01:09
Resposta: #9
 
OPPAAAAA!!!

Falha nossa! :oops:

O spikey tem razão!

O comando correto é:

dpkg-reconfigure -a

e não:

dpkg --reconfigure -a

Tenta aí!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
02/01/2009, 14:02
Resposta: #10
 
DRAGSTERTUNER Escreveu:OPPAAAAA!!!

Falha nossa! :oops:

O spikey tem razão!

O comando correto é:

dpkg-reconfigure -a

e não:

dpkg --reconfigure -a

Tenta aí!
é:
dpkg --configure -a

dpkg-reconfigure é a mesma coisa, reconfigura todos os pacotes instalados.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/01/2009, 18:43
Resposta: #11
 
Bom, eu digitei, ai aparece o erro que eu falei na primeira mensagem, e, embaixo apareceu
3ddesktop não está instalado. (3ddesktop é o pacote que eu tava isntalndo quo faltou a energia. ai eu digitei:
locate 3ddesktop
ai apareceu dois arquivos, fui ver era a documentação. E agora?

Douglas Lima
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/01/2009, 21:15
Resposta: #12
 
Douglas, nos arquivos que vc anexou não contém a saída do erro do comando:

dpkg --configure -a

Naquele que vc anexou, vc digitou o comando errado (dpkg --reconfigure -a) lembra-se? Dê esse comando:

dpkg --configure -a

e mostra pra gente a saída!

Abraços!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/01/2009, 09:37
Resposta: #13
 
o que acontece se tentar instalar ele com o aptitude?
# aptitude install 3ddesktop

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/01/2009, 21:50
Resposta: #14
 
Bom, com o aptitude não instalou e quanto ao dpkg --configure -a, este foi o resultado:

Arquivo anexado. Agora ele só instala rpm.

Douglas Lima
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/01/2009, 09:18
Resposta: #15
 
tente o seguinte, apague esses diretórios ou arquivos que estiverem dentro do update
dmatrix:/var/lib/dpkg/updates$ sudo rm -rf *.*

dmatrix:/var/lib/dpkg/updates$ ls -la
total 8
drwxr-xr-x 2 root root 4096 Jan 10 09:26 .
drwxr-xr-x 8 root root 4096 Jan 10 09:26 ..

depois tente novamente dar o dpkg --configure -a

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS