Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
COnfigurações para usar COMPIZ
04/12/2008, 18:20
Resposta: #1
COnfigurações para usar COMPIZ
Olá. Instalei o compiz aqui (fusão do Beryl com o Compiz acho) para fazer aqueles efeitos de cubo girando e tal.. Porém, acredito que o mesmo não esteje funcionando por falta de alguma configuração que devo ter que fazer no xorg.conf e não foi feita automaticamente.

Eu instalei o compiz pelo Synaptic, o driver da nvidia manualmente e o xorg.conf que eu tenho é:

Citar:# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 ([email protected]) Tue Nov 4 14:07:17 PST 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

O que preciso fazer pra rodar o compiz aqui corretamente? Obrigado.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/12/2008, 20:00
Resposta: #2
 
Primeiro verifique se a aceleração por hardware está ativa:

Código:
glxinfo | grep direct

O resultado do comando acima deve ser:
Código:
direct rendering: Yes
Se aparecer "No", verifique a instalação do driver da Nvidia.

Depois execute no terminal:

Código:
compiz --replace

Se não funcionar, poste as mensagens de erro que o compiz irá mostrar no terminal.

[Imagem: debianuseruserbarsp1.png]
[Imagem: gnomeuserqj9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/12/2008, 20:06
Resposta: #3
 
Olá. Driver da nvidia foi instalado manualmente e corretamente até onde eu sei. A bandeira da nvidia aparece sempre que eu reinicio o PC. Porém a aceleração 3D nao funciona:

Citar:[email protected]:/home/eu# glxinfo
name of display: :0.0
Error: glXCreateContext failed

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x63 32 tc 0 32 0 r . . 8 8 8 8 0 0 0 0 0 0 0 0 0 Ncon
[email protected]:/home/eu#
[email protected]:/home/eu# glxinfo | grep direct
Error: glXCreateContext failed

O que devo fazer? O xorg.conf foi configurado automaticamente também pelo programa da nvidia no finalzinho da instalação e ficou como eu postei acima.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/12/2008, 16:13
Resposta: #4
 
To com o mesmo problema, alguem pode ajudar?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/12/2008, 16:16
Resposta: #5
 
oi. eu resolvi reinstalando o driver da nvidia. tenta fazer isso ai em modo mono usuario (texto apenas). Deve resolver pra vc também.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS