Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
squid, não está respondendo - Resolvido
08/12/2008, 16:32
Resposta: #16
 
Bom dia!

Vou verificar as configurações, e rodarei os comandos novamente. de fato, parece ser o squid o problema. Tentei as mesmas configuraçoes usando o kurumin 7- apenas para teste, e apresentou os mesmos problemas.
Amanhã farei mais alguns testes com mais calma.
Muito obrigado pela grande ajuda.

Jorge Orlando
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/12/2008, 11:45
Resposta: #17
 
Instalei o Webmin e por ele apresentou o seguinte erro do squid

The Squid cache manager program /usr/lib/cgi-bin/cachemgr.cgi was not found on your system. Maybe your module configuration is incorrect.

Pode ser isso que esteja afetando o mal funcionamento do squid?

Jorge Orlando
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/12/2008, 18:31
Resposta: #18
 
Talvez... tente apt-cache search cahcemgr e poste o resultado. Não me lembro de ter instalado esse programa em separado, mas vamos ver...

Elieser Carlos Topassi
Analista de Sistemas, Consultor
Bacharelando em Ciências da Computação

UNESP - Universidade Estadual Paulista "Julio de Mesquita Filho"
São José do Rio Preto, SP
_____________________________________________________
Porque Deus escolheu as coisas Loucas deste mundo para confundir as Sábias... e as Fracas para envergonhar as Fortes... (1Co 1:27)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/12/2008, 07:55
Resposta: #19
 
Bom dia!

Adicionando ao firewall a regra iptables -t filter -A INPUT -i lo -j ACCEPT o squid passa a responder só que ele não realiza os controles de acesso como os sites proibidos e a proibição baseada em palavras. Vou tentar instalar o que me pediu acima e postarei os resultados.

Jorge Orlando
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/12/2008, 13:11
Resposta: #20
 
Bom dia!

Depois que fiz os passos descritos acima e não apresentou nenhum erro e depois eu reiniciei o squid, e ele passou a funcionar perfeitamente, inclusive com as regras de controle. - Muito obrigado mesmo pela ajuda.

Jorge Orlando
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/12/2008, 10:52
Resposta: #21
 
Bom dia!

Reiniciei o squid novamente e os erros começaram de novo, o proxy funciona, mas a retrição por palavra e url pararam de funcionar novamente.
Assim troquei o jeito de resolver o problema, ao inves de criar um arquivo com as urls não permitidas e fazer alusão a isso, como:

acl bloqueados url_regex -i "/etc/squid/bloqueados"
http_access deny bloqueados

Eu passei a citar as urls dentro do squid.conf e tudo funcionou corretamente.

Obrigado pela ajuda.

Jorge Orlando
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS