Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
navega mas não pinga!
21/11/2008, 19:03
Resposta: #1
navega mas não pinga!
entro no console e dou um "ping www.nomedosite.com.br" e nada

a mesma coisa se eu tento pingar um ip de uma amigo ou site...

Andei procurando aqui alguma coisa de errado e descobri que o /etc/hosts ainda faz referência a um provedor antigo, que eu já nem sou mais cliente, vejam:

127.0.0.1 localhost supercharger
127.0.1.1 supercharger.bno.com.br supercharger

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

72.21.35.186 www.megajogos.com.br services.megajogos.com.br
72.232.235.66 www.clubdelgioco.it
209.67.221.10 jam.unitedjoy.com download.megajogos.com.br
66.111.34.40 jam2.unitedjoy.com
216.32.89.178 access.megajogos.com.br
216.32.80.234 mjnet.megajogos.com.br

Eu já não sou + cliente da bno...atualmente sou cliente da tvsom...será que tem problema?

Aqui vão alguns dados que talvez possam ajudar...

supercharger:/home/supercharger# ifconfig
eth0 Encapsulamento do Link: Não Especificado Endereço de HW 00-11-D8-00-01-5D-0E-93-00-00-00-00-00-00-00-00
inet end.: 200.213.139.61 Bcast:200.213.139.255 Masc:255.255.255.0
UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:2635 (2.5 KiB)

eth1 Encapsulamento do Link: Ethernet Endereço de HW 00:1B:FC:CB:55:BB
inet end.: 10.10.167.202 Bcast:10.10.167.203 Masc:255.255.255.252
UP BROADCASTMULTICAST MTU:1500 Métrica:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
IRQ:17

eth2 Encapsulamento do Link: Ethernet Endereço de HW 00:1B:FC:CB:55:2B
inet end.: 10.10.167.202 Bcast:10.10.167.203 Masc:255.255.255.252
UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
RX packets:19320 errors:0 dropped:0 overruns:0 frame:0
TX packets:3137 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:1000
RX bytes:2704418 (2.5 MiB) TX bytes:483647 (472.3 KiB)
IRQ:16 Endereço de E/S:0xcc00

lo Encapsulamento do Link: Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
UP LOOPBACKRUNNING MTU:16436 Métrica:1
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:0
RX bytes:1600 (1.5 KiB) TX bytes:1600 (1.5 KiB)


supercharger:/home/supercharger# route
Tabela de Roteamento IP do Kernel
Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
10.10.167.200 * 255.255.255.252 U 0 0 0 eth1
10.10.167.200 * 255.255.255.252 U 0 0 0 eth2
200.213.139.0 * 255.255.255.0 U 0 0 0 eth0
default 10.10.167.201 0.0.0.0 UG 0 0 0 eth2
default 10.10.167.201 0.0.0.0 UG 0 0 0 eth1
supercharger:/home/supercharger#


/etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

# The primary network interface
allow-hotplug eth2
iface eth2 inet static
address 10.10.167.202
netmask 255.255.255.252
gateway 10.10.167.201

iface eth1 inet static
address 10.10.167.202
netmask 255.255.255.252
gateway 10.10.167.201

iface eth0 inet static
address 200.213.139.61
netmask 255.255.255.0

auto eth1

auto eth0
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/11/2008, 19:42
Resposta: #2
 
Vamos por partes:

1. Mude seu /etc/hosts e retire a linha q tem o IP 127.0.1.1. Ela é inútil no seu caso...
Se você não usar IPv6 (ou nãou souber o que é) deleta tudo que está no seu /etc/hosts, deixando só a primeira linha. Pode fazer sem medo. Isso vai organizar melhor seu sistema.

2. Me explique porque as interfaces eth1 e eth2 têm o mesmo IP.
Pelo que entendi, eth0 e eth1 são duas placas físicas que você possue, certo??? o que é a eth2? cartão PCMCIA ou Modem 3G?

3. O IP da eth0 é recebido do seu provedor? ou o sinal do provedor está na eth1? Ou são dois provedores que você usa ao mesmo tempo?

4. Essa rede 10.10.167.X é sua? ou foi seu provedor que a forneceu?

Responda ai que eu vejo se dá pra te ajudar...

Mas já adianto que não está pingando por causa da bagunça que tá essa configuração de rede.

Elieser Carlos Topassi
Analista de Sistemas, Consultor
Bacharelando em Ciências da Computação

UNESP - Universidade Estadual Paulista "Julio de Mesquita Filho"
São José do Rio Preto, SP
_____________________________________________________
Porque Deus escolheu as coisas Loucas deste mundo para confundir as Sábias... e as Fracas para envergonhar as Fortes... (1Co 1:27)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/11/2008, 20:14
Resposta: #3
 
*** Me explique porque as interfaces eth1 e eth2 têm o mesmo IP:

eth1 e 2 são as placas de rede da placa mãe, a da marvell e da realtek.

eth0 é o mini-modem da tim q eu tentei instalar aqui em casa e depois desisti... está inativo atualmente...

As duas placas de rede possuem o mesmo IP porque há tempos atrás, os meus problemas de conexão eu atribuía às placas de rede, então, eu ficava mudando de uma pra outra pra ver se a conexão melhorava.

Mas nos dias de hoje isso é desnecessário por 2 motivos:

1) descobri que os problemas da minha conexão não tem nada a ver com minhas placas, pq o desempenho da rede nunca mudou trocando de uma pra outra.

2) O provedor passou a travar a conexão por meio do MAC...se eu colocar a net na placa eth1, não irá funcionar, portanto atualmente só preciso da placa eth2 para internet.

*** O IP da eth0 é recebido do seu provedor?

Não sei da onde vem esse nº...não é do meu provedor...pode ser do mini-modem da tim, que eu desisti de instalar.

*** O sinal do provedor está na eth1?

O meu provedor atual está na eth2

****Ou são dois provedores que você usa ao mesmo tempo?

Não. Tenho somente um provedor atualmente. Nem o da BNO nem o do mini-modem da tim estão ativos.

***Essa rede 10.10.167.X é sua? ou foi seu provedor que a forneceu?

Esse número foi fornecido pelo atual provedor de internet.

Obrigado desde já pela ajuda!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/11/2008, 18:22
Resposta: #4
 
Edita ao seu /etc/network/interfaces e faz o seguinte:

1. Apaga tudo referente à eth0. Se o modem da tim não está mais conectado no seu computador, não tem necessidade de manter informações.

2. Apaga tudo referente à eth1. Se o seu provedor exige q vc utilize a eth2 por causa do mac, não vai ter necessidade de manter esse IP ai.

3. A ligação do seu provedor é por CABO (modem ou rádio) certo? então substitui o allow-hotplug por auto na eth2. Se for PCMCIA ou USB você precisa do hotplug.

O arquivo deverá ficar mais ou menos assim:
Código:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

# The primary network interface
auto eth2
iface eth2 inet static
    address 10.10.167.202
    netmask 255.255.255.252
    gateway 10.10.167.201

Edita o /etc/resolv.conf e retira todo o lixo. Deixa só a primeira linha.

Depois faz um ifconfig e um route e posta aqui as saídas.
Tenta fazer o ping e veja se funciona.

Elieser Carlos Topassi
Analista de Sistemas, Consultor
Bacharelando em Ciências da Computação

UNESP - Universidade Estadual Paulista "Julio de Mesquita Filho"
São José do Rio Preto, SP
_____________________________________________________
Porque Deus escolheu as coisas Loucas deste mundo para confundir as Sábias... e as Fracas para envergonhar as Fortes... (1Co 1:27)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/11/2008, 20:44
Resposta: #5
 
Depois dessas mudanças ficou assim:

supercharger:/home/supercharger# ifconfig
eth2 Encapsulamento do Link: Ethernet Endereço de HW 00:1B:FC:CB:55:2B
inet end.: 10.10.167.202 Bcast:10.10.167.203 Masc:255.255.255.252
UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
RX packets:44797 errors:0 dropped:0 overruns:0 frame:0
TX packets:32351 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:1000
RX bytes:17701113 (16.8 MiB) TX bytes:19260759 (18.3 MiB)
IRQ:16 Endereço de E/S:0xec00

lo Encapsulamento do Link: Loopback Local
inet end.: 127.0.0.1 Masc:255.0.0.0
UP LOOPBACKRUNNING MTU:16436 Métrica:1
RX packets:44 errors:0 dropped:0 overruns:0 frame:0
TX packets:44 errors:0 dropped:0 overruns:0 carrier:0
colisões:0 txqueuelen:0
RX bytes:2200 (2.1 KiB) TX bytes:2200 (2.1 KiB)

supercharger:/home/supercharger# route
Tabela de Roteamento IP do Kernel
Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
10.10.167.200 * 255.255.255.252 U 0 0 0 eth2
default 10.10.167.201 0.0.0.0 UG 0 0 0 eth2
supercharger:/home/supercharger#



etc/resolv.conf:

domain tvsom.com.br
nameserver 200.242.124.157
nameserver 200.174.99.119

Infelizmente continuo com problemas no ping...ele pinga alguns sites, + a maioria não...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/11/2008, 23:10
Resposta: #6
 
Bom, suas configurações de rede estão mais organizadas agora... vamos pensar no ping daqui pra frente.

1) Quais sites pingam normalmente? alguns exemplos

2) Quais sites não pingam? alguns exemplos

3) Você está tentando pingar pelo IP ou pelo FQDN?


Abre o /etc/resolv.conf, comenta todas as linhas (#), e adiciona o seguinte ao final:
Código:
# OpenDNS:
nameserver 208.67.222.222
nameserver 208.67.220.220

Depois tenta fazer o ping nos endereços FQDN que não estavam pingando.

Elieser Carlos Topassi
Analista de Sistemas, Consultor
Bacharelando em Ciências da Computação

UNESP - Universidade Estadual Paulista "Julio de Mesquita Filho"
São José do Rio Preto, SP
_____________________________________________________
Porque Deus escolheu as coisas Loucas deste mundo para confundir as Sábias... e as Fracas para envergonhar as Fortes... (1Co 1:27)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/11/2008, 18:12
Resposta: #7
 
Descobri hoje que eu nunca vou conseguir pingar nada!!!!!!!!


Liguei pro provedor e pasme!

O kr me disse que eles não permitem que o usuário faça ping por causa q eles temem um ddos!!!!

:shock:

Será??

Se for assim, tá tudo explicado...mas de qq forma valeu pela ajuda para arrumar o sistema, q tava bagunçado!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/11/2008, 15:21
Resposta: #8
 
ashuashuashuashua
bloquer ICMP por medo de DoS é o cúmulo.
Pergunta pra eles se já ouviram falar em Sesion Coockies ???

Além do que, não é só por ICMP que se faz um DoS...
cá pra nós, mto ruim esse seu servidor hein...

Elieser Carlos Topassi
Analista de Sistemas, Consultor
Bacharelando em Ciências da Computação

UNESP - Universidade Estadual Paulista "Julio de Mesquita Filho"
São José do Rio Preto, SP
_____________________________________________________
Porque Deus escolheu as coisas Loucas deste mundo para confundir as Sábias... e as Fracas para envergonhar as Fortes... (1Co 1:27)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/11/2008, 15:22
Resposta: #9
 
Pelo menos você ficou com sua configuração de rede mais limpa... deixa aqueles arquivos sempre organizados, senão qualquer hora vc fica sem navegar por erro num deles.

Elieser Carlos Topassi
Analista de Sistemas, Consultor
Bacharelando em Ciências da Computação

UNESP - Universidade Estadual Paulista "Julio de Mesquita Filho"
São José do Rio Preto, SP
_____________________________________________________
Porque Deus escolheu as coisas Loucas deste mundo para confundir as Sábias... e as Fracas para envergonhar as Fortes... (1Co 1:27)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/11/2008, 18:08
Resposta: #10
 
"ashuashuashuashua
bloquer ICMP por medo de DoS é o cúmulo.
Pergunta pra eles se já ouviram falar em Sesion Coockies ???"

Vc não faz a MÍNIMA idéia do que são os provedores daqui de Macapá...

Esse mesmo gerente q me disse q bloqueia ping foi o q disse que o fato de eu estar pegando 4~8 kbytes de download não tem nada a ver a minha taxa de conexão...kkkkkkkkkk

Ele só não me explicou pq no gráfico de consumo da minha banda tem uma parte do gráfico em q a conexão fica em 10kbits (eu disse 10kbits, e não kbytes!!), enquanto tem cláusula contratual me garantindo no mínimo 128kbits...

Mas já protocolei uma denúncia com farta documentação provando tudo isso sexta passada e to aguardando a decisão da ANATEL.

"Pelo menos você ficou com sua configuração de rede mais limpa... deixa aqueles arquivos sempre organizados, senão qualquer hora vc fica sem navegar por erro num deles."

Sim, a organização desses arquivos foi um passo importante nesse meu sistema...se algum dia Macapá tiver um provedor de internet q preste, ao menos um sistema rodando perfeitamente eu vou ter...

Obrigado pela ajuda!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/11/2008, 19:31
Resposta: #11
 
hehe...
precisando estamos ai...

abraços.

Elieser Carlos Topassi
Analista de Sistemas, Consultor
Bacharelando em Ciências da Computação

UNESP - Universidade Estadual Paulista "Julio de Mesquita Filho"
São José do Rio Preto, SP
_____________________________________________________
Porque Deus escolheu as coisas Loucas deste mundo para confundir as Sábias... e as Fracas para envergonhar as Fortes... (1Co 1:27)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS