Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Compartilhamento de internet, nao consigo dar ping nos sites
29/10/2008, 11:00
Resposta: #1
Compartilhamento de internet, nao consigo dar ping nos sites
Pessoal, bom dia!!

Estou com uma maquina rodando o debian 4.o com duas placas de redes com as seguintes configurações:

Placa de rede 1 ( eth0 ) --> conexão com a internet
Placa de rede 2 ( eth1 ) --> conexao de Rede Local


/etc/network/interfaces

auto lo
iface inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.99
netmask 255.255.255.0
broadcast 192.168.1.255
network 192.168.1.0
gateway 192.168.1.1

auto eth1
iface eth1 inet static
address 192.168.1.4
netmask 255.255.255.0
broadcast 192.168.20.255
network 192.168.20.0

no /etc/init.d/compartilhamento

#!/bin/bash

echo "1" > /proc/sys/net/ipv4/ip_forward

iptables -F
iptables -t nat -F
iptables -t mangle -F
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

executei o comando:

chmod +x /etc/init.d/compartilhamento

Para dar permissao para os demais usuarios

no arquivo /etc/rc2.d

usei o seguinte comando para criar a chamada

ln -s /etc/init.d/compartilhamento /etc/rc2.d/S99compartilhamento

posteriormente dei um apt-get install bind9

Coloquei a seguinte configuracao no meu outro pc com windows xp

ip: 192.168.20.2
mascara de rede: 255.255.255.0
dns: 192.168.20.1
gateway: 192.168.20.1

com essa configuracao e so pingo o servidor mas os sites nao.

porem qdo troco o DNS do pc com WINXP e coloca 192.168.1.1 ele pinga nos sites porem nao acessa a internet.

Estou usando um switch da D link para distribuir do servidor para o outro micro com XP

Obs: A internet que utilizo vem de um modem + roteador + Wireless da 3COM.


O que estou fazendo de errado ??

Desde já agradeco o apoio
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/10/2008, 11:06
Resposta: #2
 
olha cara posso estar falando besteira, mas tenta deixar a sua eth0 em dhcp só para vermos.
Espero ter ajudado
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/10/2008, 11:09
Resposta: #3
 
Pior que ja tentei por DHCP...

Da o mesmo problema....
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/10/2008, 12:12
Resposta: #4
 
Quem não consegue pingar sites na internet quando você ativa essa configuração, o servidor ou as máquinas na sua rede?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/10/2008, 13:54
Resposta: #5
 
o servidor pinga normal, a maquina da rede se trocar o dns 192.168.20.1 por 192.168.1.1 tambem pinga porem nao acessa a interntet. ja com o dns 192.168.20.1 ele so pinga o servidor a interner nao responde.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/10/2008, 23:19
Resposta: #6
 
No seu servidor, você configurou a placa da rede interna como:

Código:
auto eth1
iface eth1 inet static
address 192.168.1.4
netmask 255.255.255.0
broadcast 192.168.20.255
network 192.168.20.0

Porém no Windows XP definiu o gateway como 192.168.20.1. Não deveria ser 192.168.1.4?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/10/2008, 07:48
Resposta: #7
 
Fernando, consegui ja consigo acessar a internet nomalmente, pela sub-rede.... baixei outra versao do debian e fiz o mesmo procedimento e deu certo, porem preciso bloquear alguns sites, como orkut, msn , etc peguei alguns scripts prontos na internet conforme abaixo:

iptables -t nat -A POSTROUTING -p tcp -s 192.168.0.0/24 -d 0.0.0.0/0 --dport 1863 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 64.215.169.48/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 207.68.179.219/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 65.54.142.189/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 65.54.211.61/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 200.216.69.232/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 65.54.140.158/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 206.63.10.99/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 65.54.194.118/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 194.129.79.6/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 207.46.106.98/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 207.46.104.20/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 65.54.157.111/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 207.46.110.12/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 65.54.195.188/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 207.46.108.86/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 207.63.10.98/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 207.46.110.43/24 -j DROP
iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -d 207.68.178.61/24 -j DROP

criei um arquivo no /etc/init.d/firewall com essas configuracoes

e dei permissao

chmod +x /etc/init.d/firewall

depois executei o arquivo

/etc/init.d/compartilhamento

e por fim no /etc/rc2.d

criei uma chamada para o arquivo

ln -s /etc/init.d/firewall /etc/rc2.d/S99firewall

Porem nao funcionou.

A duvida:

Estou colocando a regra do iptables no lugar correto? Esta faltando algum comando?

Obs: Nao quero usar o squid apenas o iptables.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/10/2008, 15:41
Resposta: #8
 
Olá,

Tente colocar PREROUNTING ao invés de POSTROUTING.

Veja se agora ele passa a bloquear...
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/11/2008, 14:36
Resposta: #9
 
Boa tarde galera, sou iniciante no Debian e gostaria de saber se existe a possibilidade de fazer o compartilhamento da conexao, sem ter que configurar nas estações o dns do servidor de internet, podendo assim, configurar qlquer outro servidor de dns, como o servidor dns windows ou da telefonica, pois onde trabalho, usamos ip fixo e todos apontam o dns para o server windows, e seria muito trabalhoso reconfigurar todos os dns das estações, porque na configuração de compartilhamento que fiz, as estações só conseguem navegar indicando o ip do servidor de internet no dns, ja instalei o bind9, porem nao deu certo, vou postar aq minhas configurações

-------------
/etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
address 192.168.3.238
netmask 255.255.252.0
network 192.168.0.0
broadcast 192.168.3.255
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 192.168.0.1
dns-search grupo
gateway 192.168.0.250

iface eth1 inet static
address 172.19.128.110
netmask 255.255.255.252
gateway 172.19.128.109


auto eth0

auto eth1

-----------------------------------
/etc/rc.local

modprobe iptable_nat
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
echo 1 > /proc/sys/net/ipv4/ip_forward

---------------------------------
squid.conf


http_port 3128 transparent
visible_hostname NutriplusServerProxyTesteJimi

cache_mem 128 MB
maximum_object_size_in_memory 128 KB
maximum_object_size 512 MB
minimum_object_size 0 MB
cache_swap_low 90
cache_swap_high 95
cache_dir ufs /var/spool/squid 2048 16 256
cache_access_log /var/log/squid/access.log
refresh_pattern ^ftp: 15 20% 2280
refresh_pattern ^gopher: 15 0% 2280
refresh_pattern . 15 20% 2280

acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl SSL_ports port 443 563
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # http ttps
acl Safe_ports port 70 # gropee
acl Safe_ports port 210 # wais
acl Safe_ports port 280 # fttp-mgmt
acl Safe_ports port 488 # gsss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # muiltiling
acl Safe_ports port 901 # swat
acl Safe_ports port 1024-65535 # portas altas
acl purge method PURGE
acl CONNECT method CONNECT

http_access allow manager localhost
http_access deny manager
http_access allow purge localhost
http_access deny purge
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports

acl bloqueados url_regex -i "/etc/squid/bloqueados"
http_access deny bloqueados

acl redelocal src 192.168.3.0/24
http_access allow localhost
http_access allow redelocal
http_access deny all
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS