Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
[RESOLVIDO]Aparece 'Its Works mesmo com pasta excluida
06/10/2008, 15:40
Resposta: #1
[RESOLVIDO]Aparece 'Its Works mesmo com pasta excluida
Olá pessoal, por favor uma ajuda!

Estou tentando por o site do lugar onde trabalho no ar só que aparece toda hora o aviso padrão do apache2 (Its Works). Só que a pasta onde fica este aviso (/var/www/apache2-default) foi apagada e o aviso continua aparecendo.

O que faço? Ja segui diversos tutoriais indicando como configurar o hostname no apache2 e nada. Tem hora que o site funciona e tem hora que não.

Inclusive alterei o ARQUIVo "default" da pasta /etc/apache2/sites-available/ , comentando a linha "redirectmach" e nada

o servidor q estou usando é um Linux debian etch 4.0 com apache2, php5, mysql5 e phpmyadmin.

Agradeço qualquer ajuda...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/10/2008, 16:44
Resposta: #2
 
Por partes, como esta o teu httpd.conf nele tem as localizações dos sites internos, então é por ai que você tem de mexer para alterar isso.

O site já funcionou alguma vez? em que diretório esta? como você chamou ele pelo browser?

Rodrigo Braga Prado
Consultor de Informática/Segurança
Especialista em Linux e Software Livre
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/10/2008, 16:50
Resposta: #3
 
rodrigobp Escreveu:Por partes, como esta o teu httpd.conf nele tem as localizações dos sites internos, então é por ai que você tem de mexer para alterar isso.

O site já funcionou alguma vez? em que diretório esta? como você chamou ele pelo browser?

O httpd.conf estava vazio e ai eu criei ele setando as configuracoes pro meu site:

Ex:
NameVirtualHost *

<VirtualHost *>
ServerName www.nomedomeusite.dominio.com.br
DocumentRoot /var/www/nomedomeusite
DirectoryIndex /index.html
</VirtualHost>

ele funciona as vezes aqui dentro do meu trabalho. Só que pedi pra outras pessoas testarem o site e não funcionou.

quando acesso, o site aparece diretamente na pasta /var/www/nomedomeusite.

Só que as vezes ele aparece a mensagem "its works" e o caminho do site aparece como sendo www.nomedomeusite.dominio.com.br/apache2-default
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/10/2008, 18:44
Resposta: #4
 
Dê uma procurada no teu sistema para ver onde esta o httpd.conf correto.

Outra coisa para testar efetivamente tem quer via http://localhost/site ou http://ip_do_micro/site ou a url que você configurou no sistema dns interno como o www.site.com, por diretório não é o correto!

Você esta usando o apache ou o apache2? Como você o configurou?

Rodrigo Braga Prado
Consultor de Informática/Segurança
Especialista em Linux e Software Livre
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/10/2008, 18:50
Resposta: #5
 
betofortal Escreveu:
rodrigobp Escreveu:Por partes, como esta o teu httpd.conf nele tem as localizações dos sites internos, então é por ai que você tem de mexer para alterar isso.

O site já funcionou alguma vez? em que diretório esta? como você chamou ele pelo browser?

O httpd.conf estava vazio e ai eu criei ele setando as configuracoes pro meu site:

Ex:
NameVirtualHost *

<VirtualHost *>
ServerName www.nomedomeusite.dominio.com.br
DocumentRoot /var/www/nomedomeusite
DirectoryIndex /index.html
</VirtualHost>

ele funciona as vezes aqui dentro do meu trabalho. Só que pedi pra outras pessoas testarem o site e não funcionou.

quando acesso, o site aparece diretamente na pasta /var/www/nomedomeusite.

Só que as vezes ele aparece a mensagem "its works" e o caminho do site aparece como sendo www.nomedomeusite.dominio.com.br/apache2-default

Olá,

Por favor, poste o conteúdo desse arquivo:

Código:
cat /etc/apache2/sites-enabled/000-default

Por padrão é nele que esse redirecionamento é feito.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
07/10/2008, 10:05
Resposta: #6
 
Eu tinha desabilitado o arquivo "default" do caminho /etc/apache2/sites-available/default pelo comando "a2disite" e criado um arquivo com as configuracoes do meu site.

Com isto o arquivo "000-default" tinha sumido da pasta "sites-enable".

Agora habilitei novamente o "default" (pelo comando "a2ensite default") , e o arquivo "000-default" apareceu novamente com esta configuração:

PS: Notem que eu havia comentado a linha "RedirectMatch ^/$ /var/www/apache2-default/" para não aparecer mais. INclusive alterei o caminho padrão para /var/www mas mesmo assim o caminho "apache2-default" continua aparecendo pra mim. E o pior que eu deletei a pasta "apache2-default" do www e mesmo assim parece a "bendita" mensagem "it´s works".

Conteudo do 000-Default
--------------------------------------------------------------
NameVirtualHost *
<VirtualHost *>
ServerAdmin [email protected]

DocumentRoot /var/www/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
#** RedirectMatch ^/$ /var/www/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin]
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/]
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>
</VirtualHost>
--------------------------------------------------------------
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
07/10/2008, 12:46
Resposta: #7
 
Olá,

Deixe o seu arquivo da seguinte forma:

Código:
NameVirtualHost *
<VirtualHost *>
ServerAdmin [email protected]

DocumentRoot /var/www/
</VirtualHost>

Apenas com esse conteúdo.

Salve e reinicie o apache:

Código:
/etc/init.d/apache2 restart

Veja se agora funciona corretamente.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/10/2008, 09:08
Resposta: #8
 
Olá Fernando, obrigado pela ajuda mas nao deu certo.

Eu formatei a máquina e instalei td do ZERO. No começo, funcionou tranquilo. O site estava sendo acessado por todo mundo.

Só que agora tem hora que vc acessa e funciona e tem hora que aparece http://www.meusite.com.br/apache2-default/ e a mensagem "its works".

O que eu faço galera? O pior que eu ja alterei o apache.conf, comentei a linha do redirect mach e tudo e não funciona. Não sei mais o que fazer.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/10/2008, 11:23
Resposta: #9
 
Olá,

Quando você diz acessar por http://www.meusite.com.br, quer dizer que você está acessando de um endereço diferente do localhost, correto?

Você criou um VirtualHost para www.meusite.com.br?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/10/2008, 13:49
Resposta: #10
 
Fernando Escreveu:Olá,

Quando você diz acessar por http://www.meusite.com.br, quer dizer que você está acessando de um endereço diferente do localhost, correto?

Você criou um VirtualHost para www.meusite.com.br?

Não criei.

Eu peguei o default do site-enable e setei para a pasta onde esta a pagina.

Eu fiz este site no sistema Joomla e fiz no windows xp. Será que tem alguma incompatibilidade por ter levado o site para o Debian? eu sei que tem que "converter" alguns arquivos da plataforma windows para o linux usando o comando dos2unix, mas não consigo com pastas.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/10/2008, 14:55
Resposta: #11
 
betofortal Escreveu:
Fernando Escreveu:Olá,

Quando você diz acessar por http://www.meusite.com.br, quer dizer que você está acessando de um endereço diferente do localhost, correto?

Você criou um VirtualHost para www.meusite.com.br?

Não criei.

Eu peguei o default do site-enable e setei para a pasta onde esta a pagina.

Eu fiz este site no sistema Joomla e fiz no windows xp. Será que tem alguma incompatibilidade por ter levado o site para o Debian? eu sei que tem que "converter" alguns arquivos da plataforma windows para o linux usando o comando dos2unix, mas não consigo com pastas.

Não, esse tipo de imcompatibilidade dificilmente ocorre.

Como você formatou a máquina e instalou de novo, seria possível postar novamente o seu apache2.conf e o 000-default ( ou qualquer outro arquivo que esteja dentro de sites-enabled?

Depois que você faz as alterações nos arquivos, está reiniciando o apache? ( é necessário reiniciar para que as alterações entrem em vigor )
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/10/2008, 15:56
Resposta: #12
 
Fernando descobri qual era o erro. Existia um site que estava com o mesmo IP q o meu. Mó "Bisonhice" minha..risos.

E o pior que não era só 1. Eram 2! :|

Quando desliguei um, o outro "pegou" o ip da minha maquina. Desliguei o outro e funcionou. Agora nao tenho mais dor de cabeça!

Obrigado pela ajuda meu amigo! Grande abraço!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/10/2008, 01:01
Resposta: #13
 
Bom se você resolveu, altere o título do tópico acrescendo RESOLVIDO, assim aumentamos a nossa base de soluções e conhecimentos.

Abraços

Rodrigo Braga Prado
Consultor de Informática/Segurança
Especialista em Linux e Software Livre
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS