Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
[RESOLVIDO]INTERNET deixa de funcionar com VPN PPTP
20/09/2008, 16:10
Resposta: #1
[RESOLVIDO]INTERNET deixa de funcionar com VPN PPTP
Boa tarde,

Estou com o seguinte problema :

1) Ao acessar um servidor windows 2003 via VPN PPTP, fico sem poder navegar na internet.

Dados auxiliares para auxiliar na resolução do problema :

S.O: Debian GNU/Linux Lenny 2.6.26-1-amd64.
Modem : DSL-500B da DLINK.
Observação : Não efetuo nenhuma configuração para ter acesso internet. Está tudo configurado no modem, ou seja, o meu dispositivo de acesso a internet e o eth0.

Não possuo firewall e nem proxy configurado.

Ao executar o comando echo 1 > /proc/sys/net/ipv4/ip_forward, consigo pingar em alguns sites normalmente e o tracert também funciona de forma normal. Porém não consigo navegar na internet, nem ler e-mails, nada... nada. Acho que neste caso ele deve estar usando o link do gateway da VPN para efetuar os comandos.

Gostaria de continuar a navegar na internet através do meu link e não do link da VPN.

Fico no aguardo para que me ajudem.

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/09/2008, 01:41
Resposta: #2
 
não ficou claro a forma que está utilizando para trocar de conexão, assim peço que verifique como está ficando o gateway padrão, quando está acessando uma conexão e novamente quando estiver acessando a outra, utilize para isso o comando route:
# route
Assim quando deixar de acessar o servidor windows 2003 terá que executar alguns comando para restaurar o gateway correto. Isso é o que me parece que está ocorrendo aí.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/09/2008, 09:19
Resposta: #3
 
dmatrix Escreveu:não ficou claro a forma que está utilizando para trocar de conexão, assim peço que verifique como está ficando o gateway padrão, quando está acessando uma conexão e novamente quando estiver acessando a outra, utilize para isso o comando route:
# route
Assim quando deixar de acessar o servidor windows 2003 terá que executar alguns comando para restaurar o gateway correto. Isso é o que me parece que está ocorrendo aí.

Bom dia dmatrix,

Segue o comando route -n sem a conexão VPN :

Tabela de Roteamento IP do Kernel
Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
10.0.0.0 * 255.0.0.0 U 0 0 0 eth0
default 10.1.1.1 0.0.0.0 UG 0 0 0 eth0


Agora o comando route -n com a conexão VPN levantada :

Tabela de Roteamento IP do Kernel
Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
126.64.150.200. 10.1.1.1 255.255.255.255 UGH 0 0 0 eth0
126.64.150.200. 10.1.1.1 255.255.255.255 UGH 0 0 0 eth0
10.0.0.0 * 255.0.0.0 U 0 0 0 eth0
default * 0.0.0.0 U 0 0 0 ppp0

Neste momento perco a minha navegabilidade na internet.

Fico no aguardo para novas instruções.
Obrigado pela atenção.
Até mais.

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/09/2008, 14:50
Resposta: #4
 
Tentei de tudo para acessar um servidor Windows com PPTP e não tive sucesso ! Como vc conseguiu ? pode dar alguma dica ?

Quanto a navegação, tentei acrecentar a linha " defaultroute " no arquivo /etc/ppp/options.pptp

Entre windows acontece a mesma coisa então eu dasabilito a conexão de VPN de pegar as rotas no servidor.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/09/2008, 17:29
Resposta: #5
 
andrefreire Escreveu:Tentei de tudo para acessar um servidor Windows com PPTP e não tive sucesso ! Como vc conseguiu ? pode dar alguma dica ?

Quanto a navegação, tentei acrecentar a linha " defaultroute " no arquivo /etc/ppp/options.pptp

Entre windows acontece a mesma coisa então eu dasabilito a conexão de VPN de pegar as rotas no servidor.


Boa tarde,

Instalei pelo synaptic o network-manager-pptp, network-manager-pptp-gnome e o pptp-linux. Após a instalação apenas efetuei a configuração da VPN.

Observação : Não possuo firewall e nem proxy ativado.

Espero ter ajudado.

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/09/2008, 17:31
Resposta: #6
 
andrefreire Escreveu:Tentei de tudo para acessar um servidor Windows com PPTP e não tive sucesso ! Como vc conseguiu ? pode dar alguma dica ?

Quanto a navegação, tentei acrecentar a linha " defaultroute " no arquivo /etc/ppp/options.pptp

Entre windows acontece a mesma coisa então eu dasabilito a conexão de VPN de pegar as rotas no servidor.

Boa tarde,

Esqueci de mencionar que já havia efetuado a tentativa de colocar o defaultroute no options.pptp, mas não funcionou.

Se tiver mais alguma dica, agradeço.
Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/09/2008, 17:56
Resposta: #7
 
vou testar aqui e te falo ! inclusive sobre as rotas !
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/09/2008, 23:49
Resposta: #8
 
vadinhodebian Escreveu:
dmatrix Escreveu:não ficou claro a forma que está utilizando para trocar de conexão, assim peço que verifique como está ficando o gateway padrão, quando está acessando uma conexão e novamente quando estiver acessando a outra, utilize para isso o comando route:
# route
Assim quando deixar de acessar o servidor windows 2003 terá que executar alguns comando para restaurar o gateway correto. Isso é o que me parece que está ocorrendo aí.

Bom dia dmatrix,

Segue o comando route -n sem a conexão VPN :

Tabela de Roteamento IP do Kernel
Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
10.0.0.0 * 255.0.0.0 U 0 0 0 eth0
default 10.1.1.1 0.0.0.0 UG 0 0 0 eth0


Agora o comando route -n com a conexão VPN levantada :

Tabela de Roteamento IP do Kernel
Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
126.64.150.200. 10.1.1.1 255.255.255.255 UGH 0 0 0 eth0
126.64.150.200. 10.1.1.1 255.255.255.255 UGH 0 0 0 eth0
10.0.0.0 * 255.0.0.0 U 0 0 0 eth0
default * 0.0.0.0 U 0 0 0 ppp0

Neste momento perco a minha navegabilidade na internet.

Fico no aguardo para novas instruções.
Obrigado pela atenção.
Até mais.
faz um teste aí no terminal digita:
# route add default eth0
# route add default gw 10.1.1.1
e veja se volta a navegação ao normal.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/09/2008, 10:42
Resposta: #9
 
Vc usa Gnome ou KDE ? Inslalei os pacotes que vc mencionou mas não consegui acesso a VPN ! Na verade nem consegui configurar a conexão !
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/09/2008, 21:31
Resposta: #10
 
dmatrix Escreveu:
vadinhodebian Escreveu:
dmatrix Escreveu:não ficou claro a forma que está utilizando para trocar de conexão, assim peço que verifique como está ficando o gateway padrão, quando está acessando uma conexão e novamente quando estiver acessando a outra, utilize para isso o comando route:
# route
Assim quando deixar de acessar o servidor windows 2003 terá que executar alguns comando para restaurar o gateway correto. Isso é o que me parece que está ocorrendo aí.

Bom dia dmatrix,

Segue o comando route -n sem a conexão VPN :

Tabela de Roteamento IP do Kernel
Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
10.0.0.0 * 255.0.0.0 U 0 0 0 eth0
default 10.1.1.1 0.0.0.0 UG 0 0 0 eth0


Agora o comando route -n com a conexão VPN levantada :

Tabela de Roteamento IP do Kernel
Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
126.64.150.200. 10.1.1.1 255.255.255.255 UGH 0 0 0 eth0
126.64.150.200. 10.1.1.1 255.255.255.255 UGH 0 0 0 eth0
10.0.0.0 * 255.0.0.0 U 0 0 0 eth0
default * 0.0.0.0 U 0 0 0 ppp0

Neste momento perco a minha navegabilidade na internet.

Fico no aguardo para novas instruções.
Obrigado pela atenção.
Até mais.
faz um teste aí no terminal digita:
# route add default eth0
# route add default gw 10.1.1.1
e veja se volta a navegação ao normal.

Boa noite dmatrix,

Efetuei os comandos conforme solicitado, porém a navegação não voltou ao normal.

Fico no aguardo para novas instruções.

Obrigado...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/09/2008, 21:36
Resposta: #11
 
andrefreire Escreveu:Vc usa Gnome ou KDE ? Inslalei os pacotes que vc mencionou mas não consegui acesso a VPN ! Na verade nem consegui configurar a conexão !

Eu utilizo o Gnome. Quando eu instalei os pacotes ele habilitou no icone da conexão de rede que fica no ao lado das horas a aba conexões VPN.

Caso o icone não tenha aparecido para você, execute o comando nm-applet para que ele passe a aparecer no painel ao lado das horas.

Espero ter ajudado.

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/09/2008, 22:13
Resposta: #12
 
ok, então tente antes desabilitar os dispositivos:
# ifconfig ppp0 down
# ifconfig eth0 down
# route add default eth0
# route add default gw 10.1.1.1
# ifconfig eth0 up

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/09/2008, 10:03
Resposta: #13
 
Funciona tb com KDE ?

Instalei o Gnome e configurei a VPN pelo icone do network mansger como vc falou, mas agora como disco para o servidor ?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/09/2008, 17:08
Resposta: #14
 
Boa tarde,

Clique com o botão direito no icone do network manager e ele irá te mostrar algumas opções, dentre elas a VPN que vc configurou. Basta apenas clicar na VPN e ele efetuará automaticamente a conexão.

Até mais...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/09/2008, 21:53
Resposta: #15
 
dmatrix Escreveu:ok, então tente antes desabilitar os dispositivos:
# ifconfig ppp0 down
# ifconfig eth0 down
# route add default eth0
# route add default gw 10.1.1.1
# ifconfig eth0 up


Boa noite dmatrix,

Ele até voltou a navegar, mas perdeu a conexão VPN. Eu gostaria navegar e utilizar a conexão VPN simultaneamente.

Fico no aguardo para novas instruções.

Obrigado...

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS