Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Erros após apt-get dist-upgrade
10/09/2008, 10:02
Resposta: #1
Erros após apt-get dist-upgrade
Utilizei o comando # apt-get dist-upgrade após colocar o repositorio para o debian Lenny, baixou e instalou porem ao reiniciar o X não mais iniciava, utilizei #dpkg-reconfigure xserver-xorg e funcionou, porém quando vou utilizar o APT ele retorna as seguintes mensagens:

Código:
# apt-get install -f
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
27 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0B adicionais de espaço em disco serão usados.
Configurando docbook-xml (4.5-5) ...
update-xmlcatalog: error: entity already registered
dpkg: erro processando docbook-xml (--configure):
sub-processo post-installation script retornou estado de saída de erro 1
dpkg: problemas de dependência impedem a configuração de scrollkeeper:
scrollkeeper depende de docbook-xml (>= 4.2-11); porém:
  Pacote docbook-xml não está configurado ainda.
dpkg: erro processando scrollkeeper (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de capplets-data:
capplets-data depende de scrollkeeper; porém:
  Pacote scrollkeeper não está configurado ainda.
dpkg: erro processando capplets-data (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-panel-data:
gnome-panel-data depende de scrollkeeper; porém:
  Pacote scrollkeeper não está configurado ainda.
dpkg: erro processando gnome-panel-data (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-control-center:
gnome-control-center depende de capplets-data (>= 1:2.22); porém:
  Pacote capplets-data não está configurado ainda.
gnome-control-center depende de capplets-data (<< 1:2.23); porém:
  Pacote capplets-data não está configurado ainda.
dpkg: erro processando gnome-control-center (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-panel:
gnome-panel depende de gnome-panel-data (>= 2.20); porém:
  Pacote gnome-panel-data não está configurado ainda.
gnome-panel depende de gnome-panel-data (<< 2.21); porém:
  Pacote gnome-panel-data não está configurado ainda.
gnome-panel depende de gnome-control-center (>= 1:2.8.2-3); porém:
  Pacote gnome-control-center não está configurado ainda.
dpkg: erro processando gnome-panel (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de fast-user-switch-applet:
fast-user-switch-applet depende de gnome-panel; porém:
  Pacote gnome-panel não está configurado ainda.
dpkg: erro processando fast-user-switch-applet (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gedit:
gedit depende de scrollkeeper; porém:
  Pacote scrollkeeper não está configurado ainda.
dpkg: erro processando gedit (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-applets-data:
gnome-applets-data depende de scrollkeeper; porém:
  Pacote scrollkeeper não está configurado ainda.
dpkg: erro processando gnome-applets-data (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-applets:
gnome-applets depende de gnome-applets-data (>= 2.22); porém:
  Pacote gnome-applets-data não está configurado ainda.
gnome-applets depende de gnome-applets-data (<< 2.23); porém:
  Pacote gnome-applets-data não está configurado ainda.
gnome-applets depende de gnome-panel (>= 2.13.4); porém:
  Pacote gnome-panel não está configurado ainda.
dpkg: erro processando gnome-applets (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-session:
gnome-session depende de gnome-control-center (>= 1:2.22); porém:
  Pacote gnome-control-center não está configurado ainda.
dpkg: erro processando gnome-session (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-terminal:
gnome-terminal depende de scrollkeeper; porém:
  Pacote scrollkeeper não está configurado ainda.
dpkg: erro processando gnome-terminal (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de nautilus-data:
nautilus-data depende de scrollkeeper; porém:
  Pacote scrollkeeper não está configurado ainda.
dpkg: erro processando nautilus-data (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de nautilus:
nautilus depende de nautilus-data (>= 2.20); porém:
  Pacote nautilus-data não está configurado ainda.
nautilus depende de nautilus-data (<< 2.21); porém:
  Pacote nautilus-data não está configurado ainda.
nautilus depende de gnome-control-center (>= 2.6); porém:
  Pacote gnome-control-center não está configurado ainda.
dpkg: erro processando nautilus (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de yelp:
yelp depende de docbook-xml (>= 4.1.2); porém:
  Pacote docbook-xml não está configurado ainda.
dpkg: erro processando yelp (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-core:
gnome-core depende de gnome-control-center (>= 1:2.22.2.1); porém:
  Pacote gnome-control-center não está configurado ainda.
gnome-core depende de gedit (>= 2.22.3); porém:
  Pacote gedit não está configurado ainda.
gnome-core depende de gnome-applets (>= 2.22.2); porém:
  Pacote gnome-applets não está configurado ainda.
gnome-core depende de gnome-panel (>= 2.20.3); porém:
  Pacote gnome-panel não está configurado ainda.
gnome-core depende de gnome-session (>= 2.22.2); porém:
  Pacote gnome-session não está configurado ainda.
gnome-core depende de gnome-terminal (>= 2.22.2); porém:
  Pacote gnome-terminal não está configurado ainda.
gnome-core depende de nautilus (>= 2.20.0); porém:
  Pacote nautilus não está configurado ainda.
gnome-core depende de rarian-compat | scrollkeeper; porém:
  Pacote rarian-compat não está instalado.
  Pacote scrollkeeper não está configurado ainda.
gnome-core depende de yelp (>= 2.22.1); porém:
  Pacote yelp não está configurado ainda.
dpkg: erro processando gnome-core (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-system-monitor:
gnome-system-monitor depende de scrollkeeper; porém:
  Pacote scrollkeeper não está configurado ainda.
dpkg: erro processando gnome-system-monitor (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-user-guide:
gnome-user-guide depende de scrollkeeper; porém:
  Pacote scrollkeeper não está configurado ainda.
gnome-user-guide depende de yelp; porém:
  Pacote yelp não está configurado ainda.
dpkg: erro processando gnome-user-guide (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-utils:
gnome-utils depende de scrollkeeper; porém:
  Pacote scrollkeeper não está configurado ainda.
dpkg: erro processando gnome-utils (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gucharmap:
gucharmap depende de scrollkeeper; porém:
  Pacote scrollkeeper não está configurado ainda.
dpkg: erro processando gucharmap (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de nautilus-cd-burner:
nautilus-cd-burner depende de nautilus; porém:
  Pacote nautilus não está configurado ainda.
dpkg: erro processando nautilus-cd-burner (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de zenity:
zenity depende de scrollkeeper; porém:
  Pacote scrollkeeper não está configurado ainda.
dpkg: erro processando zenity (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de gnome-desktop-environment:
gnome-desktop-environment depende de gnome-core (= 1:2.22.2~4); porém:
  Pacote gnome-core não está configurado ainda.
gnome-desktop-environment depende de fast-user-switch-applet (>= 2.22.0); porém:
  Pacote fast-user-switch-applet não está configurado ainda.
gnome-desktop-environment depende de gnome-system-monitor (>= 2.22.2); porém:
  Pacote gnome-system-monitor não está configurado ainda.
gnome-desktop-environment depende de gnome-user-guide (>= 2.22.1); porém:
  Pacote gnome-user-guide não está configurado ainda.
gnome-desktop-environment depende de gnome-utils (>= 2.20.0.1); porém:
  Pacote gnome-utils não está configurado ainda.
gnome-desktop-environment depende de gucharmap (>= 1:2.22.1); porém:
  Pacote gucharmap não está configurado ainda.
gnome-desktop-environment depende de nautilus-cd-burner (>= 2.20.0); porém:
  Pacote nautilus-cd-burner não está configurado ainda.
gnome-desktop-environment depende de zenity (>= 2.22.1); porém:
  Pacote zenity não está configurado ainda.
dpkg: erro processando gnome-desktop-environment (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de synaptic:
synaptic depende de scrollkeeper; porém:
  Pacote scrollkeeper não está configurado ainda.
dpkg: erro processando synaptic (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de software-properties-gtk:
software-properties-gtk depende de synaptic (>= 0.57.8); porém:
  Pacote synaptic não está configurado ainda.
dpkg: erro processando software-properties-gtk (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de update-manager:
update-manager depende de synaptic; porém:
  Pacote synaptic não está configurado ainda.
update-manager depende de software-properties-gtk; porém:
  Pacote software-properties-gtk não está configurado ainda.
dpkg: erro processando update-manager (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas de dependência impedem a configuração de update-notifier:
update-notifier depende de update-manager; porém:
  Pacote update-manager não está configurado ainda.
dpkg: erro processando update-notifier (--configure):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
docbook-xml
scrollkeeper
capplets-data
gnome-panel-data
gnome-control-center
gnome-panel
fast-user-switch-applet
gedit
gnome-applets-data
gnome-applets
gnome-session
gnome-terminal
nautilus-data
nautilus
yelp
gnome-core
gnome-system-monitor
gnome-user-guide
gnome-utils
gucharmap
nautilus-cd-burner
zenity
gnome-desktop-environment
synaptic
software-properties-gtk
update-manager
update-notifier
E: Sub-process /usr/bin/dpkg returned an error code (1)

Alguma sugestão?
Obirgado.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/09/2008, 13:11
Resposta: #2
 
Conssegui resolver usando o aptitude:

# aptitude
localizei o pacote docbook-xml e marquei para remoção.
mandei aplicar.
depois # aptitude dist-upgrade
pra mim resolveu.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS