Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
erro Miro em " building 'miro.libtorrent' extension &qu
02/09/2008, 21:32
Resposta: #1
erro Miro em " building 'miro.libtorrent' extension &qu
Olá!

Estou no Kurumin, instalando o Miro (software open source para TV via internet) e na hora de rodar o run.sh, depois de descompactar o tar, aparece o seguinte erro:

Citar:/usr/bin/ld: cannot find -lboost_filesystem-mt
collect2: ld returned 1 exit status
error: command 'g++' failed with exit status 1

Como eu poderia resolver isto??

Gostaria muitíssimo que nos envolvêssemos aqui, já que o referido software promete. Espero que algum de nós já tenha passado por situação semelhante. Obrigado desde já.
Citar esta mensagem em uma resposta
07/09/2008, 22:43
Resposta: #2
 
esse tarball num tem .configure ?
num tem um readme?
parece que está faltando instalar algum pacote de desenvolvimento.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/09/2008, 03:43
Resposta: #3
 
Opa.

Não, realmente não tem .configure, somente o tal run.sh mesmo.

Pelo jeito este seria o caminho.

E de fato reclama que falta o tal -lboost_filesystem-mt . Agora, a dúvida que fica é o que é este cara?

Tentei instalar o arquivo

libboost-filesystem1.34.1_1.34.1-4ubuntu3_i386.deb

mas reclamou da versão do libc6 ser apenas 2.3.6.ds1-13etch7, e querendo uma 2.3.7 ou maior, então baixei o

libc6_2.7-13_i386.deb

porém na hora de instalá-lo: dpkg: sobre libc6_2.7-13_i386.deb contendo libc6:

Citar: libc6 conflita com tzdata-etch
tzdata oferece tzdata-etch e está instalado.
dpkg: erro processando libc6_2.7-13_i386.deb (--install):
pacotes conflitantes - não instalando libc6
Erros foram encontrados durante processamento de:
libc6_2.7-13_i386.deb.

Então parei por aqui, sem sber até onde já estava pisando.
Citar esta mensagem em uma resposta
19/09/2008, 00:42
Resposta: #4
 
por que não está utilizando o apt-get para instalar os pacotes? e por que está utilizando pacotes do ubuntu se sua distro é kurumin? é provável que os pacotes que tenha que instalar são os dev, libboost-filesystem-dev

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/09/2008, 09:22
Resposta: #5
 
O miro não é encontrado na lista de pacotes apt stable, então habilitei a unstable e alí tinha. Porém ao instalá-lo, reclamou de pacotes quebrados e fui afunilando até o terceiro nível, então parei. Vamos deixar o Miro (projeto em parceria com o Firefox), para quando estiver mais avançado.
Valeu pela dica do pacote ubuntu, realmente, achei que por ser tudo Debian, fosse tudo compatível.
Citar esta mensagem em uma resposta
23/09/2008, 14:36
Resposta: #6
 
Você pode optar por usar a versão testing, além de já ter o miro em seu repositório ele estará estavél em pouco tempo, o que será mudado se for mudado algo será correção de pequenos bugs, isso caso existam.

Rodrigo Braga Prado
Consultor de Informática/Segurança
Especialista em Linux e Software Livre
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/09/2008, 20:58
Resposta: #7
 
E como isso?:
Citar:Você pode optar por usar a versão testing
E isso?:
Citar:além de já ter o miro em seu repositório
Você quer dizer o unstable mesmo?
Citar esta mensagem em uma resposta
24/09/2008, 01:03
Resposta: #8
 
Testing = Lenny
Unstable = Sid

São diferentes, a versão teste atual (Lenny) esta quase virando estável, se houver mudança serão em poucos pacotes, então da pra usar o lenny tranquilo

Rodrigo Braga Prado
Consultor de Informática/Segurança
Especialista em Linux e Software Livre
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/09/2008, 11:00
Resposta: #9
 
Rodrigo,
você recomenda instalar pelo apt-get? Que repositório?
Citar esta mensagem em uma resposta
24/09/2008, 14:14
Resposta: #10
 
O repositório eu sempre prefiro os oficiais, e para o lenny adicione isso no teu sources.list

##########################
# Debian Lenny - Testing #
###########################
deb http://ftp.br.debian.org/debian/ lenny main non-free contrib
deb-src http://ftp.br.debian.org/debian/ lenny main non-free contrib

deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free


Depois, rode o apt-get update e apt-get -f install ou apt-get install miro

Assim que instalar edite o arquivo novamente e comente esses linhas se você não quer migrar para o lenny.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/09/2008, 21:23
Resposta: #11
 
De grande valia sua dica.
Grato.
Porém, ainda agora fui instalá-lo, após update do apt-get com os repositórios lenny e:
Citar:Os pacotes a seguir têm dependências desencontradas:
miro: Depende: libxine1-plugins (>= 1.1.12) mas não vai ser instalado
E: Pacotes quebrados
Realmente, vou arquivar o miro por enquanto.
Citar esta mensagem em uma resposta
27/09/2008, 15:43
Resposta: #12
 
adicione essa linha no seu sources.list:
deb http://www.debian-multimedia.org lenny main
e novamente tente:
# aptitude update
# aptitude install < pacote >

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS