Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Squid LibCurl SquidClamAv
06/08/2008, 08:33
Resposta: #1
Squid LibCurl SquidClamAv
eu uso squid squidclamav e clamav

algumas vezes quando instalo o squid clamav a licurl dá esse problema

CURLOPT_ERRORBUFFER: couldn't connect to host

e quando dá esse problema só refazendo o servidor inteiro para e rezando um pco quando for fazre pela segunda vez, rsrrs.

achei isso na internet mas ainda não soube onde aplicar:

In case of an error code (result != CURLE_OK), I did find an error
> description in the buffer I passed with the CURLOPT_ERRORBUFFER with
> previous versions (7.12.0 and earlier) of cURL. In the new version, this is
> not always the case. If a try a connection to an invalid host name, I get a
> very precise description, but if I try to connect to a host/port where no
> server ist running, the buffer is just empty in the new version.


Thanks for this description! This bug was probably introduced when we rewrote
the whole name resolve code for 7.12.1 and thus the connect loop was unified
and changed...


This patch seems to fix this particular flaw in my end:


diff -u -r1.114 connect.c
--- lib/connect.c 4 Aug 2004 12:38:01 -0000 1.114
+++ lib/connect.c 19 Sep 2004 14:27:22 -0000
@@ -745,6 +745,7 @@
if (sockfd == CURL_SOCKET_BAD) {
/* no good connect was made */
*sockconn = CURL_SOCKET_BAD;
+ failf(data, "couldn't connect to host");
return CURLE_COULDNT_CONNECT;
}


Alguém sabe como corrigir este problema? ou onde aplicar este patch?
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/08/2008, 23:31
Resposta: #2
 
Por favor, não poste tópicos com letras maiúsculas. Sorrisão
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS