Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Cacti: Erro no Poller.php
18/07/2008, 10:33
Resposta: #1
Cacti: Erro no Poller.php
Pessoal, instalei o cacti aqui no Lenny, mas o mesmo da um erro na hora de gerar os relatorios. o Arquivo responsavel por isso é o poller.php e o erro é o seguinte:

Código:
Monitor:/usr/share/cacti/site# php poller.php
PHP Warning:  mime_magic: type search/400       \\input         text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400       \\section       text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400       \\setlength     text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400       \\documentstyle text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400       \\chapter       text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type search/400       \\documentclass text/x-tex invalid in Unknown on line 0
PHP Warning:  mime_magic: type regex            [Cc]onstant[[:space:]]+[Ss]tory text/x-inform invalid in Unknown on line 0

Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /usr/share/php/adodb/adodb.inc.php on line 336
Monitor:/usr/share/cacti/site#

Pesquisando no Google, achei o link no proprio forum do cacti, mas nao achei legal a resposta deles dizendo que é melhor instalar o cacti pelo pacote do site, e que o suporte é complicado por se tratar de um pacote .deb... não gostei!

O link é:

http://forums.cacti.net/about27554.html

Exatamente o mesmo problema acontece comigo.
Espero a ajuda de todos.

[Imagem: debianga8.png]
[Imagem: amarok2yd9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/07/2008, 12:19
Resposta: #2
 
como instalou o cacti? pelo apt-get?
ou pelo tarball? se foi pelo tarball qual foi o motivo?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
26/07/2008, 17:58
Resposta: #3
 
Opa, desculpe a demora, mas como eu disse a na mensagem acima, foi instalado via apt-get...
Tanto que me refiro que fiquei chateado por eles nao darem suporte so por que nao foi instalado pelo tarball

[Imagem: debianga8.png]
[Imagem: amarok2yd9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/07/2008, 20:47
Resposta: #4
 
analisando as mensagens de erro, parece que está faltando instalar algum modulo do php

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/07/2008, 10:06
Resposta: #5
 
dmatrix;

Uma vez eu instalei o cacti com um passo-a-passo exatamente como fiz desta vez, o lance é que acora eu queria usar o php5 e antes foi com php4, ja criei uma maquina virtual, toda atualizada e instalei da mesma forma, sendo que com o php4 e funcionou.. será que o cacti ainda nao foi portado pra php5 (no debian) ??
Acho isso estranho...

[Imagem: debianga8.png]
[Imagem: amarok2yd9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/07/2008, 20:15
Resposta: #6
 
me parece que no php5 mudou a forma como os modulo são carregados, talvez esteja faltando habilitá-los.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/08/2008, 10:40
Resposta: #7
 
Código:
Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /usr/share/php/adodb/adodb.inc.php on line 336


Pelo fim da mensagem é possivel ver que o erro está no arquivo adodb.inc.php mais precisamente na linha 336.

Ele diz que tem erro de sintaxe, que esta faltando um "}" ou algum valor sei lá.. T_VAR etc.... eu nao manjo de php! =/

Mais um motivo pra estudar! uaheuaheuhaueh...


Eu ja fui nesse arquivo na linha que ele diz, mas nao vejo nada de anormal nao... oO

[Imagem: debianga8.png]
[Imagem: amarok2yd9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/08/2008, 13:49
Resposta: #8
 
posta essa linha então. mas acho que as linhas de comentários não fazem parte da contagem da linha do erro. então o erro pode estar nas linhas mais a frente.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS