Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Samba Lento
08/07/2008, 00:23
Resposta: #1
Samba Lento
Olá amigos!
Estou com um probleminha em minha rede meu samba ta muito lento, tenho uns sitemas que rodam nele com banco de dados postgresql em outro server tudo localmente tenho também sistemas em dos e diretorios de arquivos ja olhei ele e alterei umas confs mas não adiantou segue lento tenho em minha rede clientes WinXP e Win98.

Segue meu samba

# SERVIDOR SAMBA PDC - DEBIAN GNU/LINUX

# Global parameters
[global]

# Nome do servidor na rede
netbios name = servidor

# Grupo de trabalho ou Domínio,
workgroup = dominio

# A descrição do servidor para a rede
server string = Servidor Samba versão %v

# Resolução de nomes de máquinas no samba
name resolve order = lmhosts host wins bcast

# Usuário Administrador de Domínio.
admin users = administrador

# IPs ou hostnames dos micros da rede
hosts allow = 10.0.0. 127.

# Restringindo o acesso por interface de rede
interfaces = loopback eth0
bind interfaces only = Yes
invalid users = root

# senhas criptografadas
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
username map = /etc/samba/smbusers

# senhas em branco
null passwords = no
log level = 1

# arquivo de log do samba
log file = /var/log/samba/samba-log-%m

# tamanho máximo do arquivo de log em KBs
max log size = 5000Kb
debug pid = no
debug timestamp = yes

# Nível de detalhes do arquivo log
log level = 2
debug level = 2
lock directory = no

# Corrige acentuação dos arquivos compartilhados
unix charset = iso8859-1
display charset = cp850
preserve case = yes
# client code page = 850
# valid chars = á:Á é:É í:Í ó:Ó ú:Ú â:Â ê:Ê ô:Ô ã:Ã õ:Õ à:À ò:Ò

# Criando conta de maquina automaticamente
add machine script = useradd -g santacasa -c servidor -s /bin/false -d /dev/null %u

# Profile
# logon script = netlogon.bat
# logon path = \\%L\profiles\%U
# logon drive = H:
# logon home = \\%L\%U\.profiles

# O PDC é um servidor de data e hora?
time server = yes

# PDC servidor principal
preferred master = yes
domain master = yes
os level = 255

# O Servidor aceitará Logon dos usuários nas estações
domain logons = yes
local master = yes

# Habilita senhas criptografadas
encrypt passwords = true
wins support = yes

# Nivel de acesso
security = user

# Impedir que usuários salvem arquivos com estas extensoes
# veto files = /*.pif/*.bat/*.avi/*.mp3/*.wma/*.wmv/*.wmf/*.mpeg/*.mp4/*.dvx/*.msi/*.asf/*.wav/*.wave/*.{*}/

[homes]
comment = Home Directories
read only = No
browseable = No

Já ia esquecendo meu servidor samba ta no debian etch.
Abraços
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/07/2008, 13:29
Resposta: #2
 
Olá leociroz,

Tente adicionar a seguinte linha dentro da parte [globals]:

Código:
socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192

Depois disso reinicie o samba.

Código:
/etc/init.d/samba restart

Geralmente quando faço essa configuração a velocidade do samba aumenta muito.

Se mesmo assim não resolver, me avise.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/07/2008, 00:29
Resposta: #3
 
Olá Fernando!

Obrigado por comentar o post fiz uma nova instalação no meu serv e também mudei a placa de rede pois pesquisei na internet e vi que uma das causas possiveis poderia ser minha placa de rede fiz a conf que me passou na instalação também coloquei as seguintes:
log level = 1 # Default is 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
read raw = yes # Default
write raw = yes # Default
oplocks = no # Default
max xmit = 65535 # Default
dead time = 15 # Default is 0
getwd cache = yes

Notei uma enorme mudança quando fiz a nova instalação e apliquei estas configurações só que ainda não coloquei ele na rede apenas testei com minha máquina tive que por o serv anterior que funciona perfeitamente mas sem segurança nenhuma mas os sistemas rodam bem nele acho que vou deixar os dois um pra sistema e o outro para os arquivos mas ainda farei uns testes.

Abraços
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/07/2008, 19:17
Resposta: #4
 
leociroz

As plaicações que utilizam o banco de dados Postgresql estão lentas? Se for tentemudar os valores do shared_buffers, e max_connections no postgresql.conf...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS