Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Problema no Sarg com o Cron
26/06/2008, 16:26
Resposta: #1
Problema no Sarg com o Cron
Boa tarde Pessoal.

Estou com um problema há alguns dias.
O sarg sempre funcionou a partir do cron, mas desde o dia 19 desse mês ele dá um erro, 141, e não completa a geração do relatório.

Se eu executar manualmente ele funciona.

A única mudança que fiz neste dia foi remover os pacotes bsd-mailx, mailx e procmail. Porém, depois de recolocá-los continua sem funcionar.

Penso que pode haver alguma restrição no shell executado pelo cron.

Alguém pode dar uma luz?

Abraço.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/06/2008, 11:24
Resposta: #2
 
Olá pessoal.

Descobri o problema. Eu sempre usei as opções -z e -x do sarg, porém, do dia 19 pra cá ele resolveu implicar com elas.

Ocorre que o cron não gosta muito de processos imprimindo coisas a partir dele para a tela e essas opções fazem justamente isso....

O problema é que antes funcionava e parou de funcionar........... se eu não olhasse o fonte do sarg pra ver que para uma opção ele imprimia como se fosse erro (stderr) e para outra a saída normal (stdout), dificilmente eu desconfiaria delas por conta do histórico das mesmas comigo....

Abraço.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS