Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Problema com módulo printer
03/08/2008, 13:10
Resposta: #61
 
a máquina não é a mesma que tem o windows? se é então não deveria ser bios, além disso vc disse que o pendrive funciona, o problema me parece que seja algum detecção do sinal da impressora que não esteja legal, se vc tivesse como testar com outra impressora usb de outro modelo, acho que veria que o problema não se trata da porta.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/08/2008, 13:41
Resposta: #62
 
dá uma verificada se o seguinte pacote está instalado:
# aptitude install libprinterconf0c2a
se não estava tente fazer os testes de reconectar a impressora pra saber se ela é detectada.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/08/2008, 19:34
Resposta: #63
 
dmatrix Escreveu:dá uma verificada se o seguinte pacote está instalado:
# aptitude install libprinterconf0c2a
se não estava tente fazer os testes de reconectar a impressora pra saber se ela é detectada.

Olá dmatrix,

Esta biblioteca não estava instalada, efetuei a instalação mas nada adiantou, ou seja, a impressora continua não funcionando.

Farei o seguinte, estarei comprando um outro cabo para efetuar um teste, para verificar se o problema e no cabo.

Muito obrigado por enquanto, quando eu efetuar os testes com o novo cabo eu te aviso.

Obrigado...
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/08/2008, 19:56
Resposta: #64
 
vadinhodebian Escreveu:
dmatrix Escreveu:dá uma verificada se o seguinte pacote está instalado:
# aptitude install libprinterconf0c2a
se não estava tente fazer os testes de reconectar a impressora pra saber se ela é detectada.

Olá dmatrix,

Esta biblioteca não estava instalada, efetuei a instalação mas nada adiantou, ou seja, a impressora continua não funcionando.

Farei o seguinte, estarei comprando um outro cabo para efetuar um teste, para verificar se o problema e no cabo.

Muito obrigado por enquanto, quando eu efetuar os testes com o novo cabo eu te aviso.

Obrigado...


Olá dmatrix,

Comprei o cabo e efetuei os testes e a impressora continua na mesma, ou seja, a porta USB da impressora ainda não esta sendo reconhecida pelo Debian.

Aguardo contato para efetuarmos novas tentativas.

Obrigado...
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/08/2008, 21:16
Resposta: #65
 
vou ver quais opções existem para se aplicar na linha do kernel e alterando o modo do usbcore funcionar. já tentou inicializar a maquina configurado na linha do kernel acpi=off ?
# mcedit /boot/grub/menu.lst

...
...
root (hd0,1)
kernel /boot/vmlinuz-2.6.18-5-amd64 root=/dev/sda2 ro apci=off

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/08/2008, 08:57
Resposta: #66
 
dmatrix Escreveu:vou ver quais opções existem para se aplicar na linha do kernel e alterando o modo do usbcore funcionar. já tentou inicializar a maquina configurado na linha do kernel acpi=off ?
# mcedit /boot/grub/menu.lst

...
...
root (hd0,1)
kernel /boot/vmlinuz-2.6.18-5-amd64 root=/dev/sda2 ro apci=off

Olá dmatrix,

Alterei conforme solicitado, reiniciei o computador mas nada adiantou. O problema e que não reconhece nem a porta USB da impressora.

Fico no aguardo para novas tentativas.
Obrigado ..
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/08/2008, 15:40
Resposta: #67
 
dá uma olhada se no seu fstab ( /etc/fstab ) se possue essas linhas:
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs devmode=0666 0 0
sysfs /sys sysfs defaults 0 0

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/08/2008, 20:41
Resposta: #68
 
dmatrix Escreveu:dá uma olhada se no seu fstab ( /etc/fstab ) se possue essas linhas:
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs devmode=0666 0 0
sysfs /sys sysfs defaults 0 0

Olá dmatrix,

O meu fstab possui as seguintes linhas :

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hdb2 / ext3 errors=remount-ro 0 1
/dev/hdb5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/hdb1 /mnt/porta_arquivos ntfs-3g umask=000
/dev/hda1 /mnt/win2003 ntfs-3g umask=000

Devo acrescentar as linhas que você mencionou?

Fico no aguardo.
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/08/2008, 10:39
Resposta: #69
 
Olá dmatrix,

Ontém a noite meu kernel foi atualizado para o 2.6.26-1-amd64.

Não sei se muda alguma coisa...

Fico no aguardo.

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/08/2008, 11:09
Resposta: #70
 
é pode ser mas andei pesquisando e se não estiver enganado o suporte no kernel até existe e está certo, o problema é no usb, ou seja a impressora não é reconhecida, ainda, pelo usb, vc pode verificar isso baixando uma nova lista de ids de dispositivos usb com o comando update-usbids e depois verificar a lista atualmente reconhecida pelo usb:
# update-usbids
# cat /var/lib/usbutils/usb.ids | grep -i lexmark

aqui vc vai ver que o seu modelo não está presente, portanto ao conectar o cabo usb ele não será reconhecido pelo udev corretamente, precisamos saber se é possível adiciona-la nesta lista ou então fazer com que ela seja reconhecida como um dos modelos que aparece na lista, daí sim acredito que possa funcionar. pode até ser que adicionando manualmente nesta lista seja a solução. Tipo assim:
Código:
043d  Lexmark International, Inc.
    007c  Lexmark X1110/X1130/X1140/X1150/X1170/X1180/X1185
    002c  Lexmark X125
    003d  Lexmark X83

talvez isso mude um pouco a saga até aqui.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/08/2008, 14:26
Resposta: #71
 
vadinhodebian Escreveu:
dmatrix Escreveu:dá uma olhada se no seu fstab ( /etc/fstab ) se possue essas linhas:
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs devmode=0666 0 0
sysfs /sys sysfs defaults 0 0

Olá dmatrix,

O meu fstab possui as seguintes linhas :

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hdb2 / ext3 errors=remount-ro 0 1
/dev/hdb5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/hdb1 /mnt/porta_arquivos ntfs-3g umask=000
/dev/hda1 /mnt/win2003 ntfs-3g umask=000

Devo acrescentar as linhas que você mencionou?

Fico no aguardo.

adicione essa linha que falta e é essencial no seu fstab:
Código:
sysfs      /sys     sysfs     defaults        0    0

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/08/2008, 17:10
Resposta: #72
 
Olá dmatrix,

Coloquei a linha no fstab como solicitado.

Fui consultar o arquivo usb.ids e constatei que a impressora encontra-se na lista, porém de forma diferente.

Efetuei o comando "cat /var/lib/usbutils/usb.ids | grep X83"
e obtive o resultado :

003d X83 Scan/Print/Copy
0839 CX8300/CX8400/DX8400.

Fico no aguardo para novas tentativas para encerrarmos a saga da Lexmark X83.

Desde já agradeço pela atenção desprendida.

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/08/2008, 21:02
Resposta: #73
 
ainda existe aquela regra de criar o dispositivo no udev?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/08/2008, 21:21
Resposta: #74
 
dmatrix Escreveu:ainda existe aquela regra de criar o dispositivo no udev?

Olá dmatrix,

Ainda existe aquela regra no udev e o dispositivo lexmark_x83 está criado, localizando-se em "/dev/lexmark_x83".

Fico no aguardo.

A melhor forma de aprendizado e aquela em que um grupo de pessoas, tentam ajudar umas as outras.
________________
Marcelo R. Silva
http://mrs-linux.blogspot.com
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
31/08/2008, 13:41
Resposta: #75
 
ok, dê os seguintes comandos:
# echo 1 > /sys/module/printk/parameters/printk_time
# modprobe -rv ehci_hcd
inseria o cabo da impressora usb verifique as mensagens que saem no syslog e poste aqui:
# tail /var/log/syslog

verifique tb se o seguinte modulo está carregado:
# lsmod | grep ohci_hcd




* a alteração acima consiste em desativar o suporte ao usb 2.0 e deixar somente o usb 1.1.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS