Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Squid com autenticação !!!!
08/06/2008, 22:59
Resposta: #1
Squid com autenticação !!!!
Olá galera !!!
É o seguinte configurei o squid com autenticação de usuario
esta funcionando legal mais tem um detalhe que esta tirando minha paciência por isso resolvi postar aqui !!!

O caso é esse !! qualquer texto que o usuario pegue da internet e copiando e colando no word pede login e senha do usuario novamente !!!

#SITES BLOQUEADOS
acl bloqueados url_regex -i "/etc/squid/sitesbloq/bloqueados
acl download url_regex -i "/etc/squid/download/download
acl malware_blok_list url_regex -i "/etc/squid/malware_blok_list.txt"

#BLOQUEANDO ACESSOS
http_access deny bloqueados
http_access deny download
http_access deny malware_blok_list

#IDENTIFICACAO DO USUARIO
auth_param basic program /usr/lib/squid/ncsa_auth /etc/squid/squid_passwd
acl login proxy_auth REQUIRED
http_access allow login
auth_param basic realm rede caro usuario Digite seu login e senha

#PORTA DE ACESSO
cache_mgr suportexxxxx
http_port 3128
visible_hostname xxxxx
cache_mem 700 MB
maximum_object_size_in_memory 64 KB
maximum_object_size 512 MB
minimum_object_size 0 KB
reload_into_ims on
dns_nameservers 192.168.1.1

#CAMINHOS DO LOG'S
cache_swap_low 90
cache_swap_high 95
cache_dir ufs /var/spool/squid 700 16 256
cache_access_log /var/log/squid/access.log
cache_log /var/log/squid/cache.log
cache_store_log /var/log/squid/store.log

refresh_pattern ^ftp: 15 20% 2280
refresh_pattern ^gopher: 15 0% 2280
refresh_pattern . 15 20% 2280

acl all src 0.0.0.0/0.0.0.0
http_access allow all
acl manager proto cache object
acl meios.org src 192.168.1.1/255.255.255.255
acl SSL_ports port 443 563
acl safe_ports port 80 # http
acl safe_ports port 22 # SSH
acl safe_ports port 25 # SMTP
acl safe_ports port 21 # ftp
acl safe_ports port 443 563 # https, snews
acl safe_ports port 70 # gopher
acl safe_ports port 210 # wais
acl safe_ports port 280 # http-mgmt
acl safe_ports port 488 # gss-http
acl safe_ports port 591 # filemaker
acl safe_ports port 777 # multiling http
acl safe_ports port 901 # swat
acl safe_ports port 1025-65535 # portas-altas
acl purge method PURGE
acl CONNECT method CONNECT

http_access allow manager xxxxxx
http_access deny manager
http_access allow purge xxxxxxx
http_access deny purge
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports

#BLOQUEANDO OUTROS ACESSOS
http_access deny all
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/06/2008, 10:14
Resposta: #2
 
Mas esse squid está instalado em um servidor Windows?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/06/2008, 14:36
Resposta: #3
 
Experimente copiar e colar "apenas como texto". O Word deve estar tentando abrir uma conexão para baixar as imagens... deve ser isso.

O movimento está parado!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/06/2008, 20:49
Resposta: #4
 
estou usando o debian etch !!!
fica peidindo senha seja texto ou imagem !!!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/06/2008, 21:08
Resposta: #5
 
esse seu tópico é o mesmo deste http://www.forumdebian.com.br/topico-65 ... e9508ec674

cujo problema utilizando o colar especial resolve.
Bom iria pedir pra vc testar o broffice o qual possue uma opção de configurar o proxy nas opções dele, acredito que isso iria resolver pois o proxy no seu caso está pegando só no internet explorer certo? Agora não tenho o pacote office aqui pra saber se existe a mesma opção de configurar proxy que existe no broffice.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/06/2008, 21:22
Resposta: #6
 
outra opção é adicionar a linha para reforcar o tempo que autenticação continuará válida apesar que no man dizer que o padrão é 2 horas.

...
auth_param basic realm .....

auth_param basic credentialsttl 2 hours

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/06/2008, 20:57
Resposta: #7
 
Caro Colega
Dmatrix

Já tentei com o office 2007 mesmo assim continua pedindo senha quando copia e cola no word !!
É funcionar indo em editar colar especial !!
Mas tem um porém na empresa que trabalho muitos usuarios tem dificuldade para se adaptar !!!
Tem que ser no CTRL C + CTRL V !!!
esse é o problema !!!

Também já testei com essa configuração que vc falou !!
continua no mesmo !!!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/06/2008, 21:50
Resposta: #8
 
vc já tentou usar essa configuração:
authenticate_cache_garbage_interval 8 hours

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
12/06/2008, 18:58
Resposta: #9
 
Dmatrix
vou testar essa acl e posto aqui !!!
antes de qual acl eu posso colocar ????
hoje fiz alguns testes copiei e colei no bloco de notas e não pediu senha !!!!
Estou baixando a atualização do office 2003
e bem provavel que seja o office...outras dicas são bem vindas !!!!!!!agradeço antecipadamente
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/06/2008, 11:26
Resposta: #10
 
eles não gostam do broffice 2.x aí? testa tb com ele para sabermos se isso ocorre tb nesse. O office que está utilizando é o 9.0?
esse acl é colocada logo após a que passei acima de credencial.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/06/2008, 13:22
Resposta: #11
 
Dmatrix !!!
estou usando o office 2003 !!!! inclusive atualizei para testar mas continua na mesma !!!!!!!! pedindo senha quando copia e cola

detalhe no bloco de nota e no word pad não pedem senha !!!!

se eu colocar broffice !! vai ser uma loucura para os usuarios !!!
mas vou testar com o broffice !!!!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/06/2008, 18:00
Resposta: #12
 
Entenda, no bloco de notas e no word pad não pede senha pq ele simplesmente copia e "cola especial" pq só traz o texto, como no word ele traz as imagens e todo o restante ele necessariamente precisa acessar a página para baixar o conteúdo...

O movimento está parado!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/06/2008, 11:27
Resposta: #13
 
speedracing Escreveu:Dmatrix !!!
estou usando o office 2003 !!!! inclusive atualizei para testar mas continua na mesma !!!!!!!! pedindo senha quando copia e cola

detalhe no bloco de nota e no word pad não pedem senha !!!!

se eu colocar broffice !! vai ser uma loucura para os usuarios !!!
mas vou testar com o broffice !!!!

me parece que a forma como está configurado o seu squid.conf é que está causando isso.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/06/2008, 15:52
Resposta: #14
 
Caro Colega
Dmatrix

Instalei o Broffice em uma estação cliente !!!
resultado foi que copie e colei varias vezes texto e imagens da internet e NÃO pediu senha e login de usuario portanto creio eu que e o office 2003 !!!!
e agora ?????
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/06/2008, 18:37
Resposta: #15
 
boa! é o broffice 2.4? bom a menos que alguem diga onde está o problema no squid.conf, o msoffice deveria funcionar da mesma forma, afinal vc não configurou nada no broffice sobre o proxy, certo? Como está fazendo essa instalação do msoffice? via rede ou cdrom? Está instalando ele completo? Talvez algum recurso adicional esteja sendo instalado no msoffice que esteja requisitando uma autenticação extra, tente instala-lo num modo mais enxuto e tb faça a instalação no modo completo ( caso esteja instalando no modo padrão). Esse msoffice possue o Outlook ou outro programa que não seja Word, excel, Powerpoint e access? Teste tb uma instalação simples com somente esses.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS