Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Problemas com Acesso web SVN e PROFTPD
06/06/2008, 18:42
Resposta: #1
Problemas com Acesso web SVN e PROFTPD
Fala ai pessoal

Estou usando como firewall na ponta da minha rede uma máquina com Debian + iptables. Essa máquina tem 2 pls de rede, uma para internet e outra para rede interna.

Coloquei dois servicos: o proftpd na propria maquina do firewall e dentro da minha rede tenho um servidor com SVN
quando instalei esses servicos eles fucionaram via web mas por algum motivo agora eles nao funcionam... suspeito que seja alguma alteração que fiz no iptables porém nao consigo ver nenhuma regra que possa estar bloqueando isso. Se puderem me ajudar.

A mensagem que esta aparecendo no SVN é:

Error * Can't connect to host 'xxx.xxx.xxx.xxx': A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
obs: para acessar o svn uso tortoise

A mensagem no ie do ftp é:

Windows cannot access this folder. Make sure you typed the file name correctly and that you have permission to access the folder.
Details:
The FTP session was terminated




Minhas regras do iptables sao:

#limpando tabelas
iptables -F
iptables -X
iptables -t nat -F
iptables -t nat -X


#liberando acesso interno da rede
iptables -A INPUT -p tcp --syn -s 192.168.0.0/255.255.255.0 -j ACCEPT
iptables -A OUTPUT -p tcp --syn -s 192.168.0.0/255.255.255.0 -j ACCEPT
iptables -A FORWARD -p tcp --syn -s 192.168.0.0/255.255.255.0 -j ACCEPT


#compartilhando a web na rede interna
iptables -t nat -A POSTROUTING -s 192.168.0.0/255.255.255.0 -o eth0 -j MASQUERADE &&
echo 1 > /proc/sys/net/ipv4/ip_forward


#liberando ftp default port
iptables -A INPUT -p tcp --dport 21 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 21 -j ACCEPT


#liberando svn default port
iptables -t nat -A PREROUTING -p tcp -d xxx.xxx.xxx.xxx --dport 3690 -j DNAT --to 192.168.0.2:3690
iptables -A FORWARD -i eth0 -p tcp --dport 3690 -j LOG --log-level 1 --log-prefix "3690 svn"


#liberando vpn
iptables -A INPUT -p tcp --dport 10000 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 10000 -j ACCEPT

iptables -A INPUT -p tcp --dport 500 -j ACCEPT
iptables -A OUTPUT -p tcp --sport 500 -j ACCEPT

iptables -A INPUT -p udp --dport 10000 -j ACCEPT
iptables -A OUTPUT -p udp --sport 10000 -j ACCEPT

iptables -A INPUT -p udp --dport 500 -j ACCEPT
iptables -A OUTPUT -p udp --sport 500 -j ACCEPT


#ligando protecao para SYN Flood
echo 1 > /proc/sys/net/ipv4/tcp_syncookies


#Anulando as respostas ICMP
#echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_all


# Protecao contra port scanners ocultos
iptables -A INPUT -p tcp --tcp-flags SYN,ACK,FIN,RST RST -m limit --limit 1/s -j ACCEPT


# Bloqueando tracertroute
iptables -A INPUT -p udp -s 0/0 -i eth0 --dport 33435:33525 -j DROP


#Protecoes contra ataques
iptables -A INPUT -m state --state INVALID -j DROP



echo "Iptables Reloaded Successfully."

exit 0
##############

socorro hehehe
qualquer ajudinha é válida^^
valeu!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
07/06/2008, 00:22
Resposta: #2
Re: Problemas com Acesso web SVN e PROFTPD
pingPong Escreveu:#liberando svn default port
iptables -t nat -A PREROUTING -p tcp -d xxx.xxx.xxx.xxx --dport 3690 -j DNAT --to 192.168.0.2:3690
iptables -A FORWARD -i eth0 -p tcp --dport 3690 -j LOG --log-level 1 --log-prefix "3690 svn"

não tenho certeza, mas parece que o problema está na gravação destas logs. Tente comentar essa linha pra saber se muda algo.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/06/2008, 02:03
Resposta: #3
 
Tópico movido para sala de Redes para melhor organização do fórum.

[Imagem: debianuseruserbarsp1.png]
[Imagem: gnomeuserqj9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/06/2008, 13:58
Resposta: #4
 
antes de colocar essa linha de log nao tava funcionando .... eu coloquei pra ver se gerava um log e eu entendia o motivo... mas nao consegui gerar nada de log
=\
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/06/2008, 14:16
Resposta: #5
 
hum...faça um teste comentando temporariamente as linhas que tem DROP

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/06/2008, 11:01
Resposta: #6
 
farei agora,
mas eu segui a ideia que o iptables interpreta as regras na ordem
por isso nao achei que pudesse ter esse problema mas
vou fazer e digo o que aconteceu!
valeu pela boa vontade =)
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/06/2008, 12:07
Resposta: #7
 
nada =\
comentei todos os drops e nada
to ficando desesperado já
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/06/2008, 13:17
Resposta: #8
 
to achando ja que nao deve ser problema do iptables argh
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/06/2008, 14:50
Resposta: #9
 
será que tem algo a ver com o ipv6? dá uma olhada se esse modulo do ipv6 está sendo carregado.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/06/2008, 15:00
Resposta: #10
 
onde ipv6?
no proftpd?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/06/2008, 15:02
Resposta: #11
 
onde eu ponho ele pra carregar?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/06/2008, 22:09
Resposta: #12
 
não...eu quiz dizer que talvez fez alguma atualização e o modulo ipv6 está sendo carregado junto com os protocolos da rede, veja se ele está presente com o lsmod:
# lsmod | grep ipv6

estou chutando que talvez antes quando estava funcionando aí ele não estivesse sendo carregado, então vc poderia testar colocando ele na blacklist pra não carregar e testar as coisas se volta ao normal.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/06/2008, 11:47
Resposta: #13
 
entendi
dmatrix, fiz o grep e apareceu la
ipv6 226272 8

pra desativar eh so ir em:

/etc/modprobe.d/aliases
e colocar off como ta abaixo?

alias net-pf-10 ipv6 off
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/06/2008, 16:36
Resposta: #14
 
tb desabilita deste modo mas prefiro joga-lo no /etc/modprobe.d/blacklist que aí nem o modulo carrega mais.

ah, dá um verificada nos ips de dns que estão configurados, isso pode ser dns que está causando ( /etc/resolv.conf )

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
13/06/2008, 13:02
Resposta: #15
 
o que eu digito no
etc/modprobe.d/blacklist
blacklist ipv6 ?

e no /etc/resolv.conf
ta la o meu dns da rede + 2 dns da internet

192.168.0.2
200.x.x.x
200.x.x.x
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS