Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Clique do touchpad não funciona (RESOLVIDO)
14/12/2010, 15:58
Resposta: #1
Clique do touchpad não funciona (RESOLVIDO)
Olá todos,
O TouchPad não funciona para "clicar" com o toque do dedo (um ou dois toques). Funciona para as outras funções mover o cursor e arrastar. Uma curiosidade é que o clique funciona na tela do login gráfico (GDM3). Na área de login só começou funcionar depois que adicionei a "Section "InputClass" Identifier "Touchpad" ..." no xorg.conf, conforme é indicado em http://wiki.debian.org/SynapticsTouchpad. Não sei se fiz tudo certo, porque na minha área de trabalho o "clique" continua não funcionando.

Já li o tópico viewtopic.php?f=30&t=10945#p53904, e experimentei também uma alteração no xorg.conf seguindo a dica de viewtopic.php?p=35594#p35594, mas não resolvi o problema.

Estou utilizando o Squeeze
[email protected]:~$ uname -a
Linux note 2.6.32-5-686 #1 SMP Thu Nov 25 18:43:34 UTC 2010 i686 GNU/Linux
[email protected]:~$

Obrigado por toda ajuda.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/12/2010, 16:10
Resposta: #2
Re: Clique do touchpad não funciona
posta o conteúdo do xorg.conf atual para gente analisar e ver aonde está o problema.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/12/2010, 07:37
Resposta: #3
Re: Clique do touchpad não funciona
Desculpe a demora.
Aí está o meu /etc/X11/xorg.conf completo:
Código:
# Xorg.conf universal

    Section "ServerFlags"
            # Essa opção deixa o xorg abrir mesmo que se tenha um erro no
            # mouse.
       Option "AllowMouseOpenFail" "true"
    EndSection

    Section "Files"
       FontPath   "/usr/share/fonts/X11/misc"
       FontPath   "/usr/X11R6/lib/X11/fonts/misc"
       FontPath   "/usr/share/fonts/X11/cyrillic"
       FontPath   "/usr/X11R6/lib/X11/fonts/cyrillic"
       FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
       FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
       FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
       FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
       FontPath   "/usr/share/fonts/X11/Type1"
       FontPath   "/usr/X11R6/lib/X11/fonts/Type1"
       FontPath   "/usr/share/fonts/X11/100dpi"
       FontPath   "/usr/X11R6/lib/X11/fonts/100dpi"
       FontPath   "/usr/share/fonts/X11/75dpi"
       FontPath   "/usr/X11R6/lib/X11/fonts/75dpi"
       # path to defoma fonts
       FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
            Load "ddc"
            Load "dbe"
            Load "extmod"
            Load "bitmap"
            Load "type1"
            Load "speedo"
            Load "freetype"
            Load "record"    
    EndSection

    #
    # Nessa parte temos dois tipos de teclado, o ABNT2 e o Americano
    # Internacional, deixamos o ABNT2 por padrão, caso você use o
    # Americano Internacional descomente as linhas dele
    # (é só remover o # no início de cada linha)
    # e remover as linhas do ABNT2.
    #

    ###### Teclado ABNT2 ######
    Section "InputDevice"
       Identifier   "Generic Keyboard"
       Driver      "kbd"
       Option      "CoreKeyboard"
       Option      "XkbRules"   "xorg"
       Option      "XkbModel"   "abnt2"
       Option      "XkbLayout"   "br"
       Option      "XkbVariant"   "abnt2"
    EndSection
    ###### Fim do Teclado ABNT2 ######

    ###### Teclado americano internacional ######
    #Section "InputDevice"
    #   Identifier   "Generic Keyboard"
    #   Driver      "kbd"
    #   Option      "CoreKeyboard"
    #   Option      "XkbRules"   "xorg"
    #   Option      "XkbModel"   "pc105"
    #   Option      "XkbLayout"   "us_intl"
    #EndSection
    ####### Fim do americano internacional ######

    #
    # Aqui estão os mouses, você não precisa remover nenhum deles
    # pois o Xorg irá aceitar qualquer um já que temos a diretiva
    # "AllowMouseOpenFail"  setada como "true" acima.
    #

    # Mouse PS/2
    Section "InputDevice"
       Identifier   "Mouse0"
       Driver      "mouse"
       Option      "CorePointer"
       Option      "Device"      "/dev/psaux"
       Option      "Protocol"      "Auto"
       Option      "Emulate3Buttons"   "true"
    EndSection

    # Mouse USB
    Section "InputDevice"
       Identifier   "Mouse1"
       Driver      "mouse"
       Option      "Protocol"      "IMPS/2"
       Option      "Device"      "/dev/input/mice"
       Option      "ZAxisMapping"      "4 5"
       Option      "Buttons"      "5"
       Option      "Resolution"      "650"
    EndSection

    # Mouse Serial em ttys0
    Section "InputDevice"
       Identifier   "Mouse2"
       Driver      "mouse"
       Option      "Protocol"      "Microsoft"
       Option      "Device"      "/dev/ttys0"
       Option      "ZAxisMapping"      "4 5"
       Option      "Buttons"      "5"
       Option      "Resolution"      "650"
    EndSection

    # Mouse Serial em ttys1
    Section "InputDevice"
       Identifier   "Mouse3"
       Driver      "mouse"
       Option      "Protocol"      "Microsoft"
       Option      "Device"      "/dev/ttys1"
       Option      "ZAxisMapping"      "4 5"
       Option      "Buttons"      "5"
       Option      "Resolution"      "650"
    EndSection

#Seção TOUCHPAD, orientação <http://wiki.debian.org/SynapticsTouchpad> 13-12-2010 ##

Section "InputClass"
        Identifier      "Touchpad"                      # required
        MatchIsTouchpad "yes"                           # required
        Driver          "synaptics"                     # required
        Option          "MinSpeed"              "0.5"
        Option          "MaxSpeed"              "1.0"
        Option          "AccelFactor"           "0.075"
        Option          "TapButton1"            "1"
        Option          "TapButton2"            "2"     # multitouch
        Option          "TapButton3"            "3"     # multitouch
        Option          "VertTwoFingerScroll"   "1"     # multitouch
        Option          "HorizTwoFingerScroll"  "1"     # multitouch
        Option          "VertEdgeScroll"        "1"
        Option          "CoastingSpeed"         "8"
        Option          "CornerCoasting"        "1"
        Option          "CircularScrolling"     "1"
        Option          "CircScrollTrigger"     "7"
        Option          "EdgeMotionUseAlways"   "1"
        Option          "LBCornerButton"        "8"     # browser "back" btn
        Option          "RBCornerButton"        "9"     # browser "forward" btn
    Option          "EmulateTwoFingerMinZ"  "35"     #Instruções tópico Multitouch
        Option          "EmulateTwoFingerMinW"  "8"    #Instruções tópico Multitouch
EndSection

#FIM da SEÇÃO TOUCHPAD <http://wiki.debian.org/SynapticsTouchpad> 13-12-2010 ##

    Section "Device"
       Identifier   "Placa de Vídeo Genérica"
       # Em raros caso, comente o vesa e descomente o fbdev
            Driver   "vesa"
       # Driver   "fbdev"
    EndSection

    Section "Monitor"
       Identifier   "Monitor Genérico"
       Option      "DPMS"
       HorizSync   28-57
       VertRefresh   43-60
    EndSection

    Section "Screen"
       Identifier   "Default Screen"
       Device      "Placa de Vídeo Genérica"
       Monitor      "Monitor Genérico"
       DefaultDepth   16
       SubSection "Display"
          Depth      16
        Modes     "1365x768" "1280x720" "852x480"
          #Modes      "1280x800" "1280x1024" "1024x768" "800x600" "640x480"
    
       EndSubSection
    EndSection

    Section "ServerLayout"
       Identifier   "Default Layout"
       Screen      "Default Screen"
       InputDevice   "Generic Keyboard"
       InputDevice   "Mouse0"
       InputDevice   "Mouse1"
       InputDevice   "Mouse2"
       InputDevice   "Mouse3"
    EndSection

    Section "DRI"
       Mode   0666
    EndSection
Obrigado!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/12/2010, 15:48
Resposta: #4
Re: Clique do touchpad não funciona
tem muita coisa neste seu xorg.conf que está atrapalhando o funcionamento do mouse, faz o seguinte vamos fazer um backup deste seu xorg e tentar gerar um novo e aí vc testar se o gráfico está funcionando, depois iremos configurar o touchpad somente:
veja se gera um bom e completo com o comando:
# X -configure
# cp /etc/X11/xorg.conf{,.backup}
# cp /root/xorg.conf.new /etc/X11/xorg.conf

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
16/12/2010, 21:56
Resposta: #5
Re: Clique do touchpad não funciona
eu consegui resolver no gnome indo em Sistema -> Preferencias -> Mouse
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/12/2010, 16:35
Resposta: #6
Re: Clique do touchpad não funciona
robsoncrux Escreveu:eu consegui resolver no gnome indo em Sistema -> Preferencias -> Mouse
sim, mas para isso precisa estar configurado certo no xorg.conf além disso tem que ter a opção lá:
Option "SHMConfig" "true"

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/12/2010, 08:03
Resposta: #7
Re: Clique do touchpad não funciona
Olá Dmatrix e Robsoncrux

Mais uma vez desculpem aí a demora. Minhas atividades de ontem me mantiveram afastado do Notebook que estou configurando e de qualquer outro computador.

Realmente bastou ir no menu Sistema -> Preferências -> Mouse -> "Aba Touchpad", habilitei o clique, conforme o Robsoncrux indicou e resolveu, maravilha!

Francamente eu não tinha procurado nada neste sendido porque mudei recentemente para o Squeeze e precisei procurar um xorg.conf para resolver problemas de resolução do monitor, a partir daí as dicas e tópicos que li sobre touchpad encaminhavam para alterar o xorg.conf.

De qualquer forma eu gostaria de melhorar meu arquivo xorg.conf
O comando indicado pelo Dmatrix retorna o seguinte:
Código:
[email protected]:/home/jr# X :1 -configure

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32.25-dsa-ia32 i686 Debian
Current Operating System: Linux noteposit 2.6.32-5-686 #1 SMP Thu Nov 25 18:43:34 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-686 root=UUID=8e95463e-a34d-4ecc-9770-28138221aed3 ro single
Build Date: 12 November 2010  12:21:56AM
xorg-server 2:1.7.7-9 (Julien Cristau <[email protected]>)
Current version of pixman: 0.16.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Sat Dec 18 08:08:04 2010
List of video drivers:
    r128
    sisusb
    siliconmotion
    openchrome
    tdfx
    nv
    cirrus
    neomagic
    vmware
    mga
    sis
    ark
    radeon
    intel
    vmwlegacy
    geode
    nouveau
    trident
    ztv
    tseng
    chips
    i740
    voodoo
    s3
    apm
    mach64
    ati
    savage
    i128
    s3virge
    rendition
    fbdev
    vesa
vmware: Please ignore above "FATAL: Module vmwgfx not found."
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) open /dev/fb0: No such file or directory

Backtrace:
0: X (xorg_backtrace+0x3b) [0x80adebb]
1: X (0x8048000+0x5aa95) [0x80a2a95]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb786740c]
3: X (InitOutput+0x1da) [0x80b05aa]
4: X (0x8048000+0x1e7f0) [0x80667f0]
5: /lib/i686/cmov/libc.so.6 (__libc_start_main+0xe6) [0xb759ac76]
6: X (0x8048000+0x1e5a1) [0x80665a1]
Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.1.log" for additional information.

Abortado
[email protected]:/home/jr#

Obrigado
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/12/2010, 18:36
Resposta: #8
Re: Clique do touchpad não funciona
não entendi, por que colocou :1 ?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/12/2010, 08:52
Resposta: #9
Re: Clique do touchpad não funciona
Olha, o comando X -configure sem o ":1" tinha retornado a seguinte mensagem:
Código:
[email protected]:/home/jr# X -configure

Fatal server error:
Server is already active for display 0
    If this server is no longer running, remove /tmp/.X0-lock
    and start again.


Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.

[email protected]:/home/jr#

Daí eu vi no wiki.debian.org que mandava executar o comando Xorg :1 -configure, experimentei colocar esse :1 no comando que você indicou. Na verdade não sei prá que serve, mas achei que sem ele o comando não tinha sido executado.
Obrigado, e espero novas dicas ...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/12/2010, 13:00
Resposta: #10
Re: Clique do touchpad não funciona
ok, o comando é pra ser executado sem o modo gráfico, mas tudo bem o :1 é para inicializar o gráfico no outro viewport, estava vendo a saídas acima e mesmo assim foi gerado o arquivo novo do xorg.conf.new que precisamos,
(++) Using config file: "/root/xorg.conf.new"
dá uma olhada neste diretório se esse arquivo está lá e se o conteúdo tem todas seções esperadas.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/12/2010, 17:35
Resposta: #11
Re: Clique do touchpad não funciona
Realmente tem um arquivo /root/xorg.conf.new com o seguinte conteúdo:
Código:
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
    Load  "extmod"
    Load  "record"
    Load  "dbe"
    Load  "dri2"
    Load  "dri"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "ShadowFB"               # [<bool>]
        #Option     "Rotate"                 # <str>
        #Option     "fbdev"                  # <str>
        #Option     "debug"                  # [<bool>]
    Identifier  "Card0"
    Driver      "fbdev"
    VendorName  "Silicon Integrated Systems [SiS]"
    BoardName   "771/671 PCIE VGA Display Adapter"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
Eu não coloquei ele agora no /etc/X11/xorg.conf para testar porque tem outra pessoa da casa utilizando o notebook. Depois eu posto aqui o que aconteceu.
Obrigado por enquanto. Qualquer coisa mais manda aí por favor.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/12/2010, 08:49
Resposta: #12
Re: Clique do touchpad não funciona
Pois bem, eu coloquei o novo arquivo xorg.conf.new (gerado pelo comando "X -configure") no /etc/X11/xorg.conf, daí o computador não inicializou. Então entrei no sistema pelo "recovery mode" e no terminal recoloquei no diretório /etc/X11 o backup do xorg.conf aterior.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/12/2010, 16:17
Resposta: #13
Re: Clique do touchpad não funciona
talvez o xorg novo num tenha inicializado por causa do driver de video
Driver "fbdev"

se mudar para vesa deve carregar, esse driver é superior ao vesa, num sei se seria só carregar o modulo, veja aí dê o comando :
modprobe fbdev
e depois
startx

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/12/2010, 23:32
Resposta: #14
Re: Clique do touchpad não funciona
Valeu!
Mudei no xorg.conf o nome do driver de "fbdev" para "vesa" e o sistema iniciou no modo gráfico. Tentei habilitar o módulo fbdev, mas não deu. Veja
Código:
[email protected]:~# modprobe fbdev
FATAL: Module fbdev not found.
[email protected]:~#
Acho que assim com o vesa o meu xorg.conf está bom. O que você acha?
Até mais
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/12/2010, 09:55
Resposta: #15
Re: Clique do touchpad não funciona
acho que com vesa está funcional mas com um driver mais apropriado vc pode ter uma melhor qualidade de imagem, tente mudar para o driver sis671:
Driver "sis671"

baixe e extraia os arquivos do anexo:
[attachment=0]
copie para o diretório /usr/lib/xorg/modules/drivers
e teste novamente, em alguns casos o configurador do xorg detecta um incorreto chipset.


Arquivos Anexos
.rar  xorg-driver-sis671-0.9.1-fixed-build.rar (Tamanho: 728,32 KB / Downloads: 10)

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS