Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
[RESOLVIDO]Problema na inicialização do daemon do S.M.A.R.T.
27/11/2010, 07:51
Resposta: #1
[RESOLVIDO]Problema na inicialização do daemon do S.M.A.R.T.
Pessoal,

Bom-dia. Preciso ativar o monitoramento da saúde do HDD, através do S.M.A.R.T., e para isso segui as instruções, relacionadas pelo Morimoto, neste tutorial a seguir:

http://www.gdhpress.com.br/ferramentas/ ... ?p=cap2-32

Pois bem. Acontece que, quando da inicialização do sistema, durante o boot, me aparece a seguinte mensagem de erro, relacionada ao S.M.A.R.T.: "Starting S.M.A.R.T. daemon: smartd Failed!"

Por ora, é isso!

Um abraço! :mrgreen:

"A constante é que as pessoas mentem, a variável é o motivo"
- Dr. Gregory House
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/11/2010, 16:13
Resposta: #2
Re: Problema na inicialização do daemon do S.M.A.R.T.
vc só instalou ou descomentou a linha "start_smartd=yes"?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/11/2010, 16:17
Resposta: #3
Re: Problema na inicialização do daemon do S.M.A.R.T.
dmatrix Escreveu:vc só instalou ou descomentou a linha "start_smartd=yes"?

Instalei e descomentei a linha, como sugere o tutorial... Mas sem sucesso.

"A constante é que as pessoas mentem, a variável é o motivo"
- Dr. Gregory House
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
27/11/2010, 16:44
Resposta: #4
Re: Problema na inicialização do daemon do S.M.A.R.T.
estou achando que essa mensagem é porque ele já está em execução....dá um olhada com o ps -aux se o daemon já num está sendo executado. veja tb se parando e iniciando o serviço se dá erro ou inicializa normal:
# /etc/init.d/smartmontools stop
# /etc/init.d/smartmontools start

se num for smartmontools altere para o correto.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
28/11/2010, 09:36
Resposta: #5
Re: Problema na inicialização do daemon do S.M.A.R.T.
dmatrix Escreveu:estou achando que essa mensagem é porque ele já está em execução....dá um olhada com o ps -aux se o daemon já num está sendo executado. veja tb se parando e iniciando o serviço se dá erro ou inicializa normal:
# /etc/init.d/smartmontools stop
# /etc/init.d/smartmontools start

se num for smartmontools altere para o correto.

dmatrix,

O erro ocorre durante o boot (no runlevel anterior ao início do X). É improvável, portanto, que o processo já estivesse correndo.

De qualquer maneira, segui tua sugestão de parar o daemon manualmente e tentar reiniciá-lo e o erro também ocorre. :?

Buenas... Fico no aguardo!

"A constante é que as pessoas mentem, a variável é o motivo"
- Dr. Gregory House
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/11/2010, 10:41
Resposta: #6
Re: Problema na inicialização do daemon do S.M.A.R.T.
mas o processo aparece na listagem do ps?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
29/11/2010, 11:00
Resposta: #7
Re: Problema na inicialização do daemon do S.M.A.R.T.
dmatrix,

Bom-dia. Não, não aparece (acredito que ele não inicie por causa da falha).

"A constante é que as pessoas mentem, a variável é o motivo"
- Dr. Gregory House
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/11/2010, 07:44
Resposta: #8
Re: Problema na inicialização do daemon do S.M.A.R.T.
por favor poste o conteúdo do arquivo /etc/default/smartmontools e a saída do comando mount, veja tb se no script smartmontools vc definiu corretamente o dispositivo a ser monitorado tipo /dev/sda, aqui testei e rodou de primeira só mudei para sda que tava com hda e descomentei a linha no script.
ah diga se instalou pelo apt-get, se num foi então remova a instalação anterior e instale pelo aptitude.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/11/2010, 08:37
Resposta: #9
Re: Problema na inicialização do daemon do S.M.A.R.T.
Citar:Conteúdo do "smartmontools":

# Defaults for smartmontools initscript (/etc/init.d/smartmontools)
# This is a POSIX shell fragment

# List of devices you want to explicitly enable S.M.A.R.T. for
# Not needed (and not recommended) if the device is monitored by smartd
#enable_smart="/dev/hda /dev/hdb"

# uncomment to start smartd on system startup
start_smartd=yes

# uncomment to pass additional options to smartd on startup
#smartd_opts="--interval=1800"

- Não entendi o que tu quiseste dizer com "saída do comando mount"
- A linha correspondente à unidade de disco, no "smartmontools", está comentada por causa da instrução existente no próprio arquivo ("Not needed (and not recommended) if the device is monitored by smartd"), mas , por via das dúvidas, descomentei a linha aqui e alterei a unidade para sda (meu HDD é SATA), porém, continua com erro.
- Instalei a partir do apt-get.

No aguardo. Um abraço! Sorrisão

"A constante é que as pessoas mentem, a variável é o motivo"
- Dr. Gregory House
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/11/2010, 09:22
Resposta: #10
Re: Problema na inicialização do daemon do S.M.A.R.T.
digite o comando mount no terminal, vai gerar um saída de pontos de montagem incluindo o hd.
como que ficou então a linha do enable_smart?
deixou somente com um dispositivo?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/11/2010, 13:54
Resposta: #11
Re: Problema na inicialização do daemon do S.M.A.R.T.
Citar:/dev/sda4 on / type ext2 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
/dev/sda2 on /media/dados type fuseblk (rw,allow_other,blksize=4096)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)

dmatrix,

A linha enable_smart não ficou de jeito algum: ela está comentada, pois a recomendação do próprio S.M.A.R.T. é, caso se esteja utilizando o daemon "smartd" para monitorar o HDD (ao invés do smartmontools, acredito), não deve ser passada nenhum instrução nessa linha (pelo menos foi o que entendi).

De qualquer maneira, como eu havia mencionado, se eu descomentar a linha e referenciar o dispositivo /dev/sda o erro também ocorre... :roll: :|

"A constante é que as pessoas mentem, a variável é o motivo"
- Dr. Gregory House
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/11/2010, 16:22
Resposta: #12
Re: Problema na inicialização do daemon do S.M.A.R.T.
ok, não tenho certeza se essa linha do enable_smart evita erros, mas dá uma olhada no setup da bios da máquina se na seção de configuração do hd se lá está habilitada a opção de smart, acho que pode ser isso que está fazendo dar erro, talvez esteja desativado isso na bios.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/12/2010, 18:26
Resposta: #13
Re: Problema na inicialização do daemon do S.M.A.R.T.
Nops... Tá ativado.

"A constante é que as pessoas mentem, a variável é o motivo"
- Dr. Gregory House
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/12/2010, 16:06
Resposta: #14
Re: Problema na inicialização do daemon do S.M.A.R.T.
que versão do debian é o seu? Lenny, squeeze? que versão de kernel? digite no terminal:
uname -a

num sei se o smart tem algo associado ao acpi, pode ser algum pacote esteja faltando ou então talvez desinstalando ele e instalando novamente resolva.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
07/12/2010, 23:18
Resposta: #15
Re: Problema na inicialização do daemon do S.M.A.R.T.
dmatrix,

É o Lenny, kernel: 2.6.26-2-686

Com relação ao ACPI, acho improvável que, pelo menos no meu caso, haja alguma ligação entre um e outro, já que não utilizo nenhum esquema de economia de energia. De qualquer maneira, buscando por ACPI na listagem dos pacotes instalados (dpkg -l | grep acpi), encontrei somente duas referências, que seguem:

ii acpi-support-base 0.109-11 scripts for handling base ACPI events such as the power button
ii acpid 1.0.8-1lenny2 Utilities for using ACPI power management


Se souberes de mais alguma dica, fico no aguardo.

Um abraço e muito obrigado pelo auxílio até aqui!!

"A constante é que as pessoas mentem, a variável é o motivo"
- Dr. Gregory House
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS