Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
[RESOLVIDO] Não consigo instalar o pacote python-pyatspi
02/04/2008, 09:23
Resposta: #1
[RESOLVIDO] Não consigo instalar o pacote python-pyatspi
Olá pessoal,

Versão: Debian Testing

Início do problema: durante uma atualização via "aptitude safe-upgrade" ocorreu uma interrupção desse processo . Após reinicializar o computador eu dei os seguintes comandos:

apt-get update
apt-get install python-pyatspi

mas deu a seguinte mensagem:

Lendo lista de pacotes... Pronto
Construindo árvore de dependências
A ler a informação de estado... Pronto
python-pyatspi já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Após esta operação, serão utilizados 0B adicionais de espaço em disco.
Instalando python-pyatspi (1.22.0-1) ...
INFO: using old version '/usr/bin/python2.3'
Compiling /usr/lib/python2.3/site-packages/pyatspi/constants.py ...
File "/usr/lib/python2.3/site-packages/pyatspi/constants.py", line 195
values = ((name, value) for name, value in acc_dict.items()
^
SyntaxError: invalid syntax

pycentral: pycentral pkginstall: error byte-compiling files (6)
pycentral pkginstall: error byte-compiling files (6)
dpkg: erro processando python-pyatspi (--configure):
subprocesso post-installation script retornou código de saída de error 1
Erros foram encontrados durante processamento de:
python-pyatspi
E: Sub-process /usr/bin/dpkg returned an error code (1)

Eu já desintalei este pacote de duas formas:

aptitude purge remove python-pyatspi

e com

dpkg --force-all -P python-pyatspi

e voltei a tentar instalar e deu o mesmo erro.
Já entrei no site de pacotes da debian testing para checar quais pacotes
são necessários e estão todos instalados.

Dei o seguinte comando:

dpkg --configure -a

e a resposta foi:

Instalando python-pyatspi (1.22.0-1) ...
INFO: using old version '/usr/bin/python2.3'
Compiling /usr/lib/python2.3/site-packages/pyatspi/constants.py ...
File "/usr/lib/python2.3/site-packages/pyatspi/constants.py", line 195
values = ((name, value) for name, value in acc_dict.items()
^
SyntaxError: invalid syntax

pycentral: pycentral pkginstall: error byte-compiling files (6)
pycentral pkginstall: error byte-compiling files (6)
dpkg: erro processando python-pyatspi (--configure):
subprocesso post-installation script retornou código de saída de error 1
Erros foram encontrados durante processamento de:
python-pyatspi


Aguardo sugestões, pois já não sei mais o que fazer!

Obrigado
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/04/2008, 01:40
Resposta: #2
 
se está utilizando o lenny no sources.list então atualize o python para a versão 2.4
# aptitude install python python2.4

depois tente um:
# dpkg-reconfigure python-pyatspi

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
07/04/2008, 08:26
Resposta: #3
 
Acho que sua sugestão também funciona cara, mas já tinha resolvido o problema e foi através de um site que falava desse BUG, dizendo haver uma incompatibilidade entre o pacote python-pyatspi com o python2.3, impedindo a instalação do python-pyatspi.


A solução é a seguinte:

1) Remover o pacote python2.3 através de:

aptitude purge remove python2.3

2) Instalar o pacote python-pyatspi através de:

apt-get install python-pyatspi


O site onde encontrei a solução é o seguinte:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=471397

Obrigado a todos pela atenção e colaboração.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS