Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
RESOLVIDOnetwork-admin não abre interface gráfica,como root.
28/03/2008, 18:20
Resposta: #16
 
Fiz a edição do arquivo /var/lib/dpkg/status e o modifique como sugerido. Em seguida executei o comando

aptitude install system-tools-backends

As mensagens foram essas:

aptitude install system-tools-backends
Lendo lista de pacotes... Pronto
Construindo árvore de dependências
A ler a informação de estado... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Gravando informações estendidas de estado... Pronto
Lendo descrições de tarefas... Pronto
Construindo a base de dados... Pronto
Os NOVOS pacotes a seguir serão instalados:
system-tools-backends
Os pacotes a seguir serão REMOVIDOS:
libntfs-3g23{u}
0 pacotes atualizados, 1 novos instalados, 1 a serem removidos e 0 não atualizados.
É preciso obter 0B/167kB de arquivos. Depois do desempacotamento, 369kB serão usados.
Você deseja continuar? [Y/n/?] Y
Gravando informações estendidas de estado... Pronto
(Lendo banco de dados ... 160278 arquivos e diretórios atualmente instalados.)
Removendo libntfs-3g23 ...
Selecionando pacote previamente não selecionado system-tools-backends.
(Lendo banco de dados ... 160268 arquivos e diretórios atualmente instalados.)
Descompactando system-tools-backends (de .../system-tools-backends_2.4.2-1_i386.deb) ...
Instalando system-tools-backends (2.4.2-1) ...
Reloading system message bus config...done.
Lendo lista de pacotes... Pronto
Construindo árvore de dependências
A ler a informação de estado... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Gravando informações estendidas de estado... Pronto
Lendo descrições de tarefas... Pronto
Construindo a base de dados... Pronto
There are now 0 broken [-1], 21002 new [-1].


network-admin continua dando o mesmo erro.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/03/2008, 13:40
Resposta: #17
 
seu apt-get tem um pacote quebrado, é preciso identifica-lo e resolver isso. tente ver se os comandos abaixo existe o pacote e resolvem tal problema:
# apt-get check
# apt-get -f install

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
31/03/2008, 09:30
Resposta: #18
 
Resultado do comando: apt-get check

Lendo lista de pacotes... Pronto
Construindo árvore de dependências
A ler a informação de estado... Pronto

Resultado do comando: apt-get -f install

Lendo lista de pacotes... Pronto
Construindo árvore de dependências
A ler a informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

Ainda não foi desta vez.... continua com o erro.

Nas respostas dos comandos que eu te enviei, onde que você notou que pode ter pacote quebrado?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
31/03/2008, 11:27
Resposta: #19
 
caramba, me equivoquei não há pacotes quebrados... vamos lá verificar mais alguns pacotes instalados, veja se estes estão:
# aptitude install gnome-keyring gnome-keyring-manager libgnome-keyring0 libpam-gnome-keyring libdbus-1-3 libdbus-glib-1-2 libnet-dbus-perl libglib2.0-0

caso instalou algum, tente inicializar o system-tools-backends
# /etc/init.d/system-tools-backends start

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
31/03/2008, 12:03
Resposta: #20
 
Cara você resolveu o problema. OBRIGADÃO MESMO.

Estava faltando o pacote gnome-keyring-manager e uma das "libs".
Antes que eu ponha "resolvido" no tópico, você poderia me dizer como que eu checo através de comandos quais pacotes e "libs" são necessários para que o network-admin funcione; também gostaria de saber se o que estava faltando pode ter sido retirado durante uma atualização via apt-get update, porque eu tenho certeza que eu não tirei nada.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
31/03/2008, 16:29
Resposta: #21
 
blz, seguinte, caso precise saber de qual pacote um programa faz parte, vc deve utilizar o :
dpkg -S network-admin
ou utilize a busca no site: http://www.debian.org/distrib/packages#search_contents
que em ambos os casos vai reportar o pacote: gnome-system-tools descoberto isso vc analisa se as dependencias estão instalas :
aptitude show gnome-system-tools
ou pelo site
http://packages.debian.org/etch/gnome-system-tools

evidente que cada dependencias pode ter imbutido outras dependencias próprias de cada pacote. Normalmente o aptitude verifica isso e baixa elas pra vc. Se foi a atualização a resposta é sim, mas não foi a utilização do apt-get update e sim apt-get dist-upgrade, procure utilizar o aptitude safe-upgrade para evitar que o apt-get faça um remoção indesejada

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 2 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS