Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
GRUB Falhando
14/03/2008, 10:39
Resposta: #1
GRUB Falhando
Pessoal, o GRUB costuma falhar as vezes?
Tenho um sistema com 3 sistemas instalados, Debian, Redhat e Windows. O GRUB está bem configurado e gerenciando os tres, mas as vezes ele falha e nenhum sistema é carregado na inicializaão, fornecendo uma mensagem de erro de que nenhum harddisk foi encontrado. Em seguida, eu desconecto o HD do Windows (sao dois, um com Linux e o outro com Windows), boot novamente e o GRUB volta a funcionar. O GRUB está na MBR, então ele está no HD do Windows, certo?

title Linux Inicio
root (hd2,7)
kernel /boot/vmlinuz-2.6.9-67.EL ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.9-67.EL.img
title Red Hat Enterprise Linux AS (2.6.9-67.EL)
root (hd2,5)
kernel /boot/vmlinuz-2.6.9-67.EL ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.9-67.EL.img
title Debian GNU/Linux, kernel 2.6.18-5-k7
root (hd2,4)
kernel /boot/vmlinuz-2.6.18-5-k7 root=/dev/sda5 ro
initrd /boot/initrd.img-2.6.18-5-k7
savedefault
title Windows XP
rootnoverify (hd0,0)
chainloader +1

Um abraco a todos!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/03/2008, 21:29
Resposta: #2
 
Olá, essa mensagem de harddisk não encontrado ocorre antes ou já no grub? Pelo que entendi parece ser um problema no hd. Tente ver se é possível configurar o hd na bios no modo manual fixo.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/03/2008, 01:52
Resposta: #3
 
Acontece antes do grub.. Alias, ele nem chega a ser carregado, porque aparece essa mensagem de erro antes: "SYSTEM FAILURE"
Desconectado um hd, reiniciando, depois conectando novamente e reiniciando, o problema some. O curioso é que se eu desconecto e reconecto direto sem reiniciar, o problema não some!!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/03/2008, 20:36
Resposta: #4
 
GuilhermeSilva Escreveu:Acontece antes do grub.. Alias, ele nem chega a ser carregado, porque aparece essa mensagem de erro antes: "SYSTEM FAILURE"
Desconectado um hd, reiniciando, depois conectando novamente e reiniciando, o problema some. O curioso é que se eu desconecto e reconecto direto sem reiniciar, o problema não some!!
bom diante destas novas informações então o titulo do tópico não deveria ser esse pois é um problema fisico no hd. Como vc faz para desconectar o hd? é de gaveta? na minha opnião tá parecendo um problema no motor dele ( hd ) que não está dando partida. talvez fosse melhor recomeda-lo que faça backup dos dados principais, pois ele não me parece muito seguro.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/03/2008, 12:03
Resposta: #5
 
Desconectar que eu falo é tirar o cabo de dados e depois colocar novamente. O HD nao apresenta nenhum problema com relacao à parte mecanica, está em perfeito estado!
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/03/2008, 20:48
Resposta: #6
 
se está certo disso então ele deve funcionar perfeitamente em outro micro. verifique se o strap de jumpers nele está correto.
pode tb ser um problema na MBR do hd daí só regravando ou refazendo ela.
outra coisa tb que pode ser é falta de energia suficiente para partida do hd, verifique a fonte ou tente troca-la por uma de maior potência.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS