Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
[RESOLVIDO]Erro na inicialização do KDE 3.5
06/03/2008, 17:35
Resposta: #1
[RESOLVIDO]Erro na inicialização do KDE 3.5
Boa tarde amigos,

Eu faço o meu login no Debian Testing usando o kdm. Quando eu escolho iniciar a sessão com o Gnome, ele entra beleza.Quando eu escolho iniciar a sessão com o Kde, ai acontece o problema, pois a tela de inicialização do kde (default) aparece com 7 icones. O primeiro (desenho de uma engrenagem) começã a "piscar" e logo ela para de piscar e passa para o segundo ícone que começa a piscar com o dizer "Inicializando serviços do sistema". Demora um tempão e não passa para os ícones subsequentes nem aparece barra de ferramentas, nem o ícone K nem nada, apenas a tela com a cor normal de fundo.

1)Eu já interrompi todos os serviços pelo gnome e depois tentei entrar no kde, só que não deu certo.O comando foi rcconf.

2)Eu já atualizei o sistema e retirei o kde pelo synaptic e tornei a instala-lo, mas também não deu certo, pois continua dando o mesmo erro.

Agradeço a qualquer sugestão, pois gostaria de utilizar o kde como sempre fiz.

Obrigado,

Antonio
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
06/03/2008, 21:41
Resposta: #2
 
adicione um usuário ao sistema e tente logar com ele.
Se funcionar, o problema pode estar nos arquivos do KDE que estão na sua pasta pessoal.

Se quiser fazer um teste, mova a pasta ".kde" de sua home para outra pasta e tente logar novamente.

[Imagem: debianuseruserbarsp1.png]
[Imagem: gnomeuserqj9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/03/2008, 09:00
Resposta: #3
 
Olá pessoal,

Segui a sugestão de adicionar um usuário ao sistema e tentar logar com ele, mas infelizmente eu não consegui entrar no kde, dando o mesmo erro descrito.
No entanto eu consigui entrar na sessão desse novo usuário pelo gnome.

Porque mesmo eu desinstalando e instalando todo o kde pelo synaptic, ele persiste em dar esse erro? Como resolver ?

...aguardo mais sugestões, pois não tenho a menor idéia de como solucionar.

Obrigado
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
10/03/2008, 09:57
Resposta: #4
 
acpveiga Escreveu:... Porque mesmo eu desinstalando e instalando todo o kde pelo synaptic, ele persiste em dar esse erro? ...

Alguns erros com a interface gráfica ocorrem quando os arquivos de configuração estão com algum problema, as vezes, entre uma versão e outra do software (KDE) o formato dos arquivos de configuração mudam, fazendo com que alguns problemas surjam.

Quando desista-la um software pelo synaptic/aptitude ou apt-get, os arquivos de configuração desse software desinstalado não são removidos.
Para remover um software junto com seus arquivos de configuração, utilize a opção purge:

Código:
aptitude purge qualquer-software

Se usa apt-get:

Código:
apt-get --purge remove qualquer-software


[quote]... Como resolver ? ...[/code]

Sou usuário do GNOME, já tive e ainda tenho problemas com arquivos de configuração que mudam de formato, principalmente quando existe uma atualização do software, como por exemplo do GNOME 2.18 para 2.20.
Nesses casos, apenas removo os arquivos de configuração que ficam na minha pasta pessoal (/home/meu-usuario).
Não sei se esse é o seu caso, mas o problema pode estar nos arquivos de configuração que estão no sistema, como /etc e não nos da sua pasta pessoal, pois com outro usuário também não funcionou.
Se quiser fazer um teste, remova o kde com a opção purge:

Código:
aptitude purge kde

Remova a pasta .kde da sua partição home e tente instalar o kde de novo.

[Imagem: debianuseruserbarsp1.png]
[Imagem: gnomeuserqj9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/03/2008, 11:26
Resposta: #5
 
Olá pessoal,

Segui a sugestão de remover o kde e suas configurações utilizando o comando:

apt-get --purge remove kdebase kde-i18n-ptbr
apt-get autoclean
apt-get autoremove
apt-get update
apt-get -f dist-upgrade

Como após este comando permaneceu um arquivo no /etc
chamado kde3, eu modifiquei o seu nome para Backupkde3, pois achei que o mesmo poderia conter alguma configuração do kde que eu havia acabado de remover.

Após isto reinstalei o kde como o comando:

apt-get install kdebase kde-i18n-ptbr

Finalmente, criei outro usuário e após resetar o computador eu tentei entrar com o novo usuário em uma sessão do kde.

Infelizmente ocorreu o mesmo erro descrito no início dessas discussões.

Parece que mesmo usando o apt-get --purge remove o debian não consegue instalar o kde do zero. Pode ser que o problema seja outro ....

Aguardo sugestões ...

Obrigadão
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/03/2008, 12:35
Resposta: #6
 
Olá pessoal,

Por favor, qualquer sugestão é bem vinda.
Não sei o que fazer para usar o kde e já tentei muita coisa.

Moderador salve esse iniciante ...

até mais
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/03/2008, 01:39
Resposta: #7
 
Sou usuário do Gnome há muito tempo, não conheço muito dos problemas que o kde pode ter.

O comando que voce usou:
Citar:apt-get --purge remove kdebase kde-i18n-ptbr
Não removeu todo o KDE e sim apenas a base do KDE e a tradução dele.

Ainda acho que é problema de algum arquivo danificado ou arquivo de configuração.

Se tiver uma boa conexão com a internet e tempo de sobra, faça um teste:

- Abra um terminal e logue-se como root.
- digite:

Código:
aptitude purge kde kdebase kde-i18n-ptbr

Aguarde a remoção. Depois abra o synaptic e efetue uma busca por kde, caso encontre alguma biblioteca, remova-a.

Para finalizar, instale o software deborphan:

Código:
aptitude install deborphan

depois execute-o como root, ele vai retornar todos os programas que estão "sobrando" no sistema, remova todos os softwares indicados pelo deborphan, para remove-los use:

Código:
aptitude purge nome-do-software


Remova a pasta .kde da sua partição home, limpe o cache do apt com:

Código:
aptitude clean

Caso dentro da pasta /etc tiver uma pasta kde ou kde3, mova-a.

Por fim, tente instalar o kde de novo. Se mesmo assim não funcionar, não sei o que pode ser.

[Imagem: debianuseruserbarsp1.png]
[Imagem: gnomeuserqj9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/03/2008, 10:54
Resposta: #8
 
Bom dia a todos,

Gostaria de agradecer muito pela ajuda recebida neste forum, independentemente da solução ter sido encontrada em outra fonte, pois sei que todos doaram um pouquinho do seu tempo para tentar resolver um problema que era meu.

Vamos a solução.
Como eu achei que o problema não estava no pacote kde e portanto desinstalar e instalar não resolveria o problema, então, continuei pesquisando e dei a maior sorte por encontrar em um site de 2004 em ingles a solução abaixo:

Incluir no arquivo /etc/network/interfaces as seguintes linhas:

auto lo
iface lo inet loopback

Após isto, reboot o pc e volte a ligar que o kde entrará normalmente.
Pessoal, quando eu li eu achei que fosse besteira, pois pensei: um arquivo de configuração de rede não pode influenciar na entrada do kde ... ainda bem que eu me enganei e o treco funcionou.

Abr,

Antonio.

PS: O link do site é o seguinte

http://linux.derkeiler.com/Mailing-List ... /4107.html


[RESOLVIDO]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS