Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Erro no boot ao recriar nova tabela de partição
17/11/2010, 07:52
Resposta: #1
Erro no boot ao recriar nova tabela de partição
Olá pessoal,

Recentemente fiz backup do meu HD e em seguida criei uma nova tabela de partição. Ao recuperar o backup reisntalei o grub2 pelo ubuntu 9.10 e foi reconhecido todos os SO instalados. Ao tentar dar boot pelo Kurumin 7, aparece na tela a seguinte mensagem:


UFS: can't find ext3 filesystem on dev hdc9
mount: wrong to type, bad option, bad superblock on /dev/hdc9
missing codepage or other error
in some useful info is found in syslog - try
dmseg | tail or so
Switching root ...
/usr/lib/yiard/exec/run_int: current directory on the same fylesystem as the root: Success
Kernel panic - not syncing: Attempted to kill init!


Depois de recriar a tabela de partição, nao existe mais hdc9. Não tenho conhecimento qual arquivo que está sendo carregado durante o boot que ainda carrega a informação hdc9. Já verifiquei o arquivo /etc/fstab e fiz as modificações necessárias.

Fico grato com quem consegui me ajudar a corrigir este problema e poder dar boot pelo kurumin novamente.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
17/11/2010, 13:12
Resposta: #2
Re: Erro no boot o recriar nova tabela de partição
deve ser o fstab da nova partição aonde está o kurumin. verifique qual é a partição do kurumin, monte ela utilizando a console do ubuntu e edite o fstab desta partição montada. veja com o fdisk em qual partição está o kurumin.
# fstab -l

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/11/2010, 14:22
Resposta: #3
Re: Erro no boot ao recriar nova tabela de partição
Já tinha acessado o arquivo fstab do kurumin e feito as modificações necessárias. Acontece que ao tentar dar boot pelo kurumin, está aparecendo uma mensagem com a informação que não encontrou o sistema de arquivo ext3 da partição hdc9. Suponho que algum arquivo que está sendo caregado no boot ainda tenha a informação da partição hdc9 que não existe mais. É isso que está causando erro na inicialização. Eu consigo montar o sistema com o comando chroot. Tem algum comando capaz de limpar as informações referentes aos dispositivos montados no sistema? Já pesquiseu bastante, até tentei encontar a informação hdc9 em alguns arquivos que são carregados no boot, mas até o momento, nada encontrei.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/11/2010, 16:01
Resposta: #4
Re: Erro no boot ao recriar nova tabela de partição
já tentou mudar o grub para carregar o kurumin em modo single? pode ser que esteja no initrd ou seja algum arquivo de script no init.d, mas acho mais provável algo que esteja sendo passado para o kernel. Nos arquivos do grub num tem nenhuma referencia né? que modo está sendo seguido para carregar o kernel, o kernel chamado está no diretório do /boot do ubuntu ou em outra partição?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/11/2010, 04:57
Resposta: #5
Re: Erro no boot ao recriar nova tabela de partição
Já tentei recuperar o grub pelo kurumin. Antes de mostrar a lista dos SO apareceu na tela erro 2.
Fiz o procedimento montando a partição do kurumin no ubuntu com chroot. Depois
find /boot/grub/stage1 root (hd0,5) setup (hd0)
Entrei no arquivo menu.lst para mudar a referencia da partiçao que agora nao era mais (hd0,8).
Carregar em modo single é diferente desse procedimento que estou fazendo?

Não encontrei nehuma refêrencia não. Foi um dos primeiros lugares que procurei esta referência.

No /boot da partição do ubuntu tem apenas os arquivos referente ao sistema ubuntu. No /boot kurumin os arquivos referentes ao kurumin. Na instalação anterior estava assim e iniciava normalmente. Agora quando tento inicializar pelo kurumin ele começa a carregar e depois trava.

Quando eu monto o kurumin no ubuntu e uso o chroot, é possível carregar a lista de repositorio e atulizar. Já o comando fdisk -l não funciona pq o sistema não está complemente montado como eu tivesse dado boot por ele. Será que seria possível criar um novo vmlinuz-2.6.18.1-slh-up-2 ? E um novo initrd.img-2.6.18.1-slh-up-2 ? Tem algum comando capaz de fazer isto?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
20/11/2010, 12:09
Resposta: #6
Re: Erro no boot ao recriar nova tabela de partição
não tentou iniciar pelo modo single?
posta o conteúdo do arquivo menu.lst e o device.map, pode ser que neste ultimo esteja ainda com referencias da antiga partição. esqueça o chroot, o grub do ubuntu lança o kernel do kurumin mudando o root de uma forma diferente do comando chroot.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/11/2010, 08:51
Resposta: #7
Re: Erro no boot ao recriar nova tabela de partição
Tentando pelo modo single aparereceu a seguinte mensagem:

/bin/cat: /sys/block/hdc/dev no file such or directory
/sys/block/hdc/hdc9/dev
mount: special device /dev/hdc9 does not exist


Estou postando aqui o grub.cfg do ubuntu 10.10. Depois que eu criei este tópico, já instalei o ubuntu 10.10 para autlizar o SO e também na tentativa de corrigir o esse problema no boot.

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
set have_grubenv=true
load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
set saved_entry="${prev_saved_entry}"
save_env saved_entry
set prev_saved_entry=
save_env prev_saved_entry
set boot_once=true
fi

function savedefault {
if [ -z "${boot_once}" ]; then
saved_entry="${chosen}"
save_env saved_entry
fi
}

function recordfail {
set recordfail=1
if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
insmod vbe
insmod vga
}

insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set 01d28f60-b22d-4fd2-8195-179fc52f6548
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
load_video
insmod gfxterm
fi
terminal_output gfxterm
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set 01d28f60-b22d-4fd2-8195-179fc52f6548
set locale_dir=($root)/boot/grub/locale
set lang=pt
insmod gettext
if [ "${recordfail}" = 1 ]; then
set timeout=-1
else
set timeout=10
fi
play 480 440 1
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, with Linux 2.6.35-22-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set 01d28f60-b22d-4fd2-8195-179fc52f6548
linux /boot/vmlinuz-2.6.35-22-generic root=/dev/sda5 ro quiet splash
initrd /boot/initrd.img-2.6.35-22-generic
}
menuentry 'Ubuntu, with Linux 2.6.32-25-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set 01d28f60-b22d-4fd2-8195-179fc52f6548
linux /boot/vmlinuz-2.6.32-25-generic root=/dev/sda5 ro quiet splash
initrd /boot/initrd.img-2.6.32-25-generic
}
menuentry 'Ubuntu, with Linux 2.6.32-21-generic' --class ubuntu --class gnu-linux --class gnu --class os {
recordfail
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set 01d28f60-b22d-4fd2-8195-179fc52f6548
linux /boot/vmlinuz-2.6.32-21-generic root=/dev/sda5 ro quiet splash
initrd /boot/initrd.img-2.6.32-21-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set 01d28f60-b22d-4fd2-8195-179fc52f6548
linux16 /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos5)'
search --no-floppy --fs-uuid --set 01d28f60-b22d-4fd2-8195-179fc52f6548
linux16 /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows 7 (loader) (on /dev/sda1)" {
insmod part_msdos
insmod ntfs
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set 548057b880579ef4
chainloader +1
}
menuentry "Kurumin Linux (on /dev/sda6)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos6)'
search --no-floppy --fs-uuid --set b0980adc-97e1-42f8-83d0-49b144e648ff
linux /boot/vmlinuz-2.6.18.1-slh-up-2 ro nomce quiet apm=power-off vga=791 all-generic-ide irqpoll
initrd /boot/initrd.img-2.6.18.1-slh-up-2
}
menuentry "Debian GNU/Linux, kernel 2.6.18.1-slh-up-2 Default (on /dev/sda6)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos6)'
search --no-floppy --fs-uuid --set b0980adc-97e1-42f8-83d0-49b144e648ff
linux /boot/vmlinuz root=/dev/hdc6 ro
}
menuentry "Debian GNU/Linux, kernel 2.6.18.1-slh-up-2 Default (single-user mode) (on /dev/sda6)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos6)'
search --no-floppy --fs-uuid --set b0980adc-97e1-42f8-83d0-49b144e648ff
linux /boot/vmlinuz root=/dev/hdc6 ro single
}
menuentry "Debian GNU/Linux, kernel 2.6.26-2-486 (on /dev/sda6)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos6)'
search --no-floppy --fs-uuid --set b0980adc-97e1-42f8-83d0-49b144e648ff
linux /boot/vmlinuz-2.6.26-2-486 root=/dev/hdc6 ro
initrd /boot/initrd.img-2.6.26-2-486
}
menuentry "Debian GNU/Linux, kernel 2.6.26-2-486 (single-user mode) (on /dev/sda6)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos6)'
search --no-floppy --fs-uuid --set b0980adc-97e1-42f8-83d0-49b144e648ff
linux /boot/vmlinuz-2.6.26-2-486 root=/dev/hdc6 ro single
initrd /boot/initrd.img-2.6.26-2-486
}
menuentry "Debian GNU/Linux, kernel 2.6.18.1-slh-up-2 (on /dev/sda6)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos6)'
search --no-floppy --fs-uuid --set b0980adc-97e1-42f8-83d0-49b144e648ff
linux /boot/vmlinuz-2.6.18.1-slh-up-2 root=/dev/hdc6 ro
initrd /boot/initrd.img-2.6.18.1-slh-up-2
}
menuentry "Debian GNU/Linux, kernel 2.6.18.1-slh-up-2 (single-user mode) (on /dev/sda6)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos6)'
search --no-floppy --fs-uuid --set b0980adc-97e1-42f8-83d0-49b144e648ff
linux /boot/vmlinuz-2.6.18.1-slh-up-2 root=/dev/hdc6 ro single
initrd /boot/initrd.img-2.6.18.1-slh-up-2
}
menuentry "Debian GNU/Linux, kernel memtest86 (on /dev/sda6)" {
insmod part_msdos
insmod ext2
set root='(hd0,msdos6)'
search --no-floppy --fs-uuid --set b0980adc-97e1-42f8-83d0-49b144e648ff
linux /boot/memtest86.bin
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f $prefix/custom.cfg ]; then
source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###


E o device.map está assim:

(fd0) /dev/fd0
(hd0) /dev/sda
(hd1) /dev/sdb
(hd2) /dev/sdd
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/11/2010, 11:37
Resposta: #8
Re: Erro no boot ao recriar nova tabela de partição
agora está utilizando o grub2 num é correto ficar alterando este arquivo grub.cfg. Mas me estranha estar configurado nele root=/dev/hdc6 não tenho a visão da saída do comando fdisk -l para ter certeza mas estaria o kurumin no primeiro hd? no seu device.map consta que vc tem 3 hds é isso mesmo? talvez o correto seria root=/dev/sda6 caso o kurumin está mesmo no primeiro hd.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/11/2010, 15:06
Resposta: #9
Re: Erro no boot ao recriar nova tabela de partição
Tem apenas um HD. O que está resgistrado no device.map é pq usava um Ubuntu live pelo pendrive e depois criei o ubuntu live no meu hd externo. Meu drive de DVD pifou. Instalei o ubuntu 10.10 via USB. Não editei o grub.cfg. Este arquivo foi criado com o comando update-grub.

Quando instalei o kurumin, foi preciso colocar no boot a informação all-generic-ide irqpoll para que meu hd sata fosse reconhecido. Pelo ubuntu a partição onde o kurumin está instalado é idenficado como sda6. Pelo kurumin é identificado como hdc6.

A nomenclatura dos disposivos no kurumin é diferente. Meu HD é hdc. Os dispositivos UBS são identificados como sda, sdb, sdc, ...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/11/2010, 19:57
Resposta: #10
Re: Erro no boot ao recriar nova tabela de partição
bom então tá explicado, o grub.cfg está errado deveria estar com sda6 e o device.map tb deve conter somente o dispositivos fisicos fixos, ou seja fd0 e sda.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
22/11/2010, 19:48
Resposta: #11
Re: Erro no boot ao recriar nova tabela de partição
Neste caso alterei manualmente para sda6 o grub.cfg e comentei as linhas referentes aos HDs que não existem no device.map. Continuou a aparecer a mesma mesagem de erro, postada na minha primeira mensagem. O curioso é que, mesmo usando sda6 ou hdc6, ainda aparece na mensagem de erro uma informação referente ao dispositivo hdc9 da instalação antiga. Acredito que foi a forma como eu fiz o backup do sistema, possa ter provocado este problema. Por exemplo, fiz assim:

cp -a /media/kurumin/* /media/dispositivo_externo

Ou quem sabe este problema tem haver com os scripts de inicialização do kurumin?

Instalei o kurumin pq queria um SO rápido, leve e estável para realizar meus cálculos cientificos com o fortran. Optei por ele pela facilidade de uso e por ser leve e estável,mas já está desatualizado. Reinstala-lo teria que recofigura-lo novamente, e como minha internet é lenta, gastaria varias horas para trocar o repositório etch pelo lenny.

Tenho pouca experiência com linux, mas gostaria de trocar o kurumin pelo debian, já que este SO tem as caracteristicas que procuro, apesar de nunca ter usado. Preciso de uma indcação como fazer um pendrive de boot com o debian a partir de uma imagem iso.

Agradeço enormemente por esse suporte que me tem prestado. Isso nos encoraja de enfrentar os desafios.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
23/11/2010, 10:11
Resposta: #12
Re: Erro no boot ao recriar nova tabela de partição
sim provavelmente a forma que copiou fez com que o initrd ficasse com os caminhos anteriores, vc teria que refazer o initrd, tente comentar a linha do initrd no grub veja se muda algo ou se pelo menos chega no prompt, vc teria que refazer a imagem do initrd. Esse kurumin é o antigo? Eu não tenho certeza de que o mkinitrd vai funcionar e criar um initrd.img correto.
mkinitrd -k -o /boot/initrd.img-<version> <version>

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/11/2010, 07:27
Resposta: #13
Re: Erro no boot ao recriar nova tabela de partição
O bash não reconhece o comando mkinitrd. Utilizo o kurumin 7, que vem por padrão com o repositório de debian etch. Atualizei para o repositório do lenny, seguindo o tutorial do Morimoto.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
24/11/2010, 21:12
Resposta: #14
Re: Erro no boot ao recriar nova tabela de partição
Pesquisei como recriar o initrd e achei este tutorial aqui:

http://kernelbr.codigolivre.org.br/page ... initrd.htm

Até ai tudo bem. Me ajudou a entender como fazer o procedimento como me explicou. Estou esbarrando com o comando mkinitrd. Tentei instalar o initrd-tools conforme indicado no tutorial, mas recebo o aviso de que não tem candidato para instalação. O meu repositório do Kurumin está assim:

deb http://ftp.br.debian.org/debian lenny main contrib non-free
deb http://security.debian.org lenny/updates main contrib
deb http://www.debian-multimedia.org lenny main
deb http://volatile.debian.org/debian-volatile lenny/volatile main
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
25/11/2010, 13:07
Resposta: #15
Re: Erro no boot ao recriar nova tabela de partição
o pacote atual é initramfs-tools

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS