Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Resolucao 1440x900 - Samsung 931bw
30/12/2007, 16:48
Resposta: #1
Resolucao 1440x900 - Samsung 931bw
Galera, peço um super help pq ja quebrei a cabeça e nada. To há dias tentando configurar meu monitor novo. Uso o driver da nvidia.

Placa de Video GeForce MX 440 64MB.

Nao estou consiguindo colocar a resolucao maxima do meu monitor.

Código:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "kbd"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "abnt2"
    Option        "XkbLayout"    "br"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"    "/dev/input/mice"
    Option        "Protocol"    "ImPS/2"
    Option        "ZAxisMapping"    "4 5"
    Option        "Emulate3Buttons"    "true"
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "stylus"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "stylus"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "eraser"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "eraser"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
    Driver        "wacom"
    Identifier    "cursor"
    Option        "Device"    "/dev/input/wacom"
    Option        "Type"    "cursor"
    Option        "ForceDevice"    "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
    Identifier    "nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x]"
    Driver        "nvidia"
    Busid        "PCI:1:0:0"
    Option        "AddARGBVisuals"    "True"
    Option        "AddARGBGLXVisuals"    "True"
    Option        "NoLogo"    "True"
EndSection

Section "Monitor"
    Identifier    "SyncMaster"
    HorizSync       31.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option        "DPMS"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x]"
    Monitor        "SyncMaster"
    Defaultdepth    24
    SubSection "Display"
        Modes        "1440x900"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
  screen "Default Screen"
    Inputdevice    "Generic Keyboard"
    Inputdevice    "Configured Mouse"
    
    # Uncomment if you have a wacom tablet
    #    InputDevice     "stylus"    "SendCoreEvents"
    #    InputDevice     "cursor"    "SendCoreEvents"
    #    InputDevice     "eraser"    "SendCoreEvents"
EndSection
Section "Module"
    Load        "glx"
EndSection
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2007, 17:51
Resposta: #2
 
Está usando o Debian ou algum baseado nele, como o Ubuntu?
No wiki do fórum tem um artigo que ensina como instalar o driver da nvidia:
http://wiki.forumdebian.com.br/index.ph ... _no_Debian

Rode o
Código:
dpkg-reconfigure xserver-xorg
, selecione o driver nv ou nvidia e marque as resoluções que quizer.

[Imagem: debianuseruserbarsp1.png]
[Imagem: gnomeuserqj9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2007, 17:52
Resposta: #3
 
Tópico movido para Ambiente gráfico para melhor organização do fórum.

[Imagem: debianuseruserbarsp1.png]
[Imagem: gnomeuserqj9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2007, 18:38
Resposta: #4
 
Olá, adicione na seção do monitor mais essas duas linhas:
Código:
Section "Monitor"
     DisplaySize 1440 900
     Modeline "1440x900_60.00" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
EndSection

e na subseção do display altere o modes para:
Código:
Subsection "Display"
        Modes "1440x900_60.00"
    EndSubsection
EndSection

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2007, 19:30
Resposta: #5
 
Coloquei mas nao funcionou

Olha o log:
Código:
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce4 MX 440 with AGP8X at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 65536 kBytes
(--) NVIDIA(0): VideoBIOS: 04.18.20.22.06
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 MX 440 with AGP8X at
(--) NVIDIA(0): PCI:1:0:0:
(--) NVIDIA(0): Samsung SyncMaster (CRT-0)
(--) NVIDIA(0): Samsung SyncMaster (CRT-0): 350.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): No valid modes for "1440x900_60.00"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0): "nvidia-auto-select".
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(--) NVIDIA(0): DPI set to (86, 84); computed from "UseEdidDpi" X config
(--) NVIDIA(0): option
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
30/12/2007, 22:48
Resposta: #6
 
ok, o xorg está recusando essa resolução e aguardando um confirmação, então adicione mas essas 3 linhas agora na seção device:
Código:
Section "Device"
    Option "ModeValidation" "NoEdidDFPMaxSizeCheck"
    Option "ModeValidation" "NoDFPNativeResolutionCheck"
    Option "ModeValidation" "NoMaxPClkCheck"
EndSection

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
31/12/2007, 17:32
Resposta: #7
 
Fiz tbm e nao deu certo, o X agora nem inicia.
Assim q eu voltar pro Linux eu posto o log.
Obrigado pela Atenção
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/01/2008, 21:30
Resposta: #8
 
faça um pequeno teste, substitua por nv onde está o driver nvidia:
Código:
Section "Device"
    Identifier    "nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x]"
    Driver        "nv"

creio que isso deve identificar onde está o problema.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
01/01/2008, 22:46
Resposta: #9
 
Fiz, ta ai o log anexado

LOG.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/01/2008, 13:18
Resposta: #10
 
estranho, na log não apresenta nenhuma linha de erro, como fica o monitor, tudo preto ou cai no prompt de terminal?

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
03/01/2008, 21:19
Resposta: #11
 
Fica tudo preto escaneando o Analogico e Digital.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/01/2008, 10:48
Resposta: #12
 
Tente o seguinte então, daquelas 3 linhas adicionadas anteriormente deixe somente a do NoDFPNativeResolutionCheck e na seção Display adicione o viewport:
Código:
Section "Device"
    Option "ModeValidation" "NoDFPNativeResolutionCheck"
EndSection

Código:
Subsection "Display"
        Depth       24
        Modes "1440x900_60.00"
        ViewPort    0 0
    EndSubsection

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/01/2008, 15:32
Resposta: #13
 
Nao aceitou a resolucao novamente

Código:
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Option "ModeValidation" "NoDFPNativeResolutionCheck"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce4 MX 440 with AGP8X at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 65536 kBytes
(--) NVIDIA(0): VideoBIOS: 04.18.20.22.06
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 MX 440 with AGP8X at
(--) NVIDIA(0):     PCI:1:0:0:
(--) NVIDIA(0):     Samsung SyncMaster (CRT-0)
(--) NVIDIA(0): Samsung SyncMaster (CRT-0): 350.0 MHz maximum pixel clock
(II) NVIDIA(0): Mode Validation Overrides for Samsung SyncMaster (CRT-0):
(II) NVIDIA(0):     NoDFPNativeResolutionCheck
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): No valid modes for "1440x900_60.00"; removing.
(WW) NVIDIA(0):
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0):     "nvidia-auto-select".
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(--) NVIDIA(0): DPI set to (86, 84); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:

dmatrix, mto obrigado pela atenção, mesmo q nao de certo lhe sou mto grato.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/01/2008, 21:56
Resposta: #14
 
o que estou achando errado é o xorg estar reconhecendo o monitor como crt, sendo que ele é um lcd:
Assigned Display Device: CRT-0
bom vamos conferir se a linha do modeline está correta, execute na console o cvt:
$ cvt 1440 900
se isso não gerar nada tente com esse:
$ cvt 1440 900 60 -r -v

verifique se a linha do modeline no xorg está batendo com essa gerada pelo cvt.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/01/2008, 12:17
Resposta: #15
 
$cvt 1440 900
Modeline "1440x900_60.00" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync

Coloquei esse e o X nao iniciou, ficou scaneando digital/analogico

$cvt 1440 900 60 -r -v
Modeline "1440x900R" 88.75 1440 1488 1520 1600 900 903 909 926 +hsync -vsync

Nesse o X inciou em 1024x768 e segue abaixo o log:

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Option "AddARGBGLXVisuals" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce4 MX 440 with AGP8X at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 65536 kBytes
(--) NVIDIA(0): VideoBIOS: 04.18.20.22.06
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 MX 440 with AGP8X at
(--) NVIDIA(0): PCI:1:0:0:
(--) NVIDIA(0): Samsung SyncMaster (CRT-0)
(--) NVIDIA(0): Samsung SyncMaster (CRT-0): 350.0 MHz maximum pixel clock
(II) NVIDIA(0): Assigned Display Device: CRT-0
(WW) NVIDIA(0): No valid modes for "1440x900"; removing.
(WW) NVIDIA(0): No valid modes for "1280x1024"; removing.
(WW) NVIDIA(0): No valid modes for "720x400"; removing.
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1024x768"
(II) NVIDIA(0): "832x624"
(II) NVIDIA(0): "800x600"
(II) NVIDIA(0): "640x480"
(II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
(--) NVIDIA(0): DPI set to (86, 84); computed from "UseEdidDpi" X config
(--) NVIDIA(0): option
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS