Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Wifi e VirtualBox pararam de funcionar após atualização.
17/12/2007, 17:15
Resposta: #1
Wifi e VirtualBox pararam de funcionar após atualização.
Colegas,

Após realizar a última atualização do meu Debian 4.0 (Testing)(em uma maquina AMD64) o Wifi e o VirtualBox pararam de funcionar. Fui atrás e descobri que nessa última atualização a versão do Kernel mudou de 2.6.22.2 para 2.6.22.3 .

Analisando os pacotes instalados percebi que os pacotes madwifi-modules-2.6.22.2.amd64 e virtualbox-ose-modules-2.6.22.2.amd64 não estão compatíveis com a última versão do kernel(2.6.22.3), mas tem um grande problema: Não existe a versão 2.6.22.3 dos respectivos pacotes para download.
Como tanto a rede wifi e quanto o virtualbox são coisas bastante importantes para mim, visto que impactam diretamente no meu trabalho, pergunto aos colegas como posso resolver este problema ?

Ob.: Antes de mais nada, eu acabei precipitadamente removendo todos os pacotes da versão 2.6.22.2 do meu Linux, pois não pensava que a atualização deixaria alguns programas sem atualizar.

Aceito sugestões, dicas, conselhos e tudo que puder me ajudar a resolver este problema.

http://www.leandro.inf.br
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/12/2007, 08:34
Resposta: #2
 
Putz Galera,
Se isso é uma coisa comun no Debian, ai eu jogo a toalha. Não posso acreditar que o Debian seja irresponsável desta forma.

Ainda to acreditando que tem alguma coisa errada aqui na minha máquina.

Se alguém tiver alguma dica, por favor me fale.

http://www.leandro.inf.br
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/12/2007, 23:12
Resposta: #3
 
É o seguinte:

Alguns softwares como o virtualbox e o driver proprietário da nvidia, compilam um módulo para o kernel instalado no momento. Quando instala um novo kernel é necessário que esse módulo seja criado para o novo kernel.

No caso do virtualbox, tente fazer a instalação novamente:

Código:
aptitude reinstall virtualbox-ose

Ou baixe o pacote .deb direto do site:

http://www.virtualbox.org/wiki/Downloads

Pode ser que o problema com o modwifi seja a mesma coisa, tente reinstala-lo.

Lembrando que isso não é culpa do Debian ou do Kernel e sim do software utilizado.

[Imagem: debianuseruserbarsp1.png]
[Imagem: gnomeuserqj9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS