Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Atualização Indesejada
18/11/2007, 01:51
Resposta: #1
Atualização Indesejada
E aí pessoal o/

Bom, minha questão deve ser a de muitos quando se trata de pacotes de diferentes versões do nosso SO.

Uso o Etch. Coloquei um repositório do Unstable no sources.list e dei um apt-get upgrade.

Agora tenho vários pacotes com versões avançadas que não desejo, pois são instáveis. Na verdade tem outra coisa:

O repositório que coloquei foi o http://ftp.us.debian.org/debian, ou seja meu sistema tá todo em inglês agora.

Então. Vocês sabem como posso voltar aos meus velhos e bons pacotes do stable (em português)? Precisando de respostas é só falar!

PS.: tenho o nome dos pacotes que foram instalados no momento da atualização.

Pedro Garcia
http://eesl.org
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/11/2007, 16:20
Resposta: #2
Re: Atualização Indesejada
garciaon Escreveu:E aí pessoal o/

Bom, minha questão deve ser a de muitos quando se trata de pacotes de diferentes versões do nosso SO.

Uso o Etch. Coloquei um repositório do Unstable no sources.list e dei um apt-get upgrade.

Agora tenho vários pacotes com versões avançadas que não desejo, pois são instáveis. Na verdade tem outra coisa:

O repositório que coloquei foi o http://ftp.us.debian.org/debian, ou seja meu sistema tá todo em inglês agora.

Então. Vocês sabem como posso voltar aos meus velhos e bons pacotes do stable (em português)? Precisando de respostas é só falar!

PS.: tenho o nome dos pacotes que foram instalados no momento da atualização.

O fato de você tem usado o repositório http://ftp.us.debian.org não está relacionado com o fato do sistema ter ficado em inglês. Você provavelmente removeu o pacote locales ou reconfigurou o mesmo para usar US. Sendo assim, reinstale/reconfigure o pacote locales para que seu locales esteja como pt_BR.

Quando se utiliza mais de uma versão no sources.list é preciso configurar a preferências do apt. Antes de fazer o upgrade você deveria ter colocado no arquivo /etc/apt/apt.conf as linha:
APT::Default-Release "stable";

Pode ser etch também no lugar de stable. Para fazer downgrade dos pacotes você terá que fazer isso e também terá que usar pinagem de pacotes para que o apt de preferência aos pacotes da etch. Dê uma procurada sobre pinagem de pacotes.

Abraço.
Fabiano.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
18/11/2007, 21:39
Resposta: #3
 
Certo, Fabiano! Vou procurar sobre downgrade e pinagem de pacotes sim. Agora, sobre a história do locales, tá estranho. Primeiro, quando eu tentava instalar esse pacote, dizia:

locales: Depends: glibc-2.3.6.ds1-1

Aí adicionei o repositório oficial do Lenny

deb http://ftp.br.debian.org/debian/ lenny main contrib non-free

e instalei o locales. Eis a saída que obtive desde o apt-get:

debian:/home/pedro# apt-get install locales
Reading package lists... Done
Building dependency tree... Done
The following NEW packages will be installed:
locales
0 upgraded, 1 newly installed, 0 to remove and 890 not upgraded.
Need to get 4397kB of archives.
After unpacking 11.6MB of additional disk space will be used.
Get:1 http://ftp.br.debian.org lenny/main locales 2.6.1-1 [4397kB]
Fetched 4397kB in 1m45s (41.7kB/s)
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "pt_BRLinguat:en",
LC_ALL = (unset),
LANG = "pt_BR.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
W: Couldn't stat source package list http://www.debian-multimedia.org etch/non-free Packages (/var/lib/apt/lists/www.debian-multimedia.org_dists_etch_non-free_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list http://www.debian-multimedia.org etch/contrib Packages (/var/lib/apt/lists/www.debian-multimedia.org_dists_etch_contrib_binary-i386_Packages) - stat (2 No such file or directory)
Preconfiguring packages ...
Selecting previously deselected package locales.
(Reading database ... 134069 files and directories currently installed.)
Unpacking locales (from .../locales_2.6.1-1_all.deb) ...
Setting up locales (2.6.1-1) ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "pt_BRLinguat:en",
LC_ALL = (unset),
LANG = "pt_BR.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "pt_BRLinguat:en",
LC_ALL = (unset),
LANG = "pt_BR.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").


Porque será que tá dando esse monte de erros?

Abraço e valeu pela ajuda! =)

Pedro Garcia
http://eesl.org
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/11/2007, 10:11
Resposta: #4
 
Então, você está tendo estes problemas porque seu sistema está misto. Isso deixa o sistema mais instável do que se usa-se a unstable pura. Tente não misturar as versões ou vai continuar tendo dores de cabeça. Reconfigure o pacote locales usando o comando dpkg-reconfigure locales.

Você precisa deixar seu sistema numa única versão.

Abraço.
Fabiano.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/11/2007, 10:44
Resposta: #5
 
Perfeito, cara. O locales funcionou direitinho! Agora deixe-me explicar para quem tiver dúvidas com isso como resolvi o problema da diferença de versões.

No meu caso, o que eu queria era voltar meu Debian todo para etch (stable). Então criei o arquivo /etc/apt/preferences com o segunite conteúdo:

Código:
Package: *
Pin: release a=stable
Pin-Priority: 1001

Package: *
Pin: release a=testing
Pin-Priority: 60

Package: *
Pin: release a=unstable
Pin-Priority: 50

Isso é chamado pinagem. Você decide a prioridade dos pacotes de cada versão. Então stable tem prioridade sobre a testing, que tem vantagem sobre a unstable (1001 > 60 > 50).

Como eu queria forçar um downgrade dos meus pacotes, o pin-priority da stable tinha que ser maior que 1000, que é o limite para ele deixar de baixar a versão mais recente e fazer mesmo o downgrade forçadamente.

Após isso, basta dar um "apt-get upgrade" e seu sistema vai voltar a ficar redondinho como stable! É claro que podem ocorrer erros. No meu caso não deu nenhum mas durante minha pesquisa soube de gente que teve (e as soluções para eles estava lá também =).

Se der problema com você, dê uma procurada por "downgrade debian" no Google que tem muito material sobre o assunto!

Por fim, agradeço ao Fabiano por ter me ajudado nessa. Valeu, cara! =P

Abraços a todos,

Pedro Garcia
http://eesl.org
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
19/11/2007, 22:33
Resposta: #6
 
Opá!!! Piscada É isso ai mesmo! Perfeito.

Abraço.
Fabiano.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/11/2007, 22:02
Resposta: #7
 
Tudo bem ,amigo!!!Olha se servir de dica: Evite com todas as suas forças fazer o upgrade com repositorios testing e unstable...rsss eu aprendi na pratica a merda que deu aqui na empresa no meu micro e depois em casa...rsss tipo assim hoje em dia só habilito estes repositórios para instalar um programa ou outro e ja era, desabilito novamente. Abraços aí e boa sorte com seu Debian, o meu em casa agora anda redondo, agora o do trampooo....rssss

Open your mind and use linux
^>^

The evolution can't be stopped...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
21/11/2007, 22:07
Resposta: #8
 
Claro, claro, shiryu! Agora aprendia lição haha Abraço!

Pedro Garcia
http://eesl.org
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS