Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Problemas com JAVA ! RESOLVIDO
06/11/2007, 10:24
Resposta: #1
Problemas com JAVA ! RESOLVIDO
Bom dia !

Uso o jSMS para enviar torpedos para celulares porém de uns dias pra cá não consigo rodar mais o programa. Quando digito jsms no terminal aparece:

[email protected]:~$ jsms
Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
at java.awt.Toolkit.getDefaultToolkit(libgcj.so.81)
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(libgcj.so.81)
at java.awt.Window.<init>(libgcj.so.81)
at java.awt.Frame.<init>(libgcj.so.81)
at java.awt.Frame.<init>(libgcj.so.81)
at javax.swing.SwingUtilities$OwnerFrame.<init>(libgcj.so.81)
at javax.swing.SwingUtilities$OwnerFrame.<init>(libgcj.so.81)
at javax.swing.SwingUtilities.getOwnerFrame(libgcj.so.81)
at javax.swing.JDialog.<init>(libgcj.so.81)
at jSMS.gui.SplashScreen.<init>(SplashScreen.java)
at jSMS.JSMS.main(JSMS.java)
Caused by: java.lang.UnsatisfiedLinkError: libgtkpeer: libgtkpeer.so: cannot open shared object file: Arquivo ou diretório não encontrado
at java.lang.Runtime._load(libgcj.so.81)
at java.lang.Runtime.loadLibrary(libgcj.so.81)
at java.lang.System.loadLibrary(libgcj.so.81)
at gnu.java.awt.peer.gtk.GtkToolkit.<clinit>(libgcj.so.81)
at java.lang.Class.initializeClass(libgcj.so.81)
at java.lang.Class.forName(libgcj.so.81)
at java.awt.Toolkit.getDefaultToolkit(libgcj.so.81)
...10 more


Alguém tem idéia do que pode ser ?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
08/11/2007, 22:32
Resposta: #2
 
instale o pacote libsablevm-native1, de depois veja se ainda não funciona:
# aptitude install libsablevm-native1

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/11/2007, 06:22
Resposta: #3
 
Obrigado pela ajuda mas continua o mesmo erro ! Alguma sugestão quanto a outro programa de torpedo para celulares ?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
09/11/2007, 15:23
Resposta: #4
 
então...deve estar pegando um versão antiga do java ou uma versão mais nova não está instalado, verifique isso com os comandos abaixo, aqui vou postar com o java6:
# aptitude update
# aptitude install sun-java6-source
verificando o caminho do java se está certo:
# which java
/usr/bin/java

$ ls -l /usr/bin/java
lrwxrwxrwx 1 root root 22 2007-01-24 16:53 /usr/bin/java -> /etc/alternatives/java
$ ls -l /etc/alternatives/java
lrwxrwxrwx 1 root root 32 2007-11-09 15:58 /etc/alternatives/java -> /usr/lib/jvm/java-6-sun/bin/java
$ ls -l /usr/lib/jvm/
total 16
drwxr-xr-x 5 root root 4096 2007-03-21 10:34 java-1.4.2-gcj-4.1-1.4.2.0
lrwxrwxrwx 1 root root 23 2007-11-06 14:39 java-1.5.0-sun -> java-1.5.0-sun-1.5.0.13
drwxr-xr-x 3 root root 4096 2007-11-06 14:40 java-1.5.0-sun-1.5.0.10
drwxr-xr-x 10 root root 4096 2007-11-06 14:39 java-1.5.0-sun-1.5.0.13
lrwxrwxrwx 1 root root 19 2007-11-09 15:45 java-6-sun -> java-6-sun-1.6.0.00
drwxr-xr-x 8 root root 4096 2007-11-09 15:53 java-6-sun-1.6.0.00
lrwxrwxrwx 1 root root 26 2007-03-21 10:34 java-gcj -> java-1.4.2-gcj-4.1-1.4.2.0

se algum link simbolico estiver errado é só remove-lo e criar um novo, por exemplo se o link em /etc/alternatives
# cd /etc/alternatives
# rm java
# ln -s /usr/lib/jvm/java-6-sun/bin/java java

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
11/11/2007, 11:55
Resposta: #5
 
Muito obrigado, o erro foi no link do /etc/alternatives/ corrigi o link e voltou a funcionar. Mas como você sabia destes links todos ?
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS