Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Apt-get dando erro depois de instalar driver da nVidia
14/10/2007, 00:27
Resposta: #1
Apt-get dando erro depois de instalar driver da nVidia
olá

é o seguinte depois que eu segui os procedimentos desse link pra instalar os drivers da nvidia http://wiki.forumdebian.com.br/index.php..._no_Debian, quando eu executo a apt-get, ele sempre retorna esse erro:

Código:
debian:/home/lucianoshl# apt-get install libwine-cms
Lendo lista de pacotes... Pronto
Construindo árvore de dependências... Pronto
Os NOVOS pacotes a seguir serão instalados:
  libwine-cms
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 46 não atualizados.
1 pacotes não totalmente instalados ou removidos.
É preciso fazer o download de 427kB de arquivos.
Depois de desempacotar, 573kB adicionais de espaço em disco serão usados.
Obtendo:1 ftp://ftp.br.debian.org etch/main libwine-cms 0.9.25-2.1 [427kB]
Baixados 427kB em 11s (37,7kB/s)
Selecionando pacote previamente não selecionado libwine-cms.
(Lendo banco de dados ... 82025 arquivos e diretórios atualmente instalados.)
Descompactando libwine-cms (de .../libwine-cms_0.9.25-2.1_i386.deb) ...
Instalando cpad-kernel-source (0.10-3) ...
/var/lib/dpkg/info/cpad-kernel-source.postinst: line 49: [: too many arguments
Warning: kernel headers don't match running Linux version.
Building cpad module for Linux _CODE 13262 (this may take a few minutes)...dpkg: erro processando cpad-kernel-source (--configure):
subprocesso post-installation script retornou código de saída de error 2
Instalando libwine-cms (0.9.25-2.1) ...
Erros foram encontrados durante processamento de:
cpad-kernel-source
E: Sub-process /usr/bin/dpkg returned an error code (1)
debian:/home/lucianoshl#

os pacotes que eu mando instalar são instalados perfeitamente mas eu queria saber como tirar esse erro ai, se algum poder ajudar com alguma sugestão ai eu agradeço

até mais e obrigado
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/10/2007, 09:03
Resposta: #2
 
tente o seguinte, edite o arquivo /var/lib/dpkg/status localize a linha onde está escrito: Package: cpad-kernel-source e logo abaixo altere o status do pacote cpad-kernel-source para purge ok not-installed
salve e feche e tente novamente instalar o pacote.
# apt-get install cpad-kernel-source

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/10/2007, 13:25
Resposta: #3
 
bem fiz essa edição

Código:
Package: cpad-kernel-source
Status: purge ok not-installed
Priority: optional
Section: devel
Installed-Size: 312
Maintainer: Ron Lee <[email protected]>
Architecture: all

rodei o comando mas continua com erros


Código:
debian:/home/lucianoshl# apt-get install cpad-kernel-source
Lendo lista de pacotes... Pronto
Construindo árvore de dependências... Pronto
Os NOVOS pacotes a seguir serão instalados:
  cpad-kernel-source
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso fazer o download de 0B/68,2kB de arquivos.
Depois de desempacotar, 319kB adicionais de espaço em disco serão usados.
Pré-configurando pacotes ...
Selecionando pacote previamente não selecionado cpad-kernel-source.
(Lendo banco de dados ... 82774 arquivos e diretórios atualmente instalados.)
Descompactando cpad-kernel-source (de .../cpad-kernel-source_0.10-3_all.deb) ...
Instalando cpad-kernel-source (0.10-3) ...
/var/lib/dpkg/info/cpad-kernel-source.postinst: line 49: [: too many arguments
Warning: kernel headers don't match running Linux version.
Building cpad module for Linux _CODE 13262 (this may take a few minutes)...dpkg: erro processando cpad-kernel-source (--configure):
subprocesso post-installation script retornou código de saída de error 2
Erros foram encontrados durante processamento de:
cpad-kernel-source
E: Sub-process /usr/bin/dpkg returned an error code (1)
debian:/home/lucianoshl#

depois de executar o comando o arquivo /var/lib/dpkg/status voltou como estava, decidi fazer otro teste então eu o reeditei como vc disse, mas não usei o comando pra instalar o cpad-kernel-source, o a apt-get aparetimente não mostrou erros

Código:
debian:/home/lucianoshl# apt-get install wine
Lendo lista de pacotes... Pronto
Construindo árvore de dependências... Pronto
wine já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
debian:/home/lucianoshl#

há necessidade de instalar esse pacote para funcionar corretamente os drivers do nVidia?pois o erro com essa pacote começou depois de instalar os driver

falou e obrigado
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
14/10/2007, 22:24
Resposta: #4
 
o que fez tb tá meio certo pois o que estavamos tentando fazer é reinstalar ou instalar esse pacote o qual tem um problema de final de instalaçao. No caso ele já está instalado. O que poderia fazer tb seria apagar esse arquivo que está com problemas /var/lib/dpkg/info/cpad-kernel-source.postinst e efetuar a reinstalaçao. Não sei dizer se esse pacote é dependencia do nvidia.

"Na caixa dizia: Requer MS Windows ou superior, então eu instalei Debian/GNU
Linux!"

.
Antes de postar use a busca e veja o Wiki.
Busca do FD
Wiki do FD
Visitar o website do usuário Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
15/10/2007, 17:25
Resposta: #5
 
perfeito isso resolveu meu problema,
valeuu amigo
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS