Responder 
 
Avaliação do Tópico:
  • 0 Votos - 0 Média
  • 1
  • 2
  • 3
  • 4
  • 5
Ajuda com FGLRX + ATI X700
04/10/2007, 00:23
Resposta: #1
Ajuda com FGLRX + ATI X700
Bem em primeiro lugar vou explicar porque quero FGLRX:

Os drivers "radeon" e "ati" tem desempenho sofrível nessa placa X700 e na resolução recomendada pelo fabricante do monitor fica tudo bugado. Além disso o desempenho com FGLRX no Compiz Fusion é mil vezes melhor do que com os drivers abertos.

Agora o problema com o FGLRX:

Quando eu saio do modo gráfico com Ctrl+Alt+F1 (ou F2, F3...) eu entro numa boa no modo texto. Porém ao tentar retornar no modo gráfico com Alt+F7 o computador trava. Isso tem ocorrido no Kurumin, Debian e Ubuntu. Acredito que eu deva fazer alguma alteração no xorg.conf para sanar esse problema, mas não sei o quê.
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
04/10/2007, 21:35
Resposta: #2
 
Como fez a instalação do driver fglrx?
Quando a interface trava, o compiz está ativo?

[Imagem: debianuseruserbarsp1.png]
[Imagem: gnomeuserqj9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/10/2007, 01:01
Resposta: #3
 
Oi elias obrigado por responder.

Primeiro corrigindo um equívoco: eu ainda não tinha testado no Debian.Testei no UbuntuStudio e no Kurumin. O Debian agora é um caso a parte. Talvez comessa do Debian venha a resposta. Vou explicar como foi a experiencia em cada caso.

*Kurumin7: instalei tanto o XGL quanto o FGLRX pelos scripts que vem nele. Aceleração excelente, mas ao ir no console em texto e depois tentar retornar ao modo gráfico deu crash. Já mandei o Kurumin pro espaço...

*UbuntuStudio: instalei pelo menu dele mesmo com uma opção que se não me engano chama-se "gerenciamento de drivers proprietários" ou algo parecido (quando eu sair do Debian e entrar no UbuntuStudio eu vejo melhor). Mesmo esquema do crash no Kurumin.

*Debian: Instalei o FGLRX seguindo esse excelente tutorial:
http://www.linuxquestions.org/questions ... ?p=2753626
Fazendo algumas adaptações (ex: troquei o parâmetro "Ubuntu/feisty" por "Debian/etch").
O problema do Debian é que ainda não consegui rodar uma sessão de XGL. Não acho um tutorial decente para Gnome+XGL+Debian. Só achei pro KDE...Ao tentar rodar o XGL dá erro de fontes mensagem de "fontes não encontradas" e "não conseguir estabelecer uma fonte default".
Instalei o XGL por esse tutorial e deu errado: http://linuxangra.blogspot.com/2007/07/ ... buntu.html

Curiosamente testei os comandos Crtrl+Alt+F1 e depois Alt+F7 e não deu erro. Será que o problema do travamento está no XGL ou na forma "fácil e automática" que o Ubuntu e o Kurumin instalaram o driver ? Vou testar os comandos numa sessão normal do Gnome no UbuntuStudio sem XGL e já posto o resultado...

Update: Testei no UbuntuStidio sem XGL e travou ao sair e retornar no X. Ou seja era o driver que o Ubuntu instala automaticamente que trava tudo. Desinstalei o driver no UbuntuStudio e reinstalei da mesma forma que fiz no Debian e o bug do travamento parou. Porém ao abrir uma sessão no XGL a tela fica toda embaralhada...
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
05/10/2007, 10:37
Resposta: #4
 
É complicado, eu tinha uma ATI 9600 e foi um parto para rodar o FGLRX, XGL e compiz.
Para instalar eu usei esses tutoriais:

http://sonique54.free.fr/xgl/xgl.htm
http://www5.autistici.org/debian-xgl/
http://wiki.debian.org/Xgl

[Imagem: debianuseruserbarsp1.png]
[Imagem: gnomeuserqj9.jpg]
Encontrar todas as respostas deste usuário
Citar esta mensagem em uma resposta
Responder 


Ir ao Fórum:


Usuários visualizando este tópico: 1 Visitantes

Entre em Contato | Fórum Debian | Voltar ao Topo | Voltar ao Conteúdo | Modo Leve (Arquivo) | Feeds RSS